Error loading module '/usr/lib/x86_64-linux-gnu/samba//vfs/acl_xattr.so': /usr/lib/x86_64-linux-gnu/samba//vfs/acl_xattr.so: cannot open shared object file: No such file or directory

Bug #1091348 reported by Bruno Bigras on 2012-12-17
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
samba4 (Debian)
Fix Released
Unknown
samba4 (Ubuntu)
Undecided
Unassigned

Bug Description

When installing samba 4 on 13.04, I got :

Error loading module '/usr/lib/x86_64-linux-gnu/samba//vfs/acl_xattr.so': /usr/lib/x86_64-linux-gnu/samba//vfs/acl_xattr.so: cannot open shared object file: No such file or directory

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: samba4 4.0.0+dfsg1-1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
Date: Mon Dec 17 11:58:26 2012
InstallationDate: Installed on 2012-12-17 (0 days ago)
InstallationMedia: Ubuntu-Server 13.04 "Raring Ringtail" - Alpha amd64 (20121217)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=fr_CA:fr
 TERM=screen
 PATH=(custom, no user)
 LANG=fr_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: samba4
UpgradeStatus: No upgrade log present (probably fresh install)

Bruno Bigras (brunoqc) wrote :
Bruno Bigras (brunoqc) wrote :

Here's the term.log I got when running :

bbigras@ubuntu-raring:~$ sudo apt-get install samba4
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  bind9 bind9utils ldb-tools libdcerpc-server0 libdcerpc0 libgensec0 libhdb9-heimdal libkdc2-heimdal libldb1 libndr-standard0 libndr0
  libregistry0 libsamba-credentials0 libsamba-hostconfig0 libsamba-policy0 libsamba-util0 libsamdb0 libsmbclient-raw0 libtalloc2 libtdb1
  libtevent0 libwbclient0 python-ldb python-samba python-talloc python-tdb samba-common samba-common-bin samba-dsdb-modules samba4-common-bin
  tdb-tools
Suggested packages:
  bind9-doc phpldapadmin samba-gtk swat2 ntp
The following NEW packages will be installed:
  bind9 bind9utils ldb-tools libdcerpc-server0 libdcerpc0 libgensec0 libhdb9-heimdal libkdc2-heimdal libldb1 libndr-standard0 libndr0
  libregistry0 libsamba-credentials0 libsamba-hostconfig0 libsamba-policy0 libsamba-util0 libsamdb0 libsmbclient-raw0 libtalloc2 libtdb1
  libtevent0 libwbclient0 python-ldb python-samba python-talloc python-tdb samba-common samba-common-bin samba-dsdb-modules samba4
  samba4-common-bin tdb-tools
0 upgraded, 32 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/13.9 MB of archives.
After this operation, 59.1 MB of additional disk space will be used.
Do you want to continue [Y/n]?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba4 (Ubuntu):
status: New → Confirmed
Changed in samba4 (Debian):
status: Unknown → Confirmed
Thomas Hood (jdthood) on 2013-01-24
Changed in samba4 (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Thomas Hood (jdthood) wrote :
Nick Semenkovich (semenko) wrote :

I also had this issue, though only after removing samba4 (aptitude purge samba4) and reinstalling, due to bug #1096791

The same error appears 20 or so times during the install, although samba4 appears to be running:

Error loading module '/usr/lib/x86_64-linux-gnu/samba//vfs/acl_xattr.so': /usr/lib/x86_64-linux-gnu/samba//vfs/acl_xattr.so: cannot open shared object file: No such file or directory
error probing vfs module 'acl_xattr': NT_STATUS_UNSUCCESSFUL

Changed in samba4 (Debian):
status: Confirmed → Fix Released
Andy Igoshin (andy-igoshin) wrote :
Download full text (15.5 KiB)

the same for 13.10

---------------------------------------------------------------------------------------------------------

# aptitude install samba4
The following NEW packages will be installed:
  attr{a} bind9{a} bind9utils{a} ldb-tools{a} libdcerpc-server0{a} libdcerpc0{a} libgensec0{a} libregistry0{a}
  libsamba-credentials0{a} libsamba-policy0{a} libsamdb0{a} libsmbclient-raw0{a} python-ldb{a} python-samba{a} python-talloc{a}
  python-tdb{a} samba-dsdb-modules{a} samba4 samba4-common-bin{a} tdb-tools{a}
0 packages upgraded, 20 newly installed, 0 to remove and 0 not upgraded.
Need to get 7 723 kB of archives. After unpacking 32,4 MB will be used.
Do you want to continue? [Y/n/?]
Get: 1 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libsamba-credentials0 amd64 4.0.3+dfsg1-0.1ubuntu1 [29,6 kB]
Get: 2 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libsamdb0 amd64 4.0.3+dfsg1-0.1ubuntu1 [146 kB]
Get: 3 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libgensec0 amd64 4.0.3+dfsg1-0.1ubuntu1 [288 kB]
Get: 4 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libsmbclient-raw0 amd64 4.0.3+dfsg1-0.1ubuntu1 [560 kB]
Get: 5 http://ru.archive.ubuntu.com/ubuntu/ saucy/main python-talloc amd64 2.0.8-0.1 [7 370 B]
Get: 6 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libdcerpc0 amd64 4.0.3+dfsg1-0.1ubuntu1 [500 kB]
Get: 7 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libregistry0 amd64 4.0.3+dfsg1-0.1ubuntu1 [59,5 kB]
Get: 8 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libdcerpc-server0 amd64 4.0.3+dfsg1-0.1ubuntu1 [333 kB]
Get: 9 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe libsamba-policy0 amd64 4.0.3+dfsg1-0.1ubuntu1 [24,9 kB]
Get: 10 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe python-ldb amd64 1:1.1.15-1.1 [33,2 kB]
Get: 11 http://ru.archive.ubuntu.com/ubuntu/ saucy/main python-tdb amd64 1.2.11-2.1 [11,3 kB]
Get: 12 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe python-samba amd64 4.0.3+dfsg1-0.1ubuntu1 [3 017 kB]
Get: 13 http://ru.archive.ubuntu.com/ubuntu/ saucy/main attr amd64 1:2.4.47-1 [29,5 kB]
Get: 14 http://ru.archive.ubuntu.com/ubuntu/ saucy/main bind9utils amd64 1:9.9.3.dfsg.P2-4ubuntu1 [244 kB]
Get: 15 http://ru.archive.ubuntu.com/ubuntu/ saucy/main bind9 amd64 1:9.9.3.dfsg.P2-4ubuntu1 [336 kB]
Get: 16 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe ldb-tools amd64 1:1.1.15-1.1 [35,8 kB]
Get: 17 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe samba-dsdb-modules amd64 4.0.3+dfsg1-0.1ubuntu1 [323 kB]
Get: 18 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe samba4-common-bin amd64 4.0.3+dfsg1-0.1ubuntu1 [29,9 kB]
Get: 19 http://ru.archive.ubuntu.com/ubuntu/ saucy/main tdb-tools amd64 1.2.11-2.1 [23,1 kB]
Get: 20 http://ru.archive.ubuntu.com/ubuntu/ saucy/universe samba4 amd64 4.0.3+dfsg1-0.1ubuntu1 [1 691 kB]
Fetched 7 723 kB in 1s (5 386 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libsamba-credentials0:amd64.
(Reading database ... 286887 files and directories currently installed.)
Unpacking libsamba-credentials0:amd64 (from .../libsamba-credentials0_4.0.3+dfsg1-0.1ubuntu1_amd64.deb) ...
Selecting previously unselected package libsamdb0:amd64....

KAMI (kami911) wrote :

Installing:
apt-get install samba-vfs-modules
solved this problem for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.