gvfsd-smb-browse crashed with SIGSEGV in debug_lookup_classname_int()

Bug #911888 reported by CGraham on 2012-01-04
112
This bug affects 11 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
High
Chuck Short
Precise
High
Chuck Short

Bug Description

gvfsd-smb-browse crashed with SIGSEGV in debug_add_class()

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gvfs-backends 1.10.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic-pae 3.2.0-rc7
Uname: Linux 3.2.0-7-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Wed Jan 4 12:37:23 2012
ExecutablePath: /usr/lib/gvfs/gvfsd-smb-browse
InstallationMedia: Xubuntu 12.04 "Precise Pangolin" - Alpha i386 (20111129.2)
ProcCmdline: /usr/lib/gvfs/gvfsd-smb-browse --spawner :1.9 /org/gtk/gvfs/exec_spaw/2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb72913ef: mov (%edx,%esi,4),%eax
 PC (0xb72913ef) ok
 source "(%edx,%esi,4)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 debug_add_class () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 ?? () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 setup_logging () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 ?? () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
Title: gvfsd-smb-browse crashed with SIGSEGV in debug_add_class()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

CGraham (cgraham10) wrote :

StacktraceTop:
 debug_lookup_classname_int (classname=0xb76f8bbc "all") at ../lib/util/debug.c:243
 debug_add_class (classname=0xb76f8bbc "all") at ../lib/util/debug.c:266
 debug_init () at ../lib/util/debug.c:438
 debug_init () at ../lib/util/debug.c:426
 setup_logging (prog_name=0xb76456a5 "libsmbclient", new_logtype=DEBUG_STDOUT) at ../lib/util/debug.c:466

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
summary: - gvfsd-smb-browse crashed with SIGSEGV in debug_add_class()
+ gvfsd-smb-browse crashed with SIGSEGV in debug_lookup_classname_int()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, the issue is a libsmbclient one it seems, reassigning the bug

visibility: private → public
affects: gvfs (Ubuntu) → samba (Ubuntu)
Changed in samba (Ubuntu):
importance: Medium → High
Changed in samba (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
tags: added: bugpattern-needed
Changed in samba (Ubuntu Precise):
milestone: none → precise-alpha-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.6.1-3ubuntu3

---------------
samba (2:3.6.1-3ubuntu3) precise; urgency=low

  * debian/patches/fix-samba-printer-browsing.patch:
    Fix samba printer browsing crasher. (LP: #911888)
 -- Chuck Short <email address hidden> Mon, 23 Jan 2012 10:47:41 -0500

Changed in samba (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers