system-config-printer.py crashed with SIGSEGV in debug_lookup_classname_int()

Bug #911642 reported by mike stein on 2012-01-04
78
This bug affects 7 people
Affects Status Importance Assigned to Milestone
samba (Fedora)
Fix Released
High
samba (Ubuntu)
Medium
Unassigned

Bug Description

Setting up printer

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: system-config-printer-gnome 1.3.6+20110831-0ubuntu11
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Tue Jan 3 23:29:28 2012
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111212)
InterpreterPath: /usr/bin/python2.7
Lpstat: Error: command ['lpstat', '-v'] failed with exit code 1: lpstat: No destinations added.
MachineType: Dell Inc. MM061
PackageArchitecture: all
Papersize: letter
ProcCmdline: /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-7-generic root=UUID=d8d3ce2b-1d89-41a7-8b9d-5261eb0c143c ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x1bbe3ef: mov (%edx,%esi,4),%eax
 PC (0x01bbe3ef) ok
 source "(%edx,%esi,4)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: system-config-printer
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 debug_add_class () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 ?? () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 setup_logging () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
 ?? () from /usr/lib/i386-linux-gnu/libsmbclient.so.0
Title: system-config-printer.py crashed with SIGSEGV in debug_add_class()
UpgradeStatus: Upgraded to precise on 2011-12-29 (6 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 06/13/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.name: 0XD720
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd06/13/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0XD720:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.

StacktraceTop:
 debug_lookup_classname_int (classname=0x2025bbc "all") at ../lib/util/debug.c:243
 debug_add_class (classname=0x2025bbc "all") at ../lib/util/debug.c:266
 debug_init () at ../lib/util/debug.c:438
 debug_init () at ../lib/util/debug.c:426
 setup_logging (prog_name=0x1f726a5 "libsmbclient", new_logtype=DEBUG_STDOUT) at ../lib/util/debug.c:466

Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
summary: - system-config-printer.py crashed with SIGSEGV in debug_add_class()
+ system-config-printer.py crashed with SIGSEGV in
+ debug_lookup_classname_int()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed
visibility: private → public
Till Kamppeter (till-kamppeter) wrote :

Moving to samba, as the suggested patch fixes a bug in the Samba code.

affects: system-config-printer (Ubuntu) → samba (Ubuntu)
Changed in samba (Ubuntu):
status: Confirmed → Triaged
Andy Braben (abraben) wrote :

A Samba update on 30/1/12 has resolved this bug.

Changed in samba (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.