package samba 2:3.5.8~dfsg-1ubuntu2.3 failed to install/upgrade: ErrorMessage: package samba is not ready for configuration cannot configure (current status `half-installed')

Bug #863700 reported by Murz on 2011-09-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Low
Unassigned

Bug Description

I have normally working samba package in natty, but on upgrade to oneric I got the errors.

After upgrade is broken, "dpkg --configure -a" shows all ok.
I solve the problem via
aptitude install kubuntu-desktop:
$ sudo aptitude install kubuntu-desktop
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
  samba: Depends: samba-common (= 2:3.5.8~dfsg-1ubuntu2.3) but 2:3.5.11~dfsg-1ubuntu1 is installed.
         Depends: libwbclient0 (= 2:3.5.8~dfsg-1ubuntu2.3) but 2:3.5.11~dfsg-1ubuntu1 is installed.
open: 46; closed: 1890; defer: 10; conflict: 17 OE: I wasn't able to locate a file for the samba package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

The following NEW packages will be installed:
  qdbus{a}
The following packages will be REMOVED:
  ia32-libs-multiarch{a} libacl1{a} libatk1.0-0{a} libattr1{a} libaudio2{a} libavahi-client3{a} libavahi-common3{a} libc6{a} libcairo2{a} libcomerr2{a} libcups2{a} libcupsimage2{a} libcurl3{a} libdatrie1{a} libdb5.1{a} libdbus-1-3{a} libdrm-nouveau1a{a}
  libdrm-radeon1{a} libdrm2{a} libexpat1{a} libffi6{a} libfontconfig1{a} libfreetype6{a} libgcc1{a} libgcrypt11{a} libgdbm3{a} libgdk-pixbuf2.0-0{a} libgl1-mesa-glx{a} libglapi-mesa{a} libglib2.0-0{a} libgnutls26{a} libgpg-error0{a} libgssapi-krb5-2{a}
  libgtk2.0-0{a} libice6{a} libidn11{a} libjasper1{a} libjpeg62{a} libk5crypto3{a} libkeyutils1{a} libkrb5-3{a} libkrb5support0{a} liblcms1{a} libldap-2.4-2{a} libllvm2.9{a} libmng1{a} libnspr4{a} libnss3{a} libpango1.0-0{a} libpcre3{a} libpixman-1-0{a}
  libpng12-0{a} libqt4-dbus{a} libqt4-declarative{a} libqt4-designer{a} libqt4-network{a} libqt4-opengl{a} libqt4-qt3support{a} libqt4-script{a} libqt4-scripttools{a} libqt4-sql{a} libqt4-svg{a} libqt4-test{a} libqt4-xml{a} libqt4-xmlpatterns{a} libqtcore4{a}
  libqtgui4{a} librtmp0{a} libsasl2-2{a} libsasl2-modules{a} libselinux1{a} libsm6{a} libsqlite3-0{a} libssl1.0.0{a} libstdc++6{a} libtasn1-3{a} libthai0{a} libtiff4{a} libuuid1{a} libx11-6{a} libxau6{a} libxcb-render0{a} libxcb-shm0{a} libxcb1{a} libxcomposite1{a}
  libxcursor1{a} libxdamage1{a} libxdmcp6{a} libxext6{a} libxfixes3{a} libxft2{a} libxi6{a} libxinerama1{a} libxrandr2{a} libxrender1{a} libxss1{a} libxt6{a} libxxf86vm1{a} nspluginviewer{a} nspluginwrapper{a} qdbus{a} zlib1g{a}
The following packages will be upgraded:
  samba
1 packages upgraded, 1 newly installed, 102 to remove and 4 not upgraded.
Need to get 27.8 kB/8,105 kB of archives. After unpacking 124 MB will be freed.
Do you want to continue? [Y/n/?] Y

after that, samba is installed normally

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: samba 2:3.5.8~dfsg-1ubuntu2.3
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sat Oct 1 00:38:29 2011
ErrorMessage: ErrorMessage: package samba is not ready for configuration cannot configure (current status `half-installed')
NmbdLog:

OtherFailedConnect: Yes
SambaServerRegression: Yes
SmbConfIncluded: Yes
SmbLog:

SourcePackage: samba
Title: package samba 2:3.5.8~dfsg-1ubuntu2.3 failed to install/upgrade: ErrorMessage: package samba is not ready for configuration cannot configure (current status `half-installed')
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (0 days ago)

Murz (murznn) wrote :
Robie Basak (racb) wrote :

From VarLogDistupgradeApttermlog.gz:

Unpacking replacement samba ...

GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 129.

debconf: unable to initialize frontend: Gnome

debconf: (Couldn't recognize the image file format for file '/usr/share/pixmaps/ubuntu-logo.png' at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 129.)

debconf: falling back to frontend: Dialog

Can't locate File/Temp.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/DebianNet.pm line 18.

BEGIN failed--compilation aborted at /usr/share/perl5/DebianNet.pm line 18.

Compilation failed in require at /usr/sbin/update-inetd line 23.

dpkg: warning: subprocess old post-removal script returned error exit status 2

File/Temp.pm is provided by perl-modules.

Changed in samba (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers