Ubuntu

slow samba transfer speed to/from windows machines

Reported by cyd on 2007-02-12
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: samba

Installed samba share for a folder with rw, uploaded a file from windows xp, speed in dl is ~20 kb/s to 550kb/s

same if i upload a file from ubuntu to a shared folder on windows xp

if I download a file from the Internet the download speed is 1000 to 1600 kb/s,

the problem is present on samba and if I use direct ethernet (cross cable) the probleme persist, I have tried on two computers and if the file transfer is done xp to xp the speed is normal -> ~10mo/s (100mbits)

find no option in the config file and nothing on irc ( i think it is a bug )

Edit: The bug is likely more associated with a network driver than samba

Brandon.J (brandon-jasper) wrote :

Also noticed the same from a smb transfer to a Vista share of a DVD .iso. The transfer speed was very slow across a gigabit network. The same file transfered to an OS X machine had normal speeds.

description: updated
description: updated
Tom (teeks99) wrote :

There's lots more info about this on ubuntu forums:
http://ubuntuforums.org/showthread.php?t=424063&page=3

eppy 1 (choppy121212) wrote :

This person said they solved the problem: http://ubuntuforums.org/showpost.php?p=2808665&postcount=23
Of course using cifs instead of deprecated smbfs I hope, too.
"
 Re: Samba 100x slower than FTP?
Quote:
Originally Posted by inque_54 View Post
Hello,

I've been researching on this problem too.

Was anybody able to resolve this issue?
Actually, yes (at least for me).

My speed problems were caused by the gam_server checking my samba share for updates too often.

I added this line to /etc/gamin/gaminrc:
Code:

fsset cifs poll 60

and I haven't had a problem since.

BTW, I had to do this on ALL machines that mount this share.

Hope this helps.
"

Croesus (peturbjorn) wrote :

I had this issue, and after looking at the forums,

I managed to 'solve' this problem by putting a new network card into the computer.

The network card I was using was the onboard rtl 8111b chip.

Mathias Gug (mathiaz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Can you specify which version of the samba package you're using ?

Changed in samba:
status: New → Incomplete
alex108 (alex01-malyshev) wrote :

The bug seems to be related to a RTL8169 driver/card, other cards could be affected too. Replacing my Ethernet adapter with D-link (uses SKGE driver) solved it for me.

alex108 (alex01-malyshev) wrote :

I use current samba from Fiesty 3.0.24-2ubuntu1.2 Same behavior with cifs mounts. Previous packages were affected too at least since Dapper.

I see a lot of threads on the forums about this or similar problem with samba/network being slow. I'm surprised that there isn't a lot of posts here.

akme (akrelle) wrote :

BAD realtek 8169 module
============================
Hi Everyone, I hope this helps. I posted this with BUG 95460.. sorry about the dupe)

I had a similar problem on Feisty ( 2.6.20-15-generic and 2.6.20-16-generic) with SAMBA going REALLY REALLY slow.
Tried alll sorts of smb.conf tweeks.. no luck.

However I noticed that SAMBA access would go fast when 2 different windowze machines were basically accessing the same files

I eventually resolved it by downloading and compiling a new module/driver for the on board Realtek NIC
The default install of Feisty created a module r8169 for my machine.
I downloaded and compiled a new driver/module for RTL8111B/RTL8168B/RTL8111/RTL8168/RTL8111C NIC from the Realtek site:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false

Followed the readme instructions to build and install.
After rebooting I found I had the 2 modules (r8169 and r8168) loaded :-(

So I manually removed both and then manually loaded the r8168 module
'bounced the network (/etc/init.d/networking restart) and presto.. super fast SAMBA access

Btw the msdfs proxy made absolutely no difference for me.

Alan (mrintegrity) wrote :

I can confirm that this bug is not present in other distro I tried (gentoo) and that using the kernel module downloaded from realtek website fixes the issue completely. buying a new network card is NOT a solution.

This has been causing a lot of people a lot of headached (4kb/s with samba on 100MB network!) and it would be really nice to get this fixed.. presumably gutsy will have an up dated version of this module and it will hopefully work

Launchpad Janitor (janitor) wrote :

[Expired for samba (Ubuntu) because there has been no activity for 60 days.]

Pekka Panula (grimdin) wrote :

I have similar problem, eg. very very slow speed of samba shares. I am using win xp as client and i am reading files from samba shares and speed is about 1 Mbit/sec.

This problem is with Feisty Fawn and i recently upgraded to Gutsy Gibbon (RC) and its still a problem.

I have tested its not my ubuntu servers disk speed which is slowing its down, because also i tested using FTP and its pretty fast, about 55 Mbit/sec.
Ethernet adapter is using Intel E1000 module, even though it has realtek gigabit adapter also attached, its not been used, meaning it has not been configured and its disabled from networkmanager, it has no ip address, not even ethernet cable.

So, because using FTP i can get normal speed, i suspect something is very broken with samba.

my testparm says:
[global]
        workgroup = UBUNTU
        server string = %h server (Samba, Ubuntu)
        obey pam restrictions = Yes
        passdb backend = tdbsam
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        max xmit = 65535
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 IPTOS_LOWDELAY
        dns proxy = No
        panic action = /usr/share/samba/panic-action %d
        invalid users = root

[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers

[data]
        path = /data
        valid users = xyz, root
        read only = No
        guest ok = Yes

mcavity (mcavity5) wrote :

I'm on gutsy.
Still having the same problem. very slow file transfer from XP shares. Though sending files to XP is fast.
I'm getting about 9megs a second to send and about 400KBs when i try and copy something from the XP server.
i am using a R8169 card.

Andreas (andpro77) wrote :

Running Ubuntu Server 6.06 LTS and Windows XP Prof client - both connected via Gigabit NICs and switch, I observed the following interesting fact:

Upload of a single file is extremely slow.
Concurrent upload of two files is much faster (not only more throughput but even much faster for each file)

Download of a single or two files faster than single upload but slower than double upload. Number of concurrent connections don't matter.

Have a look at the attachment, which nicely shows what I've just tried to explain.

Tunaaja (tunaaja) wrote :

I have speed problems too after compelete reinstallation from ubuntu 7.x to 8.04
Network card is intel 1000 pro/gt and i have tested with 2 different drivers e1000-8.0.1 and e1000-7.6.15.4 and d-link dge-528T card that has DLG10028A chipset
With both cards i get about 9-10MB/s transfer rate when i transfer with ftp or samba to windows xp and previous install i got about 40-60MB/s
Other way from xp to ubuntu i get about 30MB/s and that is little slow too.
I have not changed anything else but installed new ubuntu.
Offcourse both computers have gigabit lan and switch is zyxel gigabit switch

mike33 (craigmj) wrote :

I found the resolution to my slow Samba transfers with this bug report https://bugs.launchpad.net/ubuntu/+bug/211884

In short, the problem:
Connection speed set by the nm-applet is always 1 Mb/s (when it should be 54 Mb/s)

The solution:
#sudo iwconfig wlan0 rate 54M (courtesy of Christian Mangold).

Not sure about my exact transfer rates, but my 350MB file is now taking ~6mins vs. 186mins

Alan (mrintegrity) wrote :

mike33, this bug has nothing to do with wireless so that solution you posted will be of no help to the others posting to this bug with gig nics getting 4KB/s

Mark A Gerads (nazgand) wrote :

I have the latest samba package installed, and it maxes out at 80 KBs, and slows down the longer the transfer is open. in dual boot windows, it maxes out at 830KBs.

themuddler (mike-udall) wrote :

I have samba 3.0.28a on ubuntu 8.04 on two machines, a desktop and a laptop. The desktop is connected by ethernet to a wireless router and the laptop connects wirelessly to that router at 54MBps. I share directories from the desktop to the laptop via samba to maintain compatibility if I need to boot into windows. Unfortunately, I have a maximum transfer rate of 10Mbps when moving files in nautilus. I do not expect my hard drives or network hardware to be limiting this and have no problem with internet speeds. Is it possible to setup a linux-style network in parallel with samba sharing for the time being?

Chris (tokyo-monster) wrote :

I too am having the same issues. 1 computer running Ubuntu Server 8.04, with ubuntu-desktop installed over top for gui purposes, and one running xp SP2.

On the Ubuntu machines, I can get speeds of 1.6-1.8 MEGABYTES down from the internet..

But transffering files from Ubuntu to Windows, or vice versa, I'm getting around 350KILOBYTES if I'm lucky. I've tried every combination of socket options that I could think of, and have seen no increase in speed. I'm using the onboard RTL8100C nic..

I checked out my samba logs a bunch, and see this: [2008/08/28 22:15:53, 0] auth/auth_util.c:create_builtin_users(758)
  create_builtin_users: Failed to create Users

A bunch of times, but it does not appear to effect my ability to connect to and browse my windows machines..

If anyone has made any progress on this, I'd love to know.

Something interesting to note:

I was playing around with virtual box, and couldn't get the builtin drive sharing to work with a windows xp guest operating system, so I mounted my share in windows using samba..and on the SAME computer, I was experiencing the dismal speeds that I see going from my Ubuntu machine to my external windows machine. When I did get the virtual box drive sharing working again, speeds increased drastically. Something that was going to take 35 minutes to transfer took 2.

phill84 (phill84.org) wrote :

After upgrading to 9.04 the problem still exists for me. I can download from the Internet at 10MB/s but while copying large files from xp sharing the speed was around 700KB/s
My NIC is Broadcom Corporation BCM4401-B0 with the out-of-box driver

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed

cyd, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs needs-upstream-testing
removed: samba
affects: network-manager-applet (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers