winbind won't connect to server during startup

Bug #821183 reported by Mike E. on 2011-08-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Low
Unassigned

Bug Description

I'm trying to use winbind to authenticate users from a Samba 3.5 PDC (CentOS) and I can't login to a domain account after (re)start. If I login to a local account and run "wbinfo -u", the only users listed are the BUILTIN accounts. If I then restart winbind and run "wbinfo -u" again, I receive the full list of domain users (and can from then on, login as a domain user). I think this has something to due with the fact that winbind is being started before I have a network connection (wireless). I can wait any length of time (15+ minutes) or login with a local user to where I know that I have a network connection, but still I cannot get winbind to behave until it is restarted. Can anyone help me track this down?

$ lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

$ apt-cache policy winbind
winbind:
  Installed: 2:3.5.8~dfsg-1ubuntu2.3
  Candidate: 2:3.5.8~dfsg-1ubuntu2.3
  Version table:
 *** 2:3.5.8~dfsg-1ubuntu2.3 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ natty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     2:3.5.8~dfsg-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages

Dave Walker (davewalker) on 2011-08-16
Changed in samba (Ubuntu):
importance: Undecided → Low
David Weber (wb-munzinger) wrote :

This is because winbind is still started by init.
See https://bugs.launchpad.net/ubuntu/+source/samba/+bug/612958 for the upstart script.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed

Converting winbind init.d to upstart as mentioned https://bugs.launchpad.net/ubuntu/+source/samba/+bug/612958 works for me Now I can login with winbind to active directory

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers