SAMBA cannot browse Workgroups, name resolve order

Bug #811518 reported by Felix on 2011-07-16
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Medium
Unassigned

Bug Description

Since a lot of years every fresh *ubuntu installation has the same issue. They are not able to browse the network in any way, even crash most of the time. The fix is easy and everyone knows about it but nothing changed over such a long time.

You could really improve user experience for new users with this default line in the smb.conf:

"name resolve order = wins bcast lmhosts host"

Right now the default order does not work for LANs.

Cheers

Dave Walker (davewalker) on 2011-07-19
Changed in samba (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed

This bug affected me, Windows shared worked fine, then they stopped working, and this fixed it. I tried launching an exe in Mono, and then started installing wine right before my shares stopped working. Ubuntu 12.04 amd64 to Windows 8 x64

Felix (apoapo) wrote :

OKAY, this is not fixed yet. Where do i have to send a patch to? It really is as easy as writing

name resolve order = bcast wins lmhosts host

into smb.conf. Everytime a new Ubuntu is installed users are experiencing this and think "fuck, not even shares work". Considering they raged about gfx drivers, flash, java, multi monitor setup etc before, it is a great addition to spend a few hours searching for this one.

Felix (apoapo) wrote :

The attachment "Patching 1 line in smb.conf for users sake" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
John Rose (johnaaronrose) wrote :

Still not changed in Ubuntu Precise.

John Tucker (jonti) wrote :

I've found I also need to set the hostname in smb.conf, and specify how to relate to lanmanager

netbios name = <hostname>
name resolve order = wins bcast lmhosts host
client lanman auth = yes
client ntlmv2 auth = no

I've checked this out thoroughly from an Ubuntu 12.04 client on a vanilla network (adsl router linked by ethernet to multiple machines) using both a 10.04 and a 12.04 host. In that setup, all four lines are needed for nautilus to access the share's files and directories.

I found that solution here
http://forums.majorgeeks.com/showthread.php?t=270346

Spode (forums-g) wrote :

Well, I'm using 14.04 and this is still a problem. Even the fix gets overwritten by updates.

Seems someone is determined to make sure Ubuntu does not get accepted by the general public.

Felix (apoapo) wrote :

Yes, take it as a symptom. Linux, from nerds for nerds. Everyday user has to suffer for his little knowledge about leet systems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers