[SRU] PANIC (pid 18442): internal error in winbindd

Bug #736757 reported by Michael Schwingen
74
This bug affects 9 people
Affects Status Importance Assigned to Milestone
samba
Invalid
Medium
samba (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: samba

Description: Ubuntu 10.04.2 LTS
Release: 10.04

After upgrading from winbind to 2:3.4.7~dfsg-ubuntu3.5, winbindd does not start, rendering SMB unusable on the server.

daemon.log shows the following output:

Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/fault.c:46(fault_report)
Mar 17 10:36:47 lcs-data winbindd[18442]: ===============================================================
Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/fault.c:47(fault_report)
Mar 17 10:36:47 lcs-data winbindd[18442]: INTERNAL ERROR: Signal 11 in pid 18442 (3.4.7)
Mar 17 10:36:47 lcs-data winbindd[18442]: Please read the Trouble-Shooting section of the Samba3-HOWTO
Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/fault.c:49(fault_report)
Mar 17 10:36:47 lcs-data winbindd[18442]:
Mar 17 10:36:47 lcs-data winbindd[18442]: From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/fault.c:50(fault_report)
Mar 17 10:36:47 lcs-data winbindd[18442]: ===============================================================
Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/util.c:1480(smb_panic)
Mar 17 10:36:47 lcs-data winbindd[18442]: PANIC (pid 18442): internal error
Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/util.c:1584(log_stack_trace)
Mar 17 10:36:47 lcs-data winbindd[18442]: BACKTRACE: 21 stack frames:
Mar 17 10:36:47 lcs-data winbindd[18442]: #0 /usr/sbin/winbindd(log_stack_trace+0x1a) [0x7f40611d517a]
Mar 17 10:36:47 lcs-data winbindd[18442]: #1 /usr/sbin/winbindd(smb_panic+0x1f) [0x7f40611d523f]
Mar 17 10:36:47 lcs-data winbindd[18442]: #2 /usr/sbin/winbindd(+0x14384d) [0x7f40611c484d]
Mar 17 10:36:47 lcs-data winbindd[18442]: #3 /lib/libc.so.6(+0x33af0) [0x7f405ed1eaf0]
Mar 17 10:36:47 lcs-data winbindd[18442]: #4 /usr/sbin/winbindd(rpc_pipe_np_smb_conn+0x4) [0x7f40612b7204]
Mar 17 10:36:47 lcs-data winbindd[18442]: #5 /usr/sbin/winbindd(rpccli_set_timeout+0x8) [0x7f40612b0048]
Mar 17 10:36:47 lcs-data winbindd[18442]: #6 /usr/sbin/winbindd(winbindd_lookup_names+0xb1) [0x7f406114a3b1]
Mar 17 10:36:47 lcs-data winbindd[18442]: #7 /usr/sbin/winbindd(+0xc953f) [0x7f406114a53f]
Mar 17 10:36:47 lcs-data winbindd[18442]: #8 /usr/sbin/winbindd(+0xca948) [0x7f406114b948]
Mar 17 10:36:47 lcs-data winbindd[18442]: #9 /usr/sbin/winbindd(+0xcaef7) [0x7f406114bef7]
Mar 17 10:36:47 lcs-data winbindd[18442]: #10 /usr/sbin/winbindd(+0xb4b9a) [0x7f4061135b9a]
Mar 17 10:36:47 lcs-data winbindd[18442]: #11 /usr/sbin/winbindd(winbindd_lookup_sid_by_name+0x23) [0x7f4061129773]
Mar 17 10:36:47 lcs-data winbindd[18442]: #12 /usr/sbin/winbindd(winbindd_dual_lookupname+0xb1) [0x7f4061156751]
Mar 17 10:36:47 lcs-data winbindd[18442]: #13 /usr/sbin/winbindd(+0xd31e8) [0x7f40611541e8]
Mar 17 10:36:47 lcs-data winbindd[18442]: #14 /usr/sbin/winbindd(+0xd36cf) [0x7f40611546cf]
Mar 17 10:36:47 lcs-data winbindd[18442]: #15 /usr/sbin/winbindd(+0x9e9b7) [0x7f406111f9b7]
Mar 17 10:36:47 lcs-data winbindd[18442]: #16 /usr/sbin/winbindd(tevent_common_check_signal+0x1da) [0x7f40611e699a]
Mar 17 10:36:47 lcs-data winbindd[18442]: #17 /usr/sbin/winbindd(run_events+0x34) [0x7f40611e4d64]
Mar 17 10:36:47 lcs-data winbindd[18442]: #18 /usr/sbin/winbindd(main+0xcd3) [0x7f4061121b53]
Mar 17 10:36:47 lcs-data winbindd[18442]: #19 /lib/libc.so.6(__libc_start_main+0xfd) [0x7f405ed09c4d]
Mar 17 10:36:47 lcs-data winbindd[18442]: #20 /usr/sbin/winbindd(+0x9e3f9) [0x7f406111f3f9]
Mar 17 10:36:47 lcs-data winbindd[18442]: [2011/03/17 10:36:47, 0] lib/fault.c:326(dump_core)
Mar 17 10:36:47 lcs-data winbindd[18442]: dumping core in /var/log/samba/cores/winbindd
Mar 17 10:36:47 lcs-data winbindd[18442]:

Downgrading to 2:3.4.7~dfsg-1ubuntu3.4 (including all dependencies) fixes the problem.

Revision history for this message
Chuck Short (zulcss) wrote :

Can you install samba-dbg and reproduce this please?

Thanks
chuck

Changed in samba (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Aurimas Fišeras (aurimas-gmail) wrote :

Binary package hint: samba

Description: Ubuntu 10.04.2 LTS
Release: 10.04

I'm having a similar crash after samba and kernel update last night.
Winbind crashed 2 times today.

samba-dbg was not installed.

Revision history for this message
Aurimas Fišeras (aurimas-gmail) wrote :

core dump mentioned in a log file

Revision history for this message
Hein Gustavsen (hein-gustavsen) wrote :

I have a similar problem. winbindd does start, but has crashed several times since installing 2:3.4.7~dfsg-1ubuntu3.5. Here is my gdb backtrace from core dump:

Core was generated by `/usr/sbin/winbindd'.
Program terminated with signal 6, Aborted.
#0 0x00007f4fbe8fba75 in raise () from /lib/libc.so.6
(gdb) bt
#0 0x00007f4fbe8fba75 in raise () from /lib/libc.so.6
#1 0x00007f4fbe8ff5c0 in abort () from /lib/libc.so.6
#2 0x00007f4fc0da1450 in dump_core () at lib/fault.c:337
#3 0x00007f4fc0db227e in smb_panic (why=<value optimized out>)
    at lib/util.c:1496
#4 0x00007f4fc0da184d in fault_report (sig=11) at lib/fault.c:52
#5 sig_fault (sig=11) at lib/fault.c:75
#6 <signal handler called>
#7 rpc_pipe_np_smb_conn (p=0x0) at rpc_client/rpc_transport_np.c:402
#8 0x00007f4fc0e8d048 in rpccli_set_timeout (rpc_cli=0x0, timeout=35000)
    at rpc_client/cli_pipe.c:2956
#9 0x00007f4fc0d277a1 in winbindd_lookup_sids (mem_ctx=0x7f4fc2ae8560,
    domain=<value optimized out>, num_sids=<value optimized out>,
    sids=<value optimized out>, domains=0x7fff185eaf90, names=0x7fff185eafa0,
    types=0x7fff185eaf98) at winbindd/winbindd_rpc.c:1221
#10 0x00007f4fc0d2a092 in lookup_groupmem (domain=0x7f4fc2b0a240,
    mem_ctx=0x7f4fc2ae8780, group_sid=0x7f4fc2b2e360,
    num_names=0x7fff185eb2dc, sid_mem=<value optimized out>,
    names=<value optimized out>, name_types=0x7fff185eb2a8)
    at winbindd/winbindd_ads.c:1124
#11 0x00007f4fc0d11503 in lookup_groupmem (domain=<value optimized out>,
    mem_ctx=<value optimized out>, group_sid=<value optimized out>,
    num_names=0x7fff185eb2dc, sid_mem=0x7fff185eb298, names=0x7fff185eb2a0,
---Type <return> to continue, or q <return> to quit---
    name_types=0x7fff185eb2a8) at winbindd/winbindd_cache.c:2211
#12 0x00007f4fc0d045e7 in expand_groups (domain=0x7f4fc2b0a240,
    state=<value optimized out>, group_sid=<value optimized out>,
    group_name_type=SID_NAME_DOM_GRP, num_gr_mem=<value optimized out>,
    gr_mem=<value optimized out>, gr_mem_len=0x7fff185eb668)
    at winbindd/winbindd_group.c:468
#13 fill_grent_mem (domain=0x7f4fc2b0a240, state=<value optimized out>,
    group_sid=<value optimized out>, group_name_type=SID_NAME_DOM_GRP,
    num_gr_mem=<value optimized out>, gr_mem=<value optimized out>,
    gr_mem_len=0x7fff185eb668) at winbindd/winbindd_group.c:604
#14 0x00007f4fc0d05a9f in getgrsid_sid2gid_recv (private_data=0x7f4fc2aa6890,
    success=<value optimized out>, gid=16777729)
    at winbindd/winbindd_group.c:866
#15 0x00007f4fc0cfeba0 in process_loop (argc=<value optimized out>,
    argv=<value optimized out>, envp=<value optimized out>)
    at winbindd/winbindd.c:1115
#16 main (argc=<value optimized out>, argv=<value optimized out>,
    envp=<value optimized out>) at winbindd/winbindd.c:1440

Revision history for this message
sense (opaperjam) wrote :

Same problem happen to me
ubuntu version: 10.04.2 x86_64
winbind version: 2:3.4.7~dfsg-1ubuntu3.5
And have the similar thread debugging message:

[Thread debugging using libthread_db enabled]
0x00007fb594f32f7e in waitpid () from /lib/libc.so.6
#0 0x00007fb594f32f7e in waitpid () from /lib/libc.so.6
#1 0x00007fb594eca7e9 in ?? () from /lib/libc.so.6
#2 0x00007fb597373264 in smb_panic (why=<value optimized out>)
    at lib/util.c:1486
#3 0x00007fb59736284d in fault_report (sig=11) at lib/fault.c:52
#4 sig_fault (sig=11) at lib/fault.c:75
#5 <signal handler called>
#6 rpc_pipe_np_smb_conn (p=0x0) at rpc_client/rpc_transport_np.c:402
#7 0x00007fb59744e048 in rpccli_set_timeout (rpc_cli=0x0, timeout=35000)
    at rpc_client/cli_pipe.c:2956
#8 0x00007fb5972e87a1 in winbindd_lookup_sids (mem_ctx=0x7fb597fb2b50,
    domain=<value optimized out>, num_sids=<value optimized out>,
    sids=<value optimized out>, domains=0x7fff2af6f1c0, names=0x7fff2af6f1d0,
    types=0x7fff2af6f1c8) at winbindd/winbindd_rpc.c:1221
#9 0x00007fb5972eb092 in lookup_groupmem (domain=0x7fb598041950,
    mem_ctx=0x7fb597fe8950, group_sid=0x7fb598084a90,
    num_names=0x7fff2af6f50c, sid_mem=<value optimized out>,
    names=<value optimized out>, name_types=0x7fff2af6f4d8)
    at winbindd/winbindd_ads.c:1124
#10 0x00007fb5972d2503 in lookup_groupmem (domain=<value optimized out>,
    mem_ctx=<value optimized out>, group_sid=<value optimized out>,
    num_names=0x7fff2af6f50c, sid_mem=0x7fff2af6f4c8, names=0x7fff2af6f4d0,
    name_types=0x7fff2af6f4d8) at winbindd/winbindd_cache.c:2211
#11 0x00007fb5972c55e7 in expand_groups (domain=0x7fb598041950,
    state=<value optimized out>, group_sid=<value optimized out>,
    group_name_type=SID_NAME_DOM_GRP, num_gr_mem=<value optimized out>,
    gr_mem=<value optimized out>, gr_mem_len=0x7fff2af6f898)
    at winbindd/winbindd_group.c:468
#12 fill_grent_mem (domain=0x7fb598041950, state=<value optimized out>,
    group_sid=<value optimized out>, group_name_type=SID_NAME_DOM_GRP,
    num_gr_mem=<value optimized out>, gr_mem=<value optimized out>,
    gr_mem_len=0x7fff2af6f898) at winbindd/winbindd_group.c:604
#13 0x00007fb5972c6a9f in getgrsid_sid2gid_recv (private_data=0x7fb597fd0200,
    success=<value optimized out>, gid=11610) at winbindd/winbindd_group.c:866
#14 0x00007fb5972bfba0 in process_loop (argc=<value optimized out>,
    argv=<value optimized out>, envp=<value optimized out>)
    at winbindd/winbindd.c:1115
#15 main (argc=<value optimized out>, argv=<value optimized out>,
    envp=<value optimized out>) at winbindd/winbindd.c:1440
A debugging session is active.

Changed in samba (Ubuntu):
status: Incomplete → Confirmed
Chuck Short (zulcss)
Changed in samba (Ubuntu):
importance: Low → Medium
Revision history for this message
Chuck Short (zulcss) wrote :

This is fixed in natty.

Regards
chuck

tags: added: bitesize server-sru-easy
Changed in samba (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
sense (opaperjam) wrote :

Will release the fix in lucid?

Revision history for this message
Carson Gee (x-carsongee) wrote :

I agree with sense. I am experiencing this on LTS servers with over 30 thousand users that can't login whenever this gets triggered.

Revision history for this message
Klaus Hochlehnert (klaus-kh-dev) wrote :

I also have this problem with lucid.
winbindd crashes every 2 days after my last upgrade (~1 week ago)

Revision history for this message
Ralf Lederle (ralf-lederle) wrote :

I have the same problem with lucid. Downgrading to 2:3.4.7~dfsg-1ubuntu3.4 solved the problem but this is no satisfying solution. I think a bugfix for lucid LTS is strictly necessary!

Chuck Short (zulcss)
summary: - PANIC (pid 18442): internal error in winbindd
+ [SRU] PANIC (pid 18442): internal error in winbindd
Revision history for this message
Chuck Short (zulcss) wrote :

Statement of Impact: The last SRU update for fixing bug #623342 introduced a regression that was fixed upstream. I have backported from the samba git tree. I have attached the debdiff which fixes this bug.

How to reproduce:

1. Install the lucid samba update
2. Restart winbindd

Revision history for this message
Chuck Short (zulcss) wrote :
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

APPROVED: version 2:3.4.7~dfsg-1ubuntu3.6 uploaded to lucid-proposed should be accepted.

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted samba into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in samba (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
sense (opaperjam) wrote :

Tested samba 2:3.4.7~dfsg-1ubuntu3.6 for 2 days, no panic. Thanks.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Michael Schwingen (michael-schwingen) wrote : Re: [Bug 736757] Re: [SRU] PANIC (pid 18442): internal error in winbindd

Am 04/14/2011 07:07 PM, schrieb Martin Pitt:
> Accepted samba into lucid-proposed, the package will build now and be
> available in a few hours. Please test and give feedback here. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!
Installed version from lucid-proposed yesterday - no problems yet, seems
fixed.

cu
Michael

Revision history for this message
gmoore777 (guy-moore) wrote :

It's been 36 hours, and have not got the "rpc_pipe_np_smb_conn" crash, as I call it, on any of the 3 machines that I installed the 2:3.4.7~dfsg-1ubuntu3.6 package.
Will still be monitoring this, and may even install it on a few more machines, today.

Revision history for this message
gmoore777 (guy-moore) wrote :

It's been 6 days, and the 5 machines that I have this patch on now, are doing fine.

Revision history for this message
Michael Schwingen (michael-schwingen) wrote : AUTO: Michael Schwingen ist außer Haus. (Rückkehr am 28.04.2011)

Ich bin bis 28.04.2011 abwesend.

Ich werde Ihre Nachricht nach meiner Rückkehr beantworten. In dringenden
Fällen wenden Sie sich bitte an meinen Kollegen Helmut Juchems:
<email address hidden>

Hinweis: Dies ist eine automatische Antwort auf Ihre Nachricht "[Bug
736757
] Re: [SRU] PANIC (pid 18442): internal error in winbindd" gesendet
am 25.04.2011 19:32:40.

Diese ist die einzige Benachrichtigung, die Sie empfangen werden, während
diese Person abwesend ist.

Revision history for this message
gmoore777 (guy-moore) wrote :

I pushed out the patch to 24 more machines ( 29 total) on Monday 2011-04-25 6:30 PM. All is fine since then.
Pushing out the patch to the rest of the 80 machines, right now.

Revision history for this message
gmoore777 (guy-moore) wrote :

Everything still working fine on all 80 machines since 2011-04-27.

Revision history for this message
styro (anton-list) wrote :

Just chiming in to say that 3.4.7~dfsg-1ubuntu3.6 from lucid-proposed also fixed this problem on our servers as well.

We've gone from daily winbind panics to no crashes since. We haven't noticed any side-effects either.

Any idea if or when this makes it into lucid-updates?

Revision history for this message
Schalk Engelbrecht (rockhopper) wrote :

After applying the patches, winbind is behaving nicely and we also have no more panics!

Please escalate this into lucid-updates!

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

To all who would like to see this released into lucid-updates, we need to have some verification of bug #558793 as well, since both of them are included in the package currently in -proposed.

Revision history for this message
Michael Schwingen (michael-schwingen) wrote : Re: [Bug 736757] Re: [SRU] PANIC (pid 18442): internal error in winbindd

> To all who would like to see this released into lucid-updates, we need
> to have some verification of bug #558793 as well, since both of them are
> included in the package currently in -proposed.

We just migrated our AD Servers to 2008 this weekend, and had the problems
described in #558793 (according to my colleagues who did the migration).

Also, one Linux server that was still running the release version of
10.04.02 had intermittent problems authenticating users (but no winbind
crashes).

Both problems went away after upgrading to the -proposed-upgrades versions
of samba+winbind.

cu
Michael Schwingen

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Thanks Michael. I'll consider that a verification, and have marked the bug as such.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.4.7~dfsg-1ubuntu3.6

---------------
samba (2:3.4.7~dfsg-1ubuntu3.6) lucid-proposed; urgency=low

  * debian/patches/backport-lp558793.patch: Fixes net ads dns register
    failing with Windows 2008 R2 domain. Backported from
    v3-4-stable tree (aaf6e34115c2bece85d0dc4f11951b38e9d77637
    and 0e1aec461ed69c82987cf86e6b1beb6862cc0fb4). (LP: #558793)
  * debian/patches/backport-lp736757.patch: Fix regression introduced
    by previous SRU bug fix. Backported from the v3-4-stable tree
    (995e7e500327e662b7ef2b37c83c92e75f2360bf) (LP: #736757)
 -- Chuck Short <email address hidden> Wed, 13 Apr 2011 11:13:44 -0400

Changed in samba (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in samba:
importance: Unknown → Medium
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.