smb workgroup detection takes too long

Bug #73591 reported by amichair on 2006-11-28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)

Bug Description

I'm Running Kubuntu Edgy within a Windows workgroup, with samba set up correctly to browse shared folders on a Windows server. However, after I reboot Kubuntu, browsing to "smb:/" in Konqueror results in the error:
"Unable to find any workgroups in your local network. This might be caused by an enabled firewall."
Although browsing straight to "smb://servername" works well.

If I then wait, and hit refresh every couple of minutes, I still get the error each time, but after 40 minutes or so a final refresh shows the workgroup correctly, and from then on it works well.

Since it's obviously possible to detect the workgroup successfully, as it does after waiting for a while, whatever it does to get things working should be activated on-demand the moment "smb:/" is accessed, rather than waiting for it to happen elsewhere (eventually).

(I don't know if this is relevant or not, but I'm connected to the LAN via a wireless connection, which is enabled manually after bootup completes - so there's no connectivity during the boot process).

Roel Huybrechts (rulus) wrote :

Changed the package to samba.

amichair (amichai2) wrote :

update: this happens also on a wired network, not just wireless.

Ante Karamatić (ivoks) wrote :

Is there a WINS on network or maybe DHCP supplies WINS record?

Changed in samba:
importance: Undecided → Medium
status: New → Triaged
Phill Coxon (phill-getresults) wrote :

I had exactly the same problem: "Unable to find any workgroups in your local network. This might be caused by an enabled firewall" and spent the best part of two days banging my head against a brick wall while trying to figure it out.

My Samba server is running KUbuntu 7.10 upgraded from Kubuntu 7.04

While everything worked fine in 7.04 as soon as I upgraded to 7.10 the above problem started.

The workgroup would not appear in Kubuntu or using smb:/ in konqueror.

The server could not be seen by the windows computers on the network.

I *finally* found how to stop the problem although I don't have the technical expertise to say what is causing it.

My local network consists of the Ubuntu server running samba and two windows PCs (XP home and Vista Home Premium). Both of those computers were being assigned addresses by DHCP from my ADSL router.

When I assigned static IP addresses to both windows computers the workgroup instantly appeared on all computers.

If I use DHCP on either windows computer to set a network address then the workgroup disappears.

So it appears to be some sort of clash between DHCP traffic and Samba.

Note: The DHCP server was still running on the ADSL router - it was only when I used DHCP on the windows computers that the problem occurred.

Hopefully this is helpful to others and will give some clues to someone with my technical expertise about why the problem was happening.

Patrice Vetsel (vetsel-patrice) wrote :

Could you test/confirm with a Gutsy live cd ? You have to wait few minutes before trying to browse samba share.

brhad56 (brad-maliaplace) wrote :

I also had this problem after upgrading to 7.10, and it didn't exist in 7.04. I didn't try setting static IP's for all the windows machines, but I did figure out a solution that worked for me. Apparently, I had a program called "Firestarter" installed. I don't remember if it was something I installed with 7.04 and had forgot about or if it installed automagically with the 7.10 upgrade. When I disabled it, I could then see my network in the Dolphin->Network->Samba Shares. But I still couldn't browse my network. I am not worried about a firewall, as I am behind a router, so I the used the Add/Remove Programs and removed Firestarter. And now the Samba Shares work like a champ.


JoshuaKersey (goodtimetribe) wrote :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package firestarter is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

still receiving the same error message.

I was previously able to browse it on the same laptop in the windows boot. i have not tried it again, but i'm going to. any other ideas?

JoshuaKersey (goodtimetribe) wrote :

Still dealing with this problem. to the person who said it might have something to do with dhcp being manual vs automatic. i made all of mine manual at the router level based on MAC. still get the same error.

JoshuaKersey (goodtimetribe) wrote :

Interestingly enough, I'm able to mount the shares using smbfs and I can access them in Konqueror and Dolphin via smb://machinename/path and even smb://machinename/

Mark Ellse (markellse) wrote :

Please see the bug below showing similar behaviour on Intrepid, together with some steps to isolate the problem.

Thierry Carrez (ttx) wrote :

Joshua, Mark: your issue is apparently gvfs-related (Gnome), while the original reporter has a konqueror issue. Please follow up on bug 316862 instead.

amichair and other KDE reporters: are you still experiencing the problem with one of the supported releases ?

Changed in samba:
status: Triaged → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in samba (Ubuntu):
status: Incomplete → Invalid
amichair (amichai2) wrote :

I've moved since then to a new setup, now I'm with a new Jaunty machine (upgraded from a fresh Intrepid installation) on the same LAN as the original winxp box, plus another xp. I can only note what happens out of the box now - I don't remember if there were any custom configurations on the old setup (used in the original report).

Currently, smb:/ in dolphin/konqueror doesn't give an error, but doesn't show the other pcs either - just a blank screen with 0 items in the status bar. Typing smb:/servername connects and works with the shares just fine.

Eric B (ebischoff) wrote :

Same problem here with Karmic Koala, half-solved.

The server is a Windows 2008 server. The Linux machine has only the client part of samba. The IP addresses are fix.

In konqueror:
smb://servername works fine
smb:// works fine
smb:/workgroup/servername fails

I found that my problem had two origins :
 - I had to start the "Browser" service on the windows server
 - the syntax "smb:/workgroup/servername" seems to have stopped working in KDE (???)
   but "smb://workgroup/" works fine and the final functionality is the same

I hope that helps.

Network detection is taking too long in Lucid too...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers