Ubuntu

Samba in Lucid upgrade killed Envelope Feeder on HP LJ4000 printer

Reported by Michael Lueck on 2011-01-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Low
Unassigned
samba (Ubuntu)
Low
Chuck Short

Bug Description

Binary package hint: samba

This was not an issue with the Samba builds with Ubuntu 9.04 / 9.10. I upgraded a couple of servers to 10.04 LTS (Lucid) and that upgrade killed the Envelope Feeder on all three official / latest HP drivers available for LaserJet LJ 4000 printers.

We had been using Point-n-Print to upload printer drivers to the servers for about as long as it has been supported in Samba. That has worked well.

I did not adjust anything with the print driver during the upgrade to Ubuntu 10.04 Lucid. However that upgrade killed the Envelope Feeder on the printer.

The PCL 5e and PCL 6 drivers print COM10 envelopes on plain paper from the tray, and they do not even rotate the text 90'.

The PS driver print COM10 envelopes at least rotated 90', however still on plain paper.

Inside the driver, the check box is unchecked for the envelope feeder in the PCL5e / PCL6 driver versions. It had always been checked since I built these servers / uploaded the drivers. The PS driver did keep the setting for Envelope Feeder selected.

So I trying to clear out the drivers and reupload them, with the following:

1) Stop Samba

2) Backup files:
/var/lib/samba/ntdrivers.tdb
/var/lib/samba/ntprinters.tdb
/var/lib/samba/ntforms.tdb
/var/cache/samba/printing/printers.tdb
/var/cache/samba/printing/HPLJ4000-PS.tdb
/var/cache/samba/printing/HPLJ4000-PCL6.tdb
/var/cache/samba/printing/HPLJ4000-PCL5e.tdb
/srv/shares/print/* (dir that has the print share for drivers to be uploaded to)

3) Delete said files

4) Restart Samba

5) From a Windows XP Pro workstation, login to the domain with an ID that is a PrinterAdmin

6) Re-upload drivers

7) Check the check box in the driver for the Envelope feeder.
The check box would NOT stay checked in the PCL-5e or PCL 6 drivers.
The check box DID say checked in the PS driver.

8) Return to test workstation, reinstall the drivers over-top of the drivers already on the workstation (same version drivers as before, HP has not updated them recently)

9) Confirm that the PS driver DID have the Envelope Feeder selected

10) Try printing an envelope, printer LCD does indicate that it is going to print an envelope, however 8.5 x 11 paper is pulled in

<><><><>

WorkAround: I have moved to printing directly to CUPS via Windows XP "Internet Printing"

The downside to that is I must visit each workstation to deploy the printers by hand. IPP has no "upload / download printer driver" capabilities. However all of the check boxes are functional, and envelopes print properly from all three drivers available for HP LJ4000 printers.

Dave Walker (davewalker) on 2011-02-01
Changed in samba (Ubuntu):
importance: Undecided → Low
Chuck Short (zulcss) on 2011-03-01
affects: samba (Ubuntu) → cups (Ubuntu)
Michael Lueck (mlueck) wrote :

Aaahhh, excuse me, Chuck Short: How could this possibly be CUPS which is causing these problems? The workstations print to Samba, which in turn prints through CUPS. CUPS direct printing from Windows workstations works. CUPS does not get involved until the print job reaches the server, however we are having difficulty getting the driver to keep the appropriate option check boxes when using Samba for Point-n-Print, which CUPS has nothing to do with.

So how could it NOT be Samba which is causing the trouble?

Till Kamppeter (till-kamppeter) wrote :

Chuck Short, why do think that this is a problem of CUPS and not of Samba?

Till Kamppeter (till-kamppeter) wrote :

Michael Lueck, can you log in on the server and try to print directly from there? Can you use the envelope feeder when printing from the server? Do you have a desktop machine running Linux? If so, can you print from there and see whether the envelope feeder works?

Changed in cups (Ubuntu):
status: New → Incomplete
Changed in samba (Ubuntu):
status: New → Incomplete
Michael Lueck (mlueck) wrote :

@Tim: The only application I know of which is able to comprehend the envelope feeder on the printer is WordPerfect which is a Windows application.

We run Ubuntu Server edition on our servers, no GUI, no nothing!

Yes my workstation runs Ubuntu Desktop edition (9.04 still as I have one application dependent on 9.04 code).

Likewise I am printing directly to CUPS and having much better success. Print jobs from Firefox went to never-never land while print jobs from Thunderbird (2.x) would print. Since switching to "direct to CUPS" printing Firefox is able to print. However that was broken even when the server was running 9.04. I have since upgraded it to 10.04 LTS.

And it is not only the envelope feeder which got "killed" by the upgrade form 9.04 -> 10.04. I quote: "The PCL 5e and PCL 6 drivers print COM10 envelopes on plain paper from the tray, and they do not even rotate the text 90'."

So Samba MUST be doing more than merely spooling print data headed to CUPS. "But it is coming from Windows... how much detail could Samba possibly figure out about the print job?!?!" I would think Samba merely spools data to CUPS, but apparently not the case.

One thing which I just realized, I have not tried to connect with Windows to the print queues on Samba without using the Point-n-Print uploaded drivers. I will try to work up a test environment to test that scenario. Specifically, still printing through Samba but not make use of the driver already uploaded to the server.

Michael Lueck (mlueck) wrote :

All right, I retested this via testing Samba Port based printing which I used until SpoolSS / Point-n-Print was not working properly in Samba, back in v 3.0.2 time frame. That works properly allowing the check boxes / selection to enable the Envelope Feeder option to be active.

I was able to print a COM10 envelope from WordPerfect and it was pulled correctly from the Envelope Feeder.

Port based printing is where you go to the ports tab of the printer properties, add a port, and fill in the UNC path to the printer resource on the Samba server.

So I believe this is specifically a problem with storing the printer driver on the Samba server via Point-n-Print and printing via SpoolSS. That would also tie in with check boxes not staying checked as the idea behind Point-n-Print is for administrators to be able to publish printers and pre-configure the driver for use with that SPECIFIC printer and its capabilities.

Launchpad Janitor (janitor) wrote :

[Expired for cups (Ubuntu) because there has been no activity for 60 days.]

Changed in cups (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for samba (Ubuntu) because there has been no activity for 60 days.]

Changed in samba (Ubuntu):
status: Incomplete → Expired
Michael Lueck (mlueck) wrote :

Aaakkk!!! @Till Kamppeter I updated this report a couple of times. Resetting the Samba ticket back to new as I feel the addl testing done confirms it to be a Samba bug and not CUPS.

Changed in samba (Ubuntu):
status: Expired → New
Till Kamppeter (till-kamppeter) wrote :

Sorry, as I saw your last answer, I did not see that the bug was still on "Incomplete" which causes it to expire after 60 days. Perhaps you should already set back the bug state from "Incompolete" to "New" when you answer a developer's question in any bug report.

Michael Lueck (mlueck) wrote :

Suggestion noted how to handle responding to a developer question. I had no idea that "Incomplete" had a timer ticking.

BTW: Is there a best place to install Ubuntu Lucid (10.04) packages of Samba higher than the stable release maintained for Lucid? Perhaps this is fixed by a higher release of Samba.

In the past when I started with Samba I was using Debian Sarge. I installed Samba from the official Samba repo. However, I have only used official Ubuntu packages since switching to Ubuntu. Thus since switching to Ubuntu I sort of feel out of the loop with what developments Samba has brewing.

Serge Hallyn (serge-hallyn) wrote :

Hi Chuck,

any chance you could try your hand at a new samba daily build at https://launchpad.net/~ubuntu-server-edgers/+archive/server-edgers-samba for lucid, for Michael to test with?

Changed in samba (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
Clint Byrum (clint-fewbar) wrote :

Hi Michael, thanks for taking the time to file this bug report!

Sorry that this one has been so difficult. Its fairly hard for us to test because not many of us maintain Windows XP machines for testing nor do we have HP printers, so you see where this might require us to fumble in the dark a bit before we can confirm.

I've uploaded samba from 11.04 to my PPA, which you can enable with

sudo add-apt-repository ppa:clint-fewbar/fixes

Launchpad tells me that it should start building in an hour or so, but please give it time if you don't immediately see an upgrade. You can check the build status here:

--amd64--

https://launchpad.net/~clint-fewbar/+archive/fixes/+build/2507304

--i386--

https://launchpad.net/~clint-fewbar/+archive/fixes/+build/2507305

Leaving the status as New, as I think we have as much information as we need but just need to take the steps to reproduce it.

Chuck Short (zulcss) wrote :

Please test the abouve ppa and we can try getting a fix backported.

Changed in samba (Ubuntu):
status: New → Incomplete
Michael Lueck (mlueck) wrote :

I had to do:

$ sudo apt-get install python-software-properties

To be able to use the add-apt-repository command listed in #12.

That done, refreshed the package list several times, and am not finding your updated Samba build you posted for me to test with. I will keep clawing at the keyboard... Open to suggestions. Thanks!

Changed in samba (Ubuntu):
status: Incomplete → New
Michael Lueck (mlueck) wrote :

FYI, I see no Samba packages under here:
http://ppa.launchpad.net/clint-fewbar/fixes/ubuntu/pool/main/

That just might be a problem... Chuck, could you please check on the build machine? Thanks!

Dave Walker (davewalker) wrote :

@Clint, did you delete the packages from your PPA?

Dave Walker (davewalker) on 2011-07-15
Changed in samba (Ubuntu):
importance: Undecided → Low
Michael Lueck (mlueck) wrote :

I checked back this evening on this topic. Now I see Samba package files at the URL in #15.

However Samba does not show up here:
https://launchpad.net/~clint-fewbar/+archive/mogile

So not a surprise that I am not offered to move to that build of Samba.

More assistance please.

Clint Byrum (clint-fewbar) wrote :

Hi Michael, the samba packages are in:

https://launchpad.net/~clint-fewbar/+archive/fixes

Michael Lueck (mlueck) wrote :

Thanks, I flushed out the previous PPA's and added that one. I see it now.

The samba package depends on:

* samba depends on libwbclient0 (= 2:3.5.8~dfsg-1ubuntu2.1~lucid~ppa1)

Which libwbclient0 is not on our servers. Did you build your package some other way than the official Ubuntu 10.04 ones?

Excerpts from Michael Lueck's message of Fri Aug 12 21:36:10 UTC 2011:
> Thanks, I flushed out the previous PPA's and added that one. I see it
> now.
>
> The samba package depends on:
>
> * samba depends on libwbclient0 (= 2:3.5.8~dfsg-1ubuntu2.1~lucid~ppa1)
>
> Which libwbclient0 is not on our servers. Did you build your package
> some other way than the official Ubuntu 10.04 ones?

libwbclient0 is a part of the same samba upgrade, and is also available in the PPA.

Michael Lueck (mlueck) wrote :

All right, I got the dependencies happy finally. Pulled down the following packages:

libpam-smbpass_2%3a3.5.8~dfsg-1ubuntu2.1~lucid~ppa1_i386.deb
samba_2%3a3.5.8~dfsg-1ubuntu2.1~lucid~ppa1_i386.deb
samba-common_2%3a3.5.8~dfsg-1ubuntu2.1~lucid~ppa1_all.deb
samba-common-bin_2%3a3.5.8~dfsg-1ubuntu2.1~lucid~ppa1_i386.deb
libwbclient0_2%3a3.5.8~dfsg-1ubuntu2.1~lucid~ppa1_i386.deb

I then booted up a WinXP machine, started Windows Explorer \ Printers and Faxes on our Samba server \ properties of the three LJ4000 drivers.

As usual, the Envelope Feeder check box will not stay checked on the PCL 5e and PCL 6 drivers. I check the box and the "Apply" button does not un-gray ack'ing that a change has been made which is possible to Apply / Save.

Do you think the uploaded drivers might have been corrupted by the former Samba build? Shall I go through the "purge Point-n-Print drivers" process and re-upload them?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers