samba prerm script fails on upgrade from dapper->edgy

Bug #68378 reported by Colas Le Guernic on 2006-10-26
6
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
High
Fabio Massimo Di Nitto
Edgy
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

After upgrading from 6.06 to 6.10:

E: /var/cache/apt/archives/samba_3.0.22-1ubuntu4_i386.deb: subprocess new pre-removal script returned error exit status 102

I tried the solution indicated in the similar bug #9208:

sudo rm /etc/rc2.d/S91samba
sudo rm /etc/rc3.d/S91samba

It seems to solve the problem, but I still have an error with irda-utils while reinstalling samba (and samba only)

Preconfiguring packages ...
(Reading database ... 180697 files and directories currently installed.)
Preparing to replace samba 3.0.22-1ubuntu4 (using .../samba_3.0.22-1ubuntu4_i386.deb) ...
 * Stopping Samba daemons... [ ok ]
Unpacking replacement samba ...
Setting up irda-utils (0.9.16-11ubuntu4) ...
udev active, devices will be created in /dev/.static/dev/
udev active, devices will be created in /dev/.static/dev/
Starting IrDA service: irattachinvoke-rc.d: initscript irda-utils, action "start" failed.
dpkg: error processing irda-utils (--configure):
 subprocess post-installation script returned error exit status 1
Setting up samba (3.0.22-1ubuntu4) ...
 * Starting Samba daemons... [ ok ]

It's quite surprising... I removed irda-utils, reinstalled samba, reinstalled irda-utils and everything works now.

Michael Vogt (mvo) on 2006-10-28
Changed in samba:
importance: Undecided → High
status: Unconfirmed → Confirmed
chrism (ubuntu-dirtchild) wrote :

I am a submitter of one of the dupes of this bug. Solution found was to:

-----------------------------------------------------
sudo su -
cd /etc/rc2.d/
rm S91samba
apt-get remove -f samba
apt-get -f install
apt-get install samba
cd /etc/rc3.d/
ln -s ../init.d/samba K09samba
update-manager -c
-----------------------------------------------------

the samba install complained about linking in rc3.d to /samba, hence the forced link. The run of update manager complained that some packages were out of date possibly due to modification (apologies, I didn't note the exact message), and it gave me the option to perform a dist upgrade, which worked.

I can no longer replicate the bug as my system has completed upgrade to 6.10, however I had the same symptoms as the other dupes to this bug (two errors during dist upgrade, second halting the process). I am using the UK servers.

If I can be of further help (logs etc), please ask.

Arnaud (lucasarnaud79) wrote :

Variation :

I encoutered a similar problem, but with a difference : File S91samba didnot exist on my system. "apt-get remove -f samba" complained instead about K09samba.

The cure was to adapt Chrism's solution by replacing "rm -f S91samba" with "rm -f K09samba".

(See Bug #68768)

Matt Zimmerman (mdz) wrote :

Fabio, please look into this and consider for an SRU. This doesn't seem to be as robust as it needs to be, and it's breaking upgrades for users.

Changed in samba:
assignee: nobody → fabbione
Mark Lassau (mark-lassau) wrote :

I looked at bug #9208 as suggested by Colas Le Guernic above.
I used:
  ls -l /etc/rc?.d/*samba
to find broken sym links
removed with:
  rm /etc/rc2.d/K09samba
  rm /etc/rc3.d/K09samba
And now Synaptic Manager upgraded samba fine.

I would note that bug 9208 mentioned VMWare as a possible cause of installing links, and I do have this installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers