Ubuntu

smbmnt no longer installed suid root

Reported by ltmon on 2006-10-23
4
Affects Status Importance Assigned to Milestone
samba (Baltix)
Undecided
Unassigned
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: smbfs

Upon upgrade to Edgy the binary /usr/bin/smbmnt is no longer installed with suid root.

For a normal user to be able to mount a samba share the user now has to "sudo chmod u+s /usr/bin/smbmnt".

This has occurred with my upgrade from Dapper to Edgy and another user who installed from Edgy RC1 (both on Kubuntu if it matters).

ltmon (lukemonahan) wrote :

This also goes for /usr/bin/smbumount

Ralph Janke (txwikinger) wrote :

Feature request

Changed in samba:
status: Unconfirmed → Confirmed
Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and help to improve Ubuntu.

This issue is resolved for the upcoming Ubuntu 8.04 because smbmount is now a wrapper around mount.cifs, which has the correct permissions set.

Changed in samba:
status: Confirmed → Fix Released
Changed in samba (Baltix):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers