Ubuntu

For Lucid server with Samba, console login times out

Reported by Carl Nobile on 2010-05-23
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

I have just upgraded a server running 9.10 to 10.04. When Ubuntu comes up and I try to log in with the same username and password I have used before I get "Login timed out after 60 seconds." However, if I try multiple times it will eventually let me in. I had set up ssh tokens on this server and I can log in remotely with no issues.

Adam Guthrie (therigu) on 2010-05-23
affects: ubuntu → gdm (Ubuntu)
Carl Nobile (cnobile1) wrote :

An additional issue I have found is that often when I need to use sudo the screen locks up immediately after I type in my password. On occasion it will time out, but most times I need to log in again and kill the session.

Daniel Dickinson (crazycshore) wrote :

a) I think gdm is the wrong package on several counts the most important being that this is a server install and there is no mention of a graphical login, and I experience this on an server with no console as well

b) I think this is related to samba / winbindd because when I checked the logs there were error messages related to winbindd (this is a Linux-only network, however it appears winbindd is now a default part of the Ubuntu installation).

c) I modified /etc/samba/smb.conf to have the line
auth methods = guest sam winbind

and logins on the console worked correctly where they hadn't before.

tags: added: samba winbind
tags: added: console login timeout

I had found mention of gdm being a related issues, but it wasn't
running on my server which I would expect because it's a server.

I am also running samba so I edited the file you mentioned and added the
auth methods = guest sam winbind
line to the [global] settings. However, I'm not physically near the
machine now so I can't test it at a VT until I get there.

Thanks, I hope this fixes the issue, but it seems we still have a bug
here and this is only a work around.

I wonder if this could also be causing another issue I am having. I am
running automount for my NFS mounts. When I log out then back in I
cannot get to the mounts any more. I need to run
$ sudo dpkg-reconfigure portmap <choose No>
$ sudo service portmap restart
to get them working again. Restarting alone doesn't fix it.

Should I enter another bug for this?

On Tue, May 25, 2010 at 12:54 PM, Daniel Dickinson <email address hidden> wrote:
> a) I think gdm is the wrong package on several counts the most important
> being that this is a server install and there is no mention of a
> graphical login, and I experience this on an server with no console as
> well
>
> b) I think this is related to samba / winbindd because when I checked
> the logs there were error messages related to winbindd (this is a Linux-
> only network, however it appears winbindd is now a default part of the
> Ubuntu installation).
>
> c) I modified /etc/samba/smb.conf to have the line
> auth methods = guest sam winbind
>
> and logins on the console worked correctly where they hadn't before.
>
> ** Tags added: samba winbind
>
> ** Tags added: console login timeout
>
> --
> Lucid server upgrade login times out
> https://bugs.launchpad.net/bugs/584428
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I was wrong....winbind line (and also disabling windbind in PAM) doesn't solve the issue for me. I seems once I successfully sudo I can login from the console just fine until I reboot.

Daniel Dickinson (crazycshore) wrote :

Ok, this time I really have solved it, at least for me. I have rebooted and login now works (using the change described below).

The problem is with the line:

auth optional pam_smbpass.so migrate

in /etc/pam.d/common-auth

Removing this line solves the problem. I haven't tested with winbind re-enabled yet, but I suspect it will work, and if winbind is disabled (using pam-auth-update), then login, with samba installed, works.

affects: gdm (Ubuntu) → samba (Ubuntu)
Daniel Dickinson (crazycshore) wrote :

Ok, I changed my smb.conf back to not having an auth methods line, and re-enabled winbind in PAM, but disabled the migrate line, and login works fine for me now.

Changed in samba (Ubuntu):
status: New → Confirmed
summary: - Lucid server upgrade login times out
+ For Lucid server with Samba console login times out
summary: - For Lucid server with Samba console login times out
+ For Lucid server with Samba, console login times out
tags: removed: winbind
Carl Nobile (cnobile1) wrote :

I have finally physically got to where the machine is and rebooted it after making the changes to /etc/pam.d/common-auth. This has solved the issues I originally posted here. It has not solved the portmap issues I mentioned above which indeed seems to be a completely separate issue.

Daniel thanks for the help.

I confirm that. But for me it would only timeout when I added more hard-disks to my machine. changing /etc/pam.d/common-auth solved the problem for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers