winbind pam-config potentially breaks stacking with modules of lower priority in common-passwd

Bug #556996 reported by Justin Jereza on 2010-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Low
Thierry Carrez
Lucid
Low
Thierry Carrez

Bug Description

Binary package hint: samba

Using requisite control for Password and Password-Initial in /usr/share/pam-configs/winbind potentially breaks stacking if there are other modules of lower priority.

FIX: Change requisite to [success=end default=ignore] for both Password and Password-Initial

Related branches

Steve Langasek (vorlon) wrote :

The fix for this has been committed to Debian svn and should be merged post-beta2.

Changed in samba (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in samba (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Thierry Carrez (ttx) on 2010-04-09
Changed in samba (Ubuntu Lucid):
assignee: nobody → Thierry Carrez (ttx)
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.4.7~dfsg-1ubuntu3

---------------
samba (2:3.4.7~dfsg-1ubuntu3) lucid; urgency=low

  * debian/winbind.pam-config: Fix potential breakage with stacking of
    lower-priority modules in common-passwd (LP: #556996)
 -- Thierry Carrez <email address hidden> Fri, 09 Apr 2010 16:50:07 +0200

Changed in samba (Ubuntu Lucid):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers