[SRU] Samba 3.4.0 won't let win98 clients to connect

Bug #502878 reported by Radek Krahl on 2010-01-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: samba

> lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

> apt-cache policy packagename
apt-cache policy samba
samba:
  Installed: 2:3.4.0-3ubuntu5.1
  Candidate: 2:3.4.0-3ubuntu5.1
  Version table:
 *** 2:3.4.0-3ubuntu5.1 0
        500 http://archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     2:3.4.0-3ubuntu5 0
        500 http://archive.ubuntu.com karmic/main Packages

There exist a bug in samba 3.4.0 (fixed in version 3.4.1), which doesn't allow windows 98 clients to connect to samba server. Samba bugzilla link is:

https://bugzilla.samba.org/show_bug.cgi?id=6551

It would be nice if changes mentioned there could be backported to ubuntu samba package. Recently we've upgraded our server to karmic and few of our computers still using windows 98 are unable to reach their shares.

Chuck Short (zulcss) wrote :

I plan on doing a whole bunch of samba SRU for karmic sometime next week. ill get this included.

chuck

Changed in samba (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Chuck Short (zulcss) wrote :

This has been fixed for lucid. It is a good candidate for an SRU.

chuck

Changed in samba (Ubuntu):
status: Triaged → Fix Released
Chuck Short (zulcss) on 2010-02-05
Changed in samba (Ubuntu Karmic):
status: New → In Progress
Chuck Short (zulcss) on 2010-02-05
summary: - Samba 3.4.0 won't let win98 clients to connect
+ [SRU] Samba 3.4.0 won't let win98 clients to connect
Chuck Short (zulcss) wrote :

Statement of Impact: Karmic shipped with a samba bug that prevented Widnows 98 client to connect to samba shares.

How this has been resolved: This has been resolved in upstream bug https://bugzilla.samba.org/show_bug.cgi?id=6551. It has been fixed upstream and for Lucid. I have backported the fix for karmic, which is attached to the bug report.

How to reproduce:

1. Install Samba on a Ubuntu Server.
2. Connect a Windows 98 Client to an Ubuntu Server. You should get the following error message:

Error 66: You have specified an incorrect network resource type. Your
possible choices are (1) drive letter A: through Z for a shared directory
path, or (2) port name LPT1: through LPT9 for a shared printer or modem path.

There shouldnt be a regression with this patch.

If you have any questions please let me know.

Regards
chuck

Accepted samba into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in samba (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.4.0-3ubuntu5.5

---------------
samba (2:3.4.0-3ubuntu5.5) karmic-proposed; urgency=low

  * debian/patches/fix-libsmb-keepalive-packets.patch: Fix winbind authentication
    due to an invalid NTML2 signature. (LP: #479955)
    (https://bugzilla.samba.org/show_bug.cgi?id=6646)
  * debian/patches/fix-samba-point-and-print.patch: Allow automatic download
    of printer drivers from a Samba PDC (LP: #500457)
    (https://bugzilla.samba.org/show_bug.cgi?id=6568)
  * debian/patches/fix-too-many-openfiles.patch: When connecting to a Windows
    7 share users will get an error message "Too many open files are in use"
    after a certain number of files are copied. (LP: #462172 )
    (https://bugzilla.samba.org/show_bug.cgi?id=6837)
  * debian/patches/fix-win98-failed-connect.patch: Allow win98 clients to
    connect a samba server. Users will get an "Error 66" message. (LP: #502878)
    (https://bugzilla.samba.org/show_bug.cgi?id=6551)
 -- Chuck Short <email address hidden> Fri, 05 Feb 2010 15:03:50 -0500

Changed in samba (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.