[SRU] Please backport fix for point&print samba support

Bug #500457 reported by Giovanni Bajo on 2009-12-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Wishlist
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: samba

Please backport this fix:
   https://bugzilla.samba.org/attachment.cgi?id=4508&action=view
   https://bugzilla.samba.org/show_bug.cgi?id=6568

It is required for point&print support (automatic download of Windows drivers from samba servers). Specifically, the upload procedure is totally broken without this fix.

Description: Ubuntu 9.10
Release: 9.10

samba:
  Installed: 2:3.4.0-3ubuntu5.3
  Candidate: 2:3.4.0-3ubuntu5.3
  Version table:
 *** 2:3.4.0-3ubuntu5.3 0
        500 http://it.archive.ubuntu.com karmic-proposed/main Packages
        100 /var/lib/dpkg/status
     2:3.4.0-3ubuntu5.1 0
        500 http://it.archive.ubuntu.com karmic-updates/main Packages
     2:3.4.0-3ubuntu5 0
        500 http://it.archive.ubuntu.com karmic/main Packages

Chris Johnston (cjohnston) wrote :

Recommending wishlist for possible update.

Chuck Short (zulcss) wrote :

Thanks for the bug report, Ill take a look at this.

Regards
chuck

Changed in samba (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Chuck Short (zulcss) wrote :

Thanks for the bug report. This patch has made it in to lucid. This would be a good candidate for an SRU.

Regards
chuck

Changed in samba (Ubuntu):
status: Confirmed → Fix Released
Giovanni Bajo (giovannibajo) wrote :

Any action I should take to request inclusion in a SRU?

Chuck Short (zulcss) wrote :

No it should be brought up in the meeting tomorrow.

Chuck Short (zulcss) on 2010-02-05
Changed in samba (Ubuntu Karmic):
status: New → In Progress
Chuck Short (zulcss) on 2010-02-05
summary: - Please backport fix for point&print samba support
+ [SRU] Please backport fix for point&print samba support
Chuck Short (zulcss) wrote :

Statement of Impact: The Samba shipped with karmic was shipped with a bug that prevented users to download printer drivers from a PDC.

How this has been resolved: This bug has been described in https://bugzilla.samba.org/show_bug.cgi?id=6568 and has been fixed upstream in Samba and for lucid. I have backported this patch for Karmic.

How to reproduce:

1. Setup a samba PDC.
2. Setup Samba for printer driver downloads:

http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/classicalprinting.html#id2626653

There should not be any regressions with this patch.

If you have any questions please let me know.

Regardds
chuck

John Dong (jdong) wrote :

Straightforward patch, definitely looks SRU-worthy. ACK from ubuntu-sru.

Chuck, how do you want to handle this vs #462172? One after the other or both at the same time?

Accepted samba into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in samba (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.4.0-3ubuntu5.5

---------------
samba (2:3.4.0-3ubuntu5.5) karmic-proposed; urgency=low

  * debian/patches/fix-libsmb-keepalive-packets.patch: Fix winbind authentication
    due to an invalid NTML2 signature. (LP: #479955)
    (https://bugzilla.samba.org/show_bug.cgi?id=6646)
  * debian/patches/fix-samba-point-and-print.patch: Allow automatic download
    of printer drivers from a Samba PDC (LP: #500457)
    (https://bugzilla.samba.org/show_bug.cgi?id=6568)
  * debian/patches/fix-too-many-openfiles.patch: When connecting to a Windows
    7 share users will get an error message "Too many open files are in use"
    after a certain number of files are copied. (LP: #462172 )
    (https://bugzilla.samba.org/show_bug.cgi?id=6837)
  * debian/patches/fix-win98-failed-connect.patch: Allow win98 clients to
    connect a samba server. Users will get an "Error 66" message. (LP: #502878)
    (https://bugzilla.samba.org/show_bug.cgi?id=6551)
 -- Chuck Short <email address hidden> Fri, 05 Feb 2010 15:03:50 -0500

Changed in samba (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.