Samba shared printers not accessible under Vista and Windows7

Bug #482836 reported by Herr Irrtum on 2009-11-14
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
samba
Unknown
Unknown
samba (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: samba

1. Ubuntu release:

#uname -a
Linux maedchentank 2.6.31-15-generic #49-Ubuntu SMP Fri Nov 6 09:55:13 UTC 2009 x86_64 GNU/Linux
# lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

2. involved packages:

~# apt-cache policy cups
cups:
  Installiert: 1.4.1-5ubuntu2.1
  Kandidat: 1.4.1-5ubuntu2.1
...
~# apt-cache policy samba
samba:
  Installiert: 2:3.4.0-3ubuntu5.1
  Kandidat: 2:3.4.0-3ubuntu5.1
...

3. What should happen:
Connecting to shared printers on my ubuntu 9.10 server from within windows vista64 and windows7 brings up the windows printer dialog - as is happened in ubuntu 9.04.

4, What happens instead

Connecting to shared printers on my ubuntu 9.10 server from within windows vista(64 Bit) and windows7 (64 Bit) brings a "Druckerverbindung kann nicht hergestellt werden - 0x0000000d" on Windows (exact english translation not known - should be something like "unable to connect to printer - 0x0000000d". Windows isn't telling more. The Windows Support Entry in the web about this error number is compete nonsense.
However Windows XP (32 Bit) clients connect without a problem.
Note that exactly the same Vista (64 Bit) machine (even without any LSA-Manipulations within the registry (as it is still recommanded here and there)) did work with the same smb.conf on the same server with ubuntu 9.04 (it was updated to 9.10 - meaning it was not a fresh install).
Typical folder shares on the server are no problem for vista and windows7.

BTW: Trying to get a clean new smb file is not easy because of this dpkg-reconfigure samba crash

# dpkg-reconfigure samba
 * Stopping Samba daemons [ OK ]
   [doing stuff within the nc gui until the "create /var/lib/samba/passdb.tdb?" Question and then...]
sed: -e Ausdruck #1, Zeichen 143: Unbekannte Option für `s'

However I am sure to have a clean smb.conf. The most interesting section is this (and I already tried to "open" it up as much as it may be helpful)

--------------------------------------------------
load printers = yes

   printing = cups
   printcap name = cups

[...]

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = yes
   read only = yes
   create mask = 0700
# inserted ny me
   use client driver = yes

# Windows clients look for this share name as a source of downloadable
# printer drivers

# disabling or not disabling - the [print$] Section is of course not changig anything here

# ----------------------------------
# [print$]
# comment = Printer Drivers
# path = /var/lib/samba/printers
# browseable = yes
# read only = yes
# # guest ok = no
# # changed by me
# guest ok = yes
# ---------------------------------

[...]
--------------------------------------------------

Security levels is users. Password backend is tdbsam.
Users trying to connect to the printers (2 printers - one usb and cups-pdf) are already connected to shared folders on the server successfully (so it is not a credentials problem from this side). They are also known to samba thanks to smbpasswd.

On the cups side both printers are set to shared. So anything should just work like it does perfectly with Windows XP Clients (32Bit) within the same network or like unter Ubuntu 9.04 with the same configuration (also with vista64 Clients there).

I've tried alot about this with no success.
I was surprised not to find a bug report about this, because, if you google about "karmic printer vista" you find a lot forum questions about this - and they all try a lot even unrelated things to get rid of this - but the issue remains unsolved.
Like here: <http://ubuntuforums.org/showthread.php?p=8263192>

Sidenote: Also strange: After starting/restarting the whole server, all samba folder shares work perfectly - but not even one printer is showing up (at least not on the vista/win7 clients here). Doing a "/etc/init.d/samba restart" on the server makes them visible. This can't be a sort of "late usb printer detection" issue, as cups-pdf shouldn't be affected by such things. I did not investigate much into this however.

Regards,
Herr Irrtum.

Chuck Short (zulcss) on 2009-11-18
affects: samba (Ubuntu) → cups (Ubuntu)
freeomega (freeomega) wrote :

Bump. This problem is still present as of today. Samba and config file were working perfectly on 9.04 x86, before doing a full reinstall using a x64.

- Linux box: Karmic x64 w/ samba shared printer;
- Win7 x86 client works fine;
- Win7 x64 does not work. Can't connect network printer (unable to connect to printer - 0x0000000d).

As mentioned, other users having the same problem here: http://ubuntuforums.org/showthread.php?p=8263192

Thanks,
Freeomega

This problem is still present when trying to add a printer from a Karmic Samba/CUPS print server when using any Windows 64bit client. i.e. Tested on Windows XP 64bit and Windows 7 64bit.

32bit versions of Windows XP on the other hand can add and print to the printer just fine.

Just like in the initial bug description, the printer is a RAW CUPS device with Samba configured to use the client driver.
* The CUPS-native drivers cannot be used as specific features of the Windows print driver is required.

The interim workaround has been to use:
net use lpt2 \\server\printer
And then setup the printer as a local printer on LPT2 with the native Windows driver.

This has been successful with both Windows XP 64bit and Windows 7 64bit.
Still it would be nice to be able to setup the printer the standard way...

David

dalbjerg (kenneth-dalbjerg) wrote :

I too have this problems.

Is anybody working on this bug?

Just a follow up - Jeremy Allison has pointed out the problem on this Samba discussion thread:
http://lists.samba.org/archive/samba/2010-January/153456.html

The short answer is printing in the 3.4 branch of Samba needs a lot of development tweaking.
To get around this problem I have 'downgraded' to the Debian Samba 3.3.10 packages provided by SerNet:
http://enterprisesamba.org/

Point and print works without any issues and so does printing from 64bit Windows desktops.

David

Wolkenjaeger (wolkenjaeger) wrote :

Another workaround (and in my opinion an easier one):

Win7 -> Start -> Hardware & Printers -> Add Printer -> Network/Printer

- now select "The printer that I want wasn't listed" even if it's there!
- select "... by Name" and enter your cups address of the printer: https://<hostnameORip>:631/printers/<printername> (if it does not work, try http instead of https
- choose correct driver et voilà!

Gijs Molenaar (gijzelaar) wrote :

I've applied the patch from here:
https://bugzilla.samba.org/show_bug.cgi?id=6888

to the original Ubuntu Karmic packages. It works. I've made packages of them and uploaded them to a PPA:

https://launchpad.net/~gijzelaar/+archive/samba-karmic

bbackx (ben-bbackx) wrote :

@Wolkenjaeger:
Tnx, that worked like a charm for me!

crazydave (crazy-dave) wrote :

Very frustrating for me... I know figured out how to integrate the Cups Printer in our Active Directory and now the x64 machines are not working - and no new package for Ubuntu :-/ (not in lucid-backports nor in maverick)

Someone has info when Ubuntu will release newer packages?!

Cheers,
David

Gijs Molenaar (gijzelaar) wrote :

This bug is solved in Lucid. If you use karmic you can use these packages:

https://launchpad.net/~gijzelaar/+archive/samba-karmic

Scott Moser (smoser) wrote :

@Gijs,
  If this bug is fix-released, please mark it as such.

Gijs Molenaar (gijzelaar) wrote :

@Scott:
I was in the impression I can't do that, since I don't 'own' this bug

Herr Irrtum (die-nmi) wrote :

I decided to change the status to "Fix Released". Sorry for not reacting for a long time - even after the fix was released, I wasn't aware that it's on *me* to close the bug (it it's on me that is).If there is another way to "close" this bug tell me - right now I see no other option.

Changed in cups (Ubuntu):
status: New → Fix Released
Changed in samba (Ubuntu):
status: New → Fix Released
crazydave (crazy-dave) wrote :

It's not working for me in Lucid. What package version should work under Lucid?!

crazydave (crazy-dave) on 2010-06-16
description: updated
crazydave (crazy-dave) wrote :

I will describe my problem:

What I want to do: share CUPS printers with Windows 64Bit Clients (Win XP/2003 and Win 7/2008). The clients should get the printer drivers from the CUPS server. First target is to share the PDF printer.
Installation on Lucid. CUPS Version 1.4.3-1ubuntu1; Samba Version: 2:3.4.7~dfsg-1ubuntu3

How the printer gets installed: Open explorer and go to \\printserver\ the right click on the PDF printer and click "connect".

With Windows 32bit clients the printer gets installed and printing a test page works perfect.

With Windows 64bit clients there are different symptoms:
On Win XP/2003 64bit the printer gets installed. The files ( cups6.ini cupsps6.dll cupsui6.dll PDF.ppd ps5ui.dll pscript5.dll pscript.hlp pscript.ntf PDF.ppd) show up in the c:\windows\system32\spool\drivers\x64\3\ folder. But right click on the installed printer to enter the "printer settings" brings up "The 'PDF' printer driver is not installed on this computer. Some printer properties will not be accessible unless you install the printer driver. Do you want do install the driver now?" - click on "No" brings up the Printer Properties page but printing a test page is not possible!

On Win 7/2008 64bit clients when I try to right click and choose "connect" It starts to copy some files and then I get the message "Windows cannot connect the printer. 0x000000d8". When I search for the ppd file or cups files on this client - nothing shows up.

Attached you will find the samba.log from the connection of a Win 2008 64bit client.

I'm not sure what causes this problem. Please let me know if you need more information.

Herr Irrtum (die-nmi) wrote :
Download full text (3.5 KiB)

Ok then. Someone in the comments mentioned that there is a fix which is included in Ubuntu 10.04 and also available via PPA for ubuntu 9.10. Whatever made you write this, Gijs Molenaar , it is not fixed. It's still not fixed within samba if you look at the status of the bug over there at samba (https://bugzilla.samba.org/show_bug.cgi?id=6888). However I appreciate your actions (to find the upstream original bug description and even do the package making!!) - this should have helped a lot of people - but in this case unfortunately doesn't --> so please *before* you claim it's fixed - test it . Under the conditions which are described in the bug description. Even if the samba people say it is. In this case - I repeat - it is not.
Which brings me to a second note:
Chuck Short - almost immediately after I filed this bug (as a Samba bug) you enhanced it in order to be a Cups bug as well. But why? This confuses the devs, this doesn't help anyone. As I described and other people told: It *works* with windows clients (32 bit), it works with linux *clients* - heck - it even works with Windows 7 if you redirect LPT1 or create a direct IP connector. Which is not stable (for Windows specific reasons). But it works for a moment.
It is so overwhelming clear, that this is Samba in the first place. Why CUPS then?
If a Cups dev/packager comes and sees what is actually going on... he will turn his back, mumbling that this is something for the samba guys.
If a Samba developer comes in he will realize that this is filed under "Cups" - so he will say that in the first place the cups guys are responsible.
And in the end there is the result: Deadlock.
That's why I wont change the hint that "a fix is released"for the "cups"-filed version .
Please read carefully, what Crazydave is writing (I discussed some things with him behind the scenes) - he has very precise experiences with this bug and above my description he even focuses on automatic driver rollout mechanisms which work fine (!!) with Windows 32 Bit Clients - but not with windows 64bit clients.

What about SMB2 ? (http://en.wikipedia.org/wiki/Server_Message_Block --> "Microsoft introduced SMB2 with Windows Vista in 2006."). I remember that samba had a hard time and needed more than half a year to make Vista 32 bit clients speak to printer shares.
Maybe in 64bit space some parameters of the SMB2 implementation are different. This is something for upstream samba tough.

All in all - I am out. I have no time to do further things here. Which is because I do not depend on Windows anymore (I had a very new AMD GFX card back when I filed the bug, that's why I was on Windows7 with one of my PCs back then when I filed the bug).
Good luck to dave and the others figuring this out.

Maybe someone should compare this to a different Linux (maybe rolling-release distros like Arch or Gentoo) which may have a more up to date package of samba (and well - cups). Even better: A fresh from SVN sources compiled samba - all this to compare things. Just to make sure first of all if this is Ubuntu related or upstream related. Right now it feels more upstream related for me.
Again: I do not have the time to check...

Read more...

Changed in samba (Ubuntu):
status: Fix Released → Incomplete
pirlo (admin-pirlo) wrote :

Same problem here with Ubuntu Lucid 10.04.3 and samba 3.4.7 - 32 bit driver works like charm, 64 bit driver gives the message with 0x000000d8.

one year is a very very long time for a bug!

if you have hunderts of computers you don't really want to user lpt oder ipp printing with local drivers....

will this bug ever be fixed?
ist it fixed in 10.10 or 11.04?

pirlo (admin-pirlo) wrote :

btw tried to install printer with konica minolta bizhub 283 driver from this website:
http://download6.konicaminolta.eu/konmin/public/&&BEU&DE&sw&&&&&0&&&0&&0&&0
(Druckertreiber PCL6 PCL6 driver (WHQL) for KONICA MINOLTA bizhub 423/363/283/223 1.1.2.0 2010-06-01)

James Page (james-page) on 2012-04-27
Changed in samba (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Mathew Hodson (mhodson) on 2016-07-17
affects: fedora → ubuntu
Changed in ubuntu:
status: New → Confirmed
Mathew Hodson (mhodson) on 2016-07-17
no longer affects: ubuntu
Changed in cups (Ubuntu):
importance: Undecided → Medium
no longer affects: cups (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.