Samba returns NT_STATUS_NOT_SUPPORTED when trying to view list of shares

Bug #472681 reported by hazylazysusan on 2009-11-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: samba

Whenever I try and get a listing of shares from the Windows 7 computer... "Error returning browse list: NT_STATUS_NOT_SUPPORTED." Printing using CUPS also fails with "Session Startup Failed: NT_STATUS_LOGON_FAILURE" and I can't see anything. Seems very pervasive! Just upgraded to Karmic, yet everything samba-related on Jaunty and Intrepid was perfect.

danwood76 responded here and thinks this is a bug in Karmic's samba: http://ubuntuforums.org/showpost.php?p=8230150&postcount=23

"Ok I am having this same problem.

The only live CD I have is for 8.10 and that works with my Windows 7 machine perfecty.

So I downloaded the latest samba source and compiled it, guess what?
smbclient now works and going to smb://{WINDOWS 7 MACHINE NAME} allows me to view the shares on that machine.

So I assume this is a regreassion as to a configuration issue as the old config files still work with the newer version of samba."

hazylazysusan (hazylazysusan) wrote :

The only thing is that I'm on a normal workgroup, not domain, as in that bug.

Chuck Short (zulcss) wrote :

My mistake, please add the log file for /var/log/samba/log.smbd.

Thanks
chuck

hazylazysusan (hazylazysusan) wrote :

I have attached the log.

Chuck Short (zulcss) wrote :

Can you attach the output of smbclient //<windows 7 machine> -L -d 10

Thanks
chuck

Changed in samba (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
hazylazysusan (hazylazysusan) wrote :

Hello, hope this is what you wanted.

Danny Wood (danwood76) wrote :

As milky-cow-101 has stated I also recieve this problem.
I have attached the outputs of mine on the default karmic smbclient and with version 3.4.1 (which works)

I will also add to this that it extends to nautilus which uses libsmbclient to access windows shares and also fails but with an obscure error of "Failed to retrieve file list"

Personally I think this is a huge show stopper for many people who are now using Win 7 on other machines on their networks. It is definitely a regression from previous versions as I have tested in Intrepid and it functions perfectly!

Danny Wood (danwood76) wrote :

Forgot the attachment

Danny Wood (danwood76) wrote :

Also I meant version Samba 3.4.3 for this log

Danny Wood (danwood76) wrote :

Ok further testing.

With a version samba v 3.4.1 and 3.4.2 smbclient is also the same so I assume the bug is in samba versions 3.4.0 to 3.4.2.
I will try and find the relevant bug report later as it has obviously been fixed between 3.4.2 and 3.4.3

Chuck Short (zulcss) wrote :

Can you guys enable karmic-proposed and test out that version?

Thanks
chuck

hazylazysusan (hazylazysusan) wrote :

Diffrent error now

hazylazysusan (hazylazysusan) wrote :

sorry about that

gnome terminal keeps cuttign it off. here's some of it.

Danny Wood (danwood76) wrote :

Wow, that was very fast. Was this a package already in the system?
I can confirm that the package in proposed fixes the issue in both smbclient and in nautilus browsing.

Good work, I have attached the output of the smbclient command so you can compare if you like.

hazylazysusan (hazylazysusan) wrote :

Yay, so after a restart, everything works now! Thank you so much.

lazycat (fallleaveassad) wrote :

I have the same problem, what package should I install?

Danny Wood (danwood76) wrote :

You have to enable the proposed updates but I would only update the samba packages though through synaptic.
The package will get pushed into main soon though if you can be patient.

lazycat (fallleaveassad) wrote :

Im very new to Linux, could you tell me how do I enable propose updates in Synaptic? thank you

lazycat (fallleaveassad) wrote :

After google search , is it the one that you are talking about? https://wiki.ubuntu.com/Testing/EnableProposed

The problem is I have one ubuntu server (without ubuntu-desktop), I don't know how to update it using CLI

Danny Wood (danwood76) wrote :

https://help.ubuntu.com/community/Repositories/CommandLine

Just add this line to the bottom of the /etc/apt/sources.list file:
deb http://gb.archive.ubuntu.com/ubuntu/ karmic-proposed main multiverse universe

sudo nano /etc/apt/sources.list
scroll to the bottom and add this line.

save and exit

sudo apt-get update
sudo apt-get install samba libsmbclient

then you probably want to remove that line again afterwards as some of the updates have the possibility to break your system in that repo.

lazycat (fallleaveassad) wrote :

Worked perfectly without restarting. Thank you very much danwood76

Chuck Short (zulcss) wrote :

This is fixed in lucid.

Regards
chuck

Changed in samba (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers