cannot access samba share after mount.cifs

Bug #320212 reported by Marc G. on 2009-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: smbfs

I can mount a windows share with this command in terminal. But when I do 'ls' in the mount directory, I get a segmentation fault. If I try to 'cd' in the same directory, the terminal crash.

I mounted the share with this command :
sudo mount.cifs //ipadress/data/Groupe /mnt/groupe/ -o username=workgroup/user --verbose

I get : mount.cifs kernel mount options unc=//ipadress\data,ip=192.168.2.15,domain=workgroup,pass=xxxxxx,ver=1,username=user,,,,,,,,,,,,,,,,prefixpath=Groupe

I cannot unmout after mounting, ie the mount is still listed when I type 'mount'. I get in verbose mode :
optind 2 unmount dir /mnt/groupe

Nautilus cannot mount this share either. I get an error message : "No file or folder of this type". //ipadress/data is mounted but it is empty (no folder named Groupe).

The window share is accessible from a windows XP computer and with smbclient with this command :
smbclient //ipadress/data/Groupe --user=workgroup/user
It is then possible to do "smb: \> ls" after and to see all the files in the folder.

I'm using Ubuntu 8.10 and the version of smbfs is 2:3.2.3-1ubuntu3.4

Thierry Carrez (ttx) wrote :

Several CIFS fixes were pushed to the latest intrepid kernel in -proposed, could you test it and report if the failure is still there ?

Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in samba:
status: New → Incomplete
Marc G. (marc-gu) wrote :

Updated to kernel 2.6.27-11 and the problem is still present.

Thierry Carrez (ttx) on 2009-01-25
Changed in samba:
status: Incomplete → New
Marc G. (marc-gu) wrote :

I tried with the version 2:3.2.3-1ubuntu3.5 of samba available in -proposed and the problem is still present.

I tried with the Ubuntu Desktop 8.04.2 amd64 LiveCD and I get something different. After mounting the share, I'm able to "ls" or "cd" in the share directory without causing a crash or a segfault. I'm also able to unmount the share. But it is //ipadress/data/ that is mounted instead of //ipadress/data/Groupe. I can see the folder Groupe and other but these folders also contain another folder Groupe and the others (it should not). The command "ls /mnt/groupe/Groupe/Groupe/" return : "ls: reading directory .: Object is remote"

Thierry Carrez (ttx) wrote :

Weird. Where is your share located ? Windows box, NAS, another Samba server ? Does "cat /proc/fs/cifs/DebugData" return anything after the mount ?

Changed in samba:
status: New → Incomplete
Marc G. (marc-gu) wrote :

The share is on a Windows box. This is a server of an university so I cannot try anything special on it.

This is the output of "cat /proc/fs/cifs/DebugData" :

Display Internal CIFS Data Structures for Debugging
---------------------------------------------------
CIFS Version 1.54
Active VFS Requests: 0
Servers:
1) Name: 192.168.2.15 Domain: WORKGROUP Uses: 1 OS: Windows Server 2003 R2 3790 Service Pack 1
 NOS: Windows Server 2003 R2 5.2 Capability: 0x1f3fd
 SMB session status: 1 TCP status: 1
 Local Users To Server: 1 SecMode: 0xf Req On Wire: 0
 Shares:
 1) \\192.168.2.15\data Mounts: 1 Type: NTFS DevInfo: 0x20 Attributes: 0x700ff
PathComponentMax: 255 Status: 0x1 type: DISK

 MIDs:

Thierry Carrez (ttx) on 2009-01-30
Changed in samba:
status: Incomplete → New
Brian Curtis (bcurtiswx) wrote :

Marked as Triaged and Medium Importance as it deals with "# A problem with a non-essential hardware component (network card, camera, webcam, music player, sound card, power management feature, printer, etc.) "

Changed in samba:
importance: Undecided → Medium
status: New → Triaged
Thierry Carrez (ttx) wrote :

That's probably a DFS share, which is... not well supported, to say the least. Will mark as duplicate of bug 134080

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers