smb mounts stop working after idle time

Bug #310932 reported by Phoenix on 2008-12-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Unknown
High
samba
Unknown
Unknown
samba (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox

I have a two Samba Servers, one on Suse 11 and one on FreeBSD and Ubuntu Desktop shows the same problems.

I have some Network Resources bookmarked. When I need to access a certain place, I simply use the bookmark, which works fine and a Shotcut is created on the desktop, which also works great. After idleing around, I like to access the network share again but the shortcut on the Desktop errors out, so does the bookmark - the errors are attached.

I have to unmount the resource and access it then via the bookmark (abviously as the desktop shortcut gets removed) and can happily access the network resource.

Desired effect: - I like to access my Samba Server independently of how much time passed meanwhile

Phoenix (phoenix-dominion) wrote :
Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

the issue is similar to http://bugzilla.gnome.org/show_bug.cgi?id=539593, should be sent to bugzilla.gnome.org by somebody having the bug

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=578139

summary: - Network mounts (smb) stop working after idle time
+ smb mounts stop working after idle time
Changed in gvfs (Ubuntu):
status: New → Triaged
Changed in gvfs:
status: Unknown → New
Changed in gvfs:
importance: Unknown → Medium
Changed in gvfs:
importance: Medium → High
status: New → Confirmed
Changed in gvfs:
status: Confirmed → Unknown
affects: gvfs (Ubuntu) → samba (Ubuntu)
Changed in samba (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:4.1.13+dfsg-4ubuntu3

---------------
samba (2:4.1.13+dfsg-4ubuntu3) vivid; urgency=medium

  * debian/patches/git_timeout_client_error.patch:
    - don't let smb mounts timeout that leads to errors when trying to
      reuse a mount after idling for a while in e.g nautilus (lp: #310932)
 -- Sebastien Bacher <email address hidden> Fri, 03 Apr 2015 17:20:06 +0200

Changed in samba (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.