System freeze when working on Samba or Cifs mounted share of NetApp server

Bug #307408 reported by vogu on 2008-12-12
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by untill
samba (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by untill

Bug Description

I have a server from Network Appliances that I mount on my Xubuntu 8.10 via SAMBA or CIFS. Mounting a share from that server is ok, but when changing to a directory below that mountpoint, the system quickly crashes.

The directory in which one I change has some 250 directory entries. In the few cases, where the system doesn't crash and where I can do an "ls", the result only shows some 145 of the 250 directories.

As I told, the system normally freezes. It does this nearly every time when entering "cd" followed by TAB (for bash completion). In that case, nothing works any longer, not the mouse nor the keyboard. The system can even not be pinged any longer.

I do not use any special mount options, just
   mount.cifs //server/share /mnt/xxx
or
   mount.smbfs ...

I can easily reproduce the problem on
 - Ubuntu 8.10
 - Xubuntu 8.10
 - Debian Lenny (since I updated it 14 days ago; before that update, there was no problem)

The problem does not appear on
 - Ubuntu 8.04
 - Debian Etch

There's no problem mounting a Samba share on a Linux server; the bug only occurs when mounting a NetApp share.

I made my tests on 4 different PCs with the same results everywhere.

I saw a similar bug report with the number 296304. Although the server there is a Wind98 oldtimer, the effects seem to be the same.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in samba.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Barry Morrison (basketcase) wrote :

I'm having this same issue myself.

Edited /etc/fstab to mount two shares off a NetApp. System completely locks up and I have to turn the system off.

If I use the GUI to mount them, they mount, but when I try and open a file/directory, again the system completely locks up.

Alex (akruth) wrote :
Alex (akruth) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

Changed in samba:
importance: Undecided → Medium
status: New → Triaged
Andy Spiegl (spiegl+ubuntu) wrote :

You are not alone!

I just (unwillingly *sigh*) reproduced the bug here on my workstation
(Ubuntu 8.10, 32bit, with all available updates) and a NetApp share.
The first ls showed only 148 of the available 288 files in a directory.
After some more ls (or cp) the kernel crashed.

Andy.

Alex (akruth) wrote :

I don't believe this is a bug of samba. When using smbclient directly this effect does not apply, i.e. no crashes or missing directory entries. Also no problem with Ruby/SMB (http://rubysmb.sourceforge.net/) for example.

Is there anything between "ls" and samba?

untill (till-etill) wrote :

I can confirm this issue with 8.10, and I can reproduce.

The system will freeze after mounting at any time, lasting from immediately to several hours, where 1 minute or so is most common. Keyboard LEDs usually start blinking.

I'm not a kernel dev, but how possibly can a bug like this take out the entire system? Sounds like two bugs to me: On in this package (BTW is this a module?) and one in the kernel.

I just confirmed with our admins that Iæm mounting a against a NetApp server.
My other data: Linux localhost 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

Thierry Carrez (ttx) wrote :

Might be a dupe of bug 286828. Could you test the kernel in intrepid-proposed together with the "nodfs" mount parameter as explained there ?

Changed in samba:
status: Triaged → Incomplete
Alex (akruth) wrote :

I just tested with the new kernel from intrepid-proposed, it indeed works with it with and without "nodfs".

Barry Morrison (basketcase) wrote :

I upgraded to 2.6.27-11-generic from Intrepid-proposed and it seems like it may be working. I haven't gotten it to lock up yet. Will report back. Wish I could contribute more, but the system locks up and I have to power down. Nothing in /var/log/syslog or /var/log/samba/*

I can't ssh into the box, if I have an active connection via ssh, it kills it.

vogu (vogu00) wrote :

I added the nodfs mount option in fs/cifs/connect.c in my intrepid kernel (2.6.27-2), recompiled the kernel, installed it and restarted. I mounted the NetApp share with that option. The bug still persisted (system freeze). So, that's no solution.

I then tried intrepid-proposed (kernel 2.6.27-11) and can confirm that the bug has gone. It works with and without the nodfs mount option.

Thierry Carrez (ttx) wrote :

So it's a different problem, but some other fix in 2.6.27-11 fixed it.

Changed in samba:
status: Incomplete → Fix Committed
Andy Spiegl (spiegl+ubuntu) wrote :

I can confirm, too that the intrepid-proposed (kernel 2.6.27-11)
solves the issue. Now I can see all 276 files on the nfs-share
(before only 149) and no crash anymore. Whoopie!

But I can't find anything related in the kernel changelogs.
Does anybody have an idea which change did the trick?

Thx,
 Andy.

vogu (vogu00) wrote :

The solution must be somehere in the version 2.6.27-3 ... 2.6.27-11
Does anybody know if there's an archive of the debian packages of these kernel versions somewhere? If so, I could try the different kernels one by another in order to find out when it started working. That way, we could reduce to a minimum the number of changes that might have an influence.

Thierry Carrez (ttx) wrote :

Moving to "linux" since the kernel in proposed solves the problem

Changed in linux:
status: New → Fix Committed
Changed in samba:
status: Fix Committed → Invalid
Steve Langasek (vorlon) wrote :

Does anyone know if this is fixed in the kernel in jaunty? I don't have access to a NetApp to test against.

Barry Morrison (basketcase) wrote :

I upgraded a box to the latest 9.04 over the weekend. I should be able to take it to work and verify if it is/isn't fixed in 9.04.

vogu (vogu00) wrote :

As the kernel update 2.6.27-11 became available today, I redid the whole NetApps-tests on one of my boxes:

- Installed 8.10 with no updates: Freezes
- Updated 8.10, kernel is 2.6.27-11: Runs
- Upgraded to 9.04, kernel is 2.6.28-5: Runs

:-)

Barry Morrison (basketcase) wrote :

I copied/pasted my /etc/fstab from my working 8.10 box with the proposed kernel to my latest 9.04 install. Paths are the same as far as mount points and location of .smbcredentials and I get this error:

mount: wrong fs type, bad option, bad superblock on //10.10.9.42/oit$/systems,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail or so

mount: wrong fs type, bad option, bad superblock on //10.10.9.42/bmorriso,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail or so

Now if I just go to 'Places' 'Connect to Server' and connect to the shares that way. It works. I'm able to browse the share, open documents, files, whatever else...even write to them. Never crashed once, unlike the old 8.10 that would crash almost instantly. I'd say it is fixed in 9.04.

FWIW:
~$ uname -r
2.6.28-5-generic

Eric Krieger (grammatoncleric) wrote :

I can also confirm that I too can mount and browse large cifs shares (i.e. with 144+ files and directories) on a netapp san with the new kernel update.

Thierry Carrez (ttx) on 2009-03-04
Changed in linux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers