samba got "ERRDOS - ERRnoaccess" error after upgrade from Gutsy to 8.04

Bug #297758 reported by Estro on 2008-11-13
4
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: samba

I've just tried to upgrade one of my Gutsy machines to 8.04. The upgrade went fine except that after the upgrade my Gutsy machines cannot access the Samba share on the 8.04 machine, while the 8.04 machine can still access the old samba share on the Gutsy machine.

When I tried to "sudo mount /mnt/rock" from a Gutsy machine, mill, I got

13873: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

However, I can still mount an old share in my Gutsy machine from the new 8.04 machine. The related information are listed below. I have been Googling several days and still cannot got this problem resolved. Please help.

===========================================================
On the newly upgraded 8.04 machine: rock
$ testparm
(see the attached file for output)
$ smbclient -V
Version 3.0.28a

on old Gutsy machine: mill
# the line in /etc/fstab
//rock/inbox /mnt/rock smbfs rsize=8192,wsize=8192,timeo=14,intr

$ smbclient -V
Version 3.0.26a

$ smbclient -L rock
Domain=[ROCK] OS=[Unix] Server=[Samba 3.0.28a]

        Sharename Type Comment
        --------- ---- -------
        print$ Disk Printer Drivers
        inbox Disk
        IPC$ IPC IPC Service (rock server (Samba, Ubuntu))
        PDF Printer PDF
Domain=[ROCK] OS=[Unix] Server=[Samba 3.0.28a]

        Server Comment
        --------- -------

        Workgroup Master
        --------- -------
        WORKGROUP ROCK

Estro (benkial) wrote :
Estro (benkial) wrote :

I think I figured out the problem, even thought I am not totally sure what causing it...

The problem got resolved by adding "username=jmill" in the /etc/fstab file as follows, which was not needed before the upgrade. But somehow, after adding the username to the fstab line, I can now mount the remote share.

//rock/inbox /mnt/rock smbfs username=jmill,rsize=8192,wsize=8192,timeo=14,intr

Ante Karamatić (ivoks) wrote :

Having:

//rock/inbox /mnt/rock smbfs rsize=8192,wsize=8192,timeo=14,intr

in fstab is wrong. In your samba server setup you have 'valid users' for inbox share. But, with line like this one doesn't specify a user. So, your client connects to a share as anonymouse. I find it strange if it worked before.

Changed in samba:
importance: Undecided → Medium
status: New → Triaged
Thierry Carrez (ttx) wrote :

Closing it since the reporter confirmed having fixed it using the username= parameter. I guess the difference comes from the SMBFS/CIFS transition.

Changed in samba:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers