Public shares not possible in home folder (Hardy 8.04)

Bug #294728 reported by Max-Ulrich Farber on 2008-11-06
2
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: samba

Folders in my home directory can not be shared with guest access permission, even if the acces mode is set to 0777. That is the case with net usershare as well as with shares in /etc/samba/smb.conf. The automatic adding of permissions in Nautilus does not help either.

Obviously this is a bug in samba 3.0.28 a ( Ubuntu 8.04 Hardy Heron), because it is fixed in Samba 3.2.3 (Ubuntu 4.10 Intrepid Ibex). Please fix it in Hardy too (Hardy is LTS!).

On Thu, Nov 06, 2008 at 03:26:50PM -0000, Max-Ulrich Farber wrote:
> Folders in my home directory can not be shared with guest access
> permission, even if the acces mode is set to 0777. That is the case with
> net usershare as well as with shares in /etc/samba/smb.conf. The
> automatic adding of permissions in Nautilus does not help either.

Could you post the configuration section you're using in smb.conf to
setup the share? Could you also post the configuration section you're
using for the net usershare configuration?

 status incomplete

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in samba:
status: New → Incomplete

What do you actually mean by "configuration section"? The few lines for the share only or the [global] part also?

[Gemeinsam]
path = /home/farber/Gemeinsam
available = yes
browsable = yes
public = yes
writable = yes

The share is not accessible at all even if /home/farber/Gemeinsam is set to mode 0777. As soon as I comment out the line "# public = yes", personal access is possible.

@ Mathias Gug

Is that what you did need?

Perhaps that can help you: Public shares inside a directory (in this case it is "/home/farber/") are possible only if the access to the *whole* directory is allowed for everyone. This is not normal. It should be enough to allow access to the share. It had always been like that before, and it is so in Intrepid again, but not in Hardy. Nobody would like to set his entire home directory to mode 0777 to be able to install public shares!

I am surprised that the status of this bug report is still "incomplete".

The bug must be known by the samba crew, because it is fixed in samba 3.2.3 implemented in Intrepid.

What I am asking for is to fix it in Hardy too because Hardy is LTS!

Thierry Carrez (ttx) on 2008-12-01
Changed in samba:
status: Incomplete → New
Changed in samba:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.2
Thierry Carrez (ttx) wrote :

Can't reproduce this on hardy.

Starting from a virgin minimal install:
$ sudo apt-get install samba (3.0.28a-1ubuntu4.7 gets installed)
$ mkdir ~/Gemeinsam
$ chmod 0777 ~/Gemeinsam
and defining the [Gemeinsam] share as stated in comment 2: I can read/write to the share alright.

Maybe you changed the default home directory permissions on your hardy host ?

Changed in samba:
status: New → Incomplete

I was not at home last week. Sorry for not answering sooner.

Thierry Carrez is right; the bug seemes to be fixed now. I have done nothing else but installing the usual updates, and public shares now do work in Hardy as well as in Intrepid.

Thanks, Max

Thierry Carrez (ttx) wrote :

Then we'll suppose it got fixed by own of the numerous hardy Samba SRUs.
Thanks for your confirmation, Max-Ulrich.

Changed in samba:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers