smbmount/smbmnt/mount.smb iocharset,codepage options don't work

Bug #29413 reported by Juan Diaz on 2006-01-23
6
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Medium
Unassigned

Bug Description

when we specify a charset translation (e.g. iso88859-1) in mounting a smbfs (a Windows' shared folder), there is no conversion charset.

For example,

$ mount.smb //winpc/shrfolder /mnt/shared -o rw,username=usr,uid=linuxusr,codepage=cp1252,iocharset=iso8859-1

doesn't make any conversion.

I can confirm this, with mount.cifs it works as it should. In breezy it worked too I think, the default iocharset in breezy also was utf8, which it isn't anymore. (I never tried to change it in breezy, because utf8 was what I needed)

Juan Diaz (juandiazq) wrote :

I've tried the following command line:

sudo [mount.cifs|mount.smb] //winpc/shrfolder /mnt/shared -o username=usr,uid=linuxusr,iocharset=utf8,codepage=cp850

and it has worked perfectly: folder and filename special chars are shown correctly. However, if no options are set (leave default options), there are invalid encoding errors.

Thanks a lot.

Changed in samba:
status: Unconfirmed → Confirmed
Steve Langasek (vorlon) wrote :

samba (3.0.27a-2ubuntu1) hardy; urgency=low

  * Merge from debian unstable (LP: #174296), remaining changes:
    * debian/patches/VERSION.patch:
      - set SAMBA_VERSION_VENDOR_SUFFIX to Ubuntu
    * debian/smb.conf:
      - Add "(Samba, Ubuntu)" to server string.
      - Comment out the default [homes] shares and add more verbose comments to
        explain what they do and how they work (LP #27608). Also, add a
        comment about "valid users = %S" to show users how to restrict access
        to \\server\username to only username.
      - default passwd chat value is modified
    * debian/samba-common.config:
      - do not change priority to HIGH if dhclient3 is installed
      - use priority medium instead of high for the workgroup question
    * Set Ubuntu maintainer address.

samba (3.0.27a-2) unstable; urgency=low

  * debian/patches/disable-weak-auth.patch: disable plaintext authentication
    on the client, and lanman authentication on both client and server, by
    default since these are only needed for Win9x or Samba with encrypted
    passwords disabled and are potential password attack vectors. This
    change is backported from Samba 3.2. LP: #163194.
  * Don't build the userspace tools for the deprecated smbfs kernel driver
    anymore; instead, use a shell wrapper around mount.cifs that translates
    option names between the smbfs and cifs drivers.
    Closes: #169624, #256637, #265468, #289179, #305210, #410075;
    LP: #29413
  * debian/panic-action: detect when we're on an Ubuntu system and direct bug
    reporters to Launchpad instead of to the Debian BTS. Closes: #452940.
  * debian/samba.init: call log_progress_msg separately for each daemon on
    stop rather than passing a second arg to log_daemon_msg, for greater
    compatibility with both Debian and Ubuntu LSB initscript implementations.
    Closes: #453350.
  * Drop smbldap-tools to Suggests:, consistent with the textbook meaning of
    recommends/suggests which is now implemented correctly in apt.
    Closes: #453144.
  * Get rid of the build-dependency on type-handling:
    - add a new target, "update-archs", to be invoked by hand to refresh
      the list of known Linux architectures for the libacl1-dev
      build-dep; this avoids the clean target making changes to
      debian/control
    - rework the sed line so that it works in-place on debian/control,
      so we can get rid of debian/control.in as well and just update
      debian/control directly
    Closes: #340570.

 -- Steve Langasek <email address hidden> Wed, 05 Dec 2007 16:14:20 -0800

Changed in samba:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers