dragon crashed with SIGSEGV

Bug #285304 reported by Bespoke Systems on 2008-10-18
10
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdemultimedia

startup crash

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/dragon
NonfreeKernelModules: fglrx
Package: dragonplayer 4:4.1.2-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/dragon smb://storage/music/Videos/Tom%20Petty%20-%20Into%20The%20Great%20Wide%20Open%20(Johnny%20Depp).mpg
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: kdemultimedia
StacktraceTop:
 ?? () from /usr/lib/libsmbclient.so.0
 ?? () from /usr/lib/libsmbclient.so.0
 ?? () from /usr/lib/libsmbclient.so.0
 ?? () from /usr/lib/libsmbclient.so.0
 ?? () from /usr/lib/libsmbclient.so.0
Title: dragon crashed with SIGSEGV
Uname: Linux 2.6.27-7-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:timeval_compare () from /usr/lib/libsmbclient.so.0
run_events () from /usr/lib/libsmbclient.so.0
event_loop_once () from /usr/lib/libsmbclient.so.0
cli_pull () from /usr/lib/libsmbclient.so.0
cli_read () from /usr/lib/libsmbclient.so.0

Changed in kdemultimedia:
importance: Undecided → Medium
Shinji (thorsten-reichelt) wrote :

I can confirm this bug. Every time i start dragon it crashes with a SISEGV in strlen().

Started from a konsole window it sais:

shinji@frodo:~$ dragon --debug
amarok: BEGIN: Codeine::MainWindow::MainWindow()
amarok: BEGIN: Codeine::VideoWindow::VideoWindow(QWidget*)
Segmentation fault (core dumped)

Changed in kdemultimedia:
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

The crash is in libsmbclient

Thierry Carrez (ttx) wrote :

Shinji: your bug seems to be slightly different (this one doesn't crash in strlen()). Yours looks a lot like bug 287512.

This one may be a duplicate of bug 264943...
Bespoke Systems: What is the SMB server you're trying to access ? A NAS ? Another Samba server ? A Windows server ? Does dragon work OK for you with local files ? Did this use to work with previous versions of Ubuntu ?

Changed in samba:
importance: Medium → Undecided
status: Confirmed → Incomplete
Oliver Sic (soliver) on 2009-01-16
Changed in samba:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers