Panic or segfault in Samba

Bug #281188 reported by kebing on 2008-10-10
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Sean Sosik-Hamor

Bug Description

Binary package hint: samba

The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 15632 (/usr/sbin/smbd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Ubuntu by visiting this link:
https://launchpad.net/ubuntu/+source/samba/+filebug

kebing (kebing-zh) wrote :
nijho005 (dik-nijhoff) wrote :

The Samba 'panic action' script, /usr/share/samba/panic-action,

was called for PID 6015 (/usr/sbin/smbd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Ubuntu by visiting this link:
https://launchpad.net/ubuntu/+source/samba/+filebug

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]

[New Thread 0xb75e36d0 (LWP 6015)]

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

0xb7b0c424 in __kernel_vsyscall ()
#0 0xb7b0c424 in __kernel_vsyscall ()
#1 0xb77275e3 in waitpid () from /lib/tls/i686/cmov/libc.so.6
#2 0xb76c475b in ?? () from /lib/tls/i686/cmov/libc.so.6
#3 0xb78b750d in system () from /lib/tls/i686/cmov/libpthread.so.0
#4 0xb7cdb5a1 in smb_panic () from /usr/sbin/smbd
#5 0xb7b793bf in smbd_messaging_context () from /usr/sbin/smbd
#6 0xb7b7b1e9 in main () from /usr/sbin/smbd

Eric Vernichon (eric-vernichon) wrote :

I have the same problem

[Thread debugging using libthread_db enabled]
[New Thread 0x7f92bf9af700 (LWP 1925)]
0x00007f92bc774f15 in waitpid () from /lib/libc.so.6
#0 0x00007f92bc774f15 in waitpid () from /lib/libc.so.6
#1 0x00007f92bc70d461 in ?? () from /lib/libc.so.6
#2 0x00007f92bfbbbe38 in smb_panic () from /usr/sbin/smbd
#3 0x00007f92bfa7c3c1 in main () from /usr/sbin/smbd
The program is running. Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]

shankhs (shankholove2005) wrote :

I am having the same problem.I am attaching the mail I am getting .

shankhs (shankholove2005) wrote :

shankhs@shankhs-desktop:~$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10
shankhs@shankhs-desktop:~$ uname -a
Linux shankhs-desktop 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux
shankhs@shankhs-desktop:~$ apt-cache policy samba
samba:
  Installed: 2:3.2.3-1ubuntu3.3
  Candidate: 2:3.2.3-1ubuntu3.3
  Version table:
 *** 2:3.2.3-1ubuntu3.3 0
        500 http://in.archive.ubuntu.com intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     2:3.2.3-1ubuntu3 0
        500 http://in.archive.ubuntu.com intrepid/main Packages

Lucas Young (lucas-digitalus) wrote :

I'm also having this problem with a new install of Ubuntu 8.10 LAMP Server (+ubuntu desktop) on a mixed Win/OSX network.
[New Thread 0xb74946d0 (LWP 7227)]
0xb79bb424 in __kernel_vsyscall ()
#0 0xb79bb424 in __kernel_vsyscall ()
#1 0xb75d85e3 in waitpid () from /lib/tls/i686/cmov/libc.so.6
#2 0xb757575b in ?? () from /lib/tls/i686/cmov/libc.so.6
#3 0xb776850d in system () from /lib/tls/i686/cmov/libpthread.so.0
#4 0xb7b8a601 in smb_panic () from /usr/sbin/smbd
#5 0xb7b75023 in sig_fault () from /usr/sbin/smbd
#6 <signal handler called>
#7 0xb7b66730 in rep_strlcpy () from /usr/sbin/smbd
#8 0xb7b995a2 in connections_fetch_entry () from /usr/sbin/smbd
#9 0xb7a3b230 in yield_connection () from /usr/sbin/smbd
#10 0xb7a63ded in close_cnum () from /usr/sbin/smbd
#11 0xb7a41584 in conn_close_all () from /usr/sbin/smbd
#12 0xb7a284fd in exit_server_common () from /usr/sbin/smbd
#13 0xb7a286f1 in exit_server_cleanly () from /usr/sbin/smbd
#14 0xb7a2aaf0 in main () from /usr/sbin/smbd

discont (discont) wrote :

Same here:

The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 16283 (/usr/sbin/smbd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Ubuntu by visiting this link:
https://launchpad.net/ubuntu/+source/samba/+filebug

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb756c6d0 (LWP 16283)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7a9d430 in __kernel_vsyscall ()
#0 0xb7a9d430 in __kernel_vsyscall ()
#1 0xb76b0733 in waitpid () from /lib/tls/i686/cmov/libc.so.6
#2 0xb764d78b in ?? () from /lib/tls/i686/cmov/libc.so.6
#3 0xb784050d in system () from /lib/tls/i686/cmov/libpthread.so.0
#4 0xb7c6c5c1 in smb_panic () from /usr/sbin/smbd
#5 0xb7c56f93 in ?? () from /usr/sbin/smbd
#6 <signal handler called>
#7 0xb7c486a0 in rep_strlcpy () from /usr/sbin/smbd
#8 0xb7c7b662 in connections_fetch_entry () from /usr/sbin/smbd
#9 0xb7b1d2a0 in yield_connection () from /usr/sbin/smbd
#10 0xb7b45e5d in close_cnum () from /usr/sbin/smbd
#11 0xb7e9867d in reply_tdis () from /usr/sbin/smbd
#12 0xb7b4330e in ?? () from /usr/sbin/smbd
#13 0xb7b45521 in smbd_process () from /usr/sbin/smbd
#14 0xb7b0cb4f in main () from /usr/sbin/smbd
The program is running. Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]

shankhs (shankholove2005) wrote :

I am attaching the report self-generated by samba after installing samba-dbg.

Christian Kroll (tunix79) wrote :

Same problem here. I have just copied some files from a read only samba share to a Windows 2000 client.

[Thread debugging using libthread_db enabled]
[New Thread 0x7f42848f9700 (LWP 9676)]
0x00007f42816b3f15 in waitpid () from /lib/libc.so.6
#0 0x00007f42816b3f15 in waitpid () from /lib/libc.so.6
#1 0x00007f428164c461 in ?? () from /lib/libc.so.6
#2 0x00007f4284afae48 in smb_panic () from /usr/sbin/smbd
#3 0x00007f4284ae74c4 in sig_fault () from /usr/sbin/smbd
#4 <signal handler called>
#5 0x00007f4284ad9a31 in rep_strlcpy () from /usr/sbin/smbd
#6 0x00007f4284b08a09 in connections_fetch_entry () from /usr/sbin/smbd
#7 0x00007f42849c9c31 in yield_connection () from /usr/sbin/smbd
#8 0x00007f42849ee8e0 in close_cnum () from /usr/sbin/smbd
#9 0x00007f4284cda886 in reply_tdis () from /usr/sbin/smbd
#10 0x00007f42849ebf6e in switch_message () from /usr/sbin/smbd
#11 0x00007f42849ee008 in smbd_process () from /usr/sbin/smbd
#12 0x00007f42849bb803 in main () from /usr/sbin/smbd

Sean Sosik-Hamor (sciri) wrote :
Download full text (6.3 KiB)

I've been experiencing the same problem since upgrading from Intrepid to Jaunty Development. Crash occurs on reboot.

==========

sciri@baka:~$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu jaunty (development branch)
Release: 9.04
Codename: jaunty

==========

sciri@baka:~$ apt-cache policy winbind
winbind:
  Installed: 2:3.3.0-3ubuntu2
  Candidate: 2:3.3.0-3ubuntu2
  Version table:
 *** 2:3.3.0-3ubuntu2 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status
sciri@baka:~$ apt-cache policy samba
samba:
  Installed: (none)
  Candidate: 2:3.3.0-3ubuntu2
  Version table:
     2:3.3.0-3ubuntu2 0
        500 http://archive.ubuntu.com jaunty/main Packages
sciri@baka:~$ apt-cache policy samba-common
samba-common:
  Installed: 2:3.3.0-3ubuntu2
  Candidate: 2:3.3.0-3ubuntu2
  Version table:
 *** 2:3.3.0-3ubuntu2 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

==========

E-mail received:

The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 3743 (/usr/sbin/winbindd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Ubuntu by visiting this link:
https://launchpad.net/ubuntu/+source/samba/+filebug

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7fc39f245710 (LWP 3743)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00007fc39d1ab8...

Read more...

Changed in samba:
status: New → Confirmed

I have the same problem on latest Jaunty/amd64. I also saw these lines in dmesg:

[ 50.337015] type=1502 audit(1235553386.815:23): operation="inode_permission" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/upcase.dat.samba3" pid=4542 profile="/usr/sbin/nmbd"
[ 50.337028] type=1502 audit(1235553386.815:24): operation="file_mmap" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/upcase.dat.samba3" pid=4542 profile="/usr/sbin/nmbd"
[ 50.337048] type=1502 audit(1235553386.815:25): operation="inode_permission" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/lowcase.dat.samba3" pid=4542 profile="/usr/sbin/nmbd"
[ 50.337057] type=1502 audit(1235553386.815:26): operation="file_mmap" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/lowcase.dat.samba3" pid=4542 profile="/usr/sbin/nmbd"
[ 50.354286] type=1502 audit(1235553386.833:27): operation="setattr" requested_mask="w::" denied_mask="w::" fsuid=0 attribute="mode,ctime," name="/var/log/samba/cores/" pid=4542 profile="/usr/sbin/nmbd"
[ 50.354294] type=1502 audit(1235553386.833:28): operation="setattr" requested_mask="w::" denied_mask="w::" fsuid=0 attribute="mode,ctime," name="/var/log/samba/cores/" pid=4542 profile="/usr/sbin/nmbd"
[ 50.374469] type=1502 audit(1235553386.852:29): operation="inode_permission" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/valid.dat.samba3" pid=4542 profile="/usr/sbin/nmbd"
[ 50.374479] type=1502 audit(1235553386.852:30): operation="file_mmap" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/valid.dat.samba3" pid=4542 profile="/usr/sbin/nmbd"
[ 50.500546] type=1502 audit(1235553386.979:31): operation="inode_permission" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/upcase.dat.samba3" pid=4544 profile="/usr/sbin/smbd"
[ 50.500559] type=1502 audit(1235553386.979:32): operation="file_mmap" requested_mask="r::" denied_mask="r::" fsuid=0 name="/usr/share/samba/upcase.dat.samba3" pid=4544 profile="/usr/sbin/smbd"

Maybe it is a broken apparmor-profile which causes problems?

GangTae Ko (gtko-hanmail) wrote :

I also have same problems like above.
---------------------------------------------------
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 30746 (/usr/sbin/smbd).

This means there was a problem with the program, such as a segfault.
Below is a backtrace for this process generated with gdb, which shows
the state of the program at the time the error occurred. The Samba log
files may contain additional information about the problem.

If the problem persists, you are encouraged to first install the
samba-dbg package, which contains the debugging symbols for the Samba
binaries. Then submit the provided information as a bug report to
Ubuntu by visiting this link:
https://launchpad.net/ubuntu/+source/samba/+filebug

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb753b6d0 (LWP 30746)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7a66430 in __kernel_vsyscall ()
#0 0xb7a66430 in __kernel_vsyscall ()
#1 0xb767f733 in waitpid () from /lib/tls/i686/cmov/libc.so.6
#2 0xb761c78b in ?? () from /lib/tls/i686/cmov/libc.so.6
#3 0xb780f50d in system () from /lib/tls/i686/cmov/libpthread.so.0
#4 0xb7c35601 in smb_panic () from /usr/sbin/smbd
#5 0xb7c20023 in ?? () from /usr/sbin/smbd
#6 <signal handler called>
#7 0xb7c11730 in rep_strlcpy () from /usr/sbin/smbd
#8 0xb7c445a2 in connections_fetch_entry () from /usr/sbin/smbd
#9 0xb7ae6230 in yield_connection () from /usr/sbin/smbd
#10 0xb7b0eded in close_cnum () from /usr/sbin/smbd
#11 0xb7e615bd in reply_tdis () from /usr/sbin/smbd
#12 0xb7b0c29e in ?? () from /usr/sbin/smbd
#13 0xb7b0e4b1 in smbd_process () from /usr/sbin/smbd
#14 0xb7ad5adf in main () from /usr/sbin/smbd
The program is running. Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]

Ali Nadalizadeh (nadalizadeh) wrote :

I'm being affected by this one for ~9 month(s)
Still no fix or workaround on this bug ?

----
The Samba 'panic action' script, /usr/share/samba/panic-action,
was called for PID 15316 ().

This means there was a problem with the program, such as a segfault.
However, the executable could not be found for process 15316.
It may have died unexpectedly, or you may not have permission to debug
the process.
----

How can I attach a gdb process to the failed samba process to post a back-trace here ?

Robin Sheat (eythian) wrote :

This has started happening to me with Jaunty, however I get the same as Ali above: it's not able to give a backtrace of any sort.

no!chance (ralf-fehlau) wrote :

I have the same problem in hardy (64bit) since 7.5.09. All patches are installed. After installing the debugging symbols, I get this stack trace:

[Thread debugging using libthread_db enabled]
[New Thread 0x7f1873834700 (LWP 26480)]
0x00007f1870a3b4a5 in waitpid () from /lib/libc.so.6
#0 0x00007f1870a3b4a5 in waitpid () from /lib/libc.so.6
#1 0x00007f18709dc461 in ?? () from /lib/libc.so.6
#2 0x0000000000613c7b in smb_panic (why=<value optimized out>)
    at lib/util.c:1639
#3 0x0000000000618cf1 in assert_uid (ruid=4294967295, euid=1024)
    at lib/util_sec.c:102
#4 0x00000000004ba5ae in become_id (uid=1024, gid=1024) at smbd/sec_ctx.c:57
#5 0x00000000004ba726 in pop_sec_ctx () at smbd/sec_ctx.c:345
#6 0x00000000004afef9 in unbecome_root () at smbd/uid.c:400
#7 0x00000000005d36e8 in gid_to_sid (psid=0x7fff7b84b390, gid=1021)
    at passdb/lookup_sid.c:1202
#8 0x00000000004c435a in get_nt_acl (fsp=0xb04a50, security_info=7,
    ppdesc=0x7fff7b84b4c8) at smbd/posix_acls.c:2809
#9 0x000000000046e09e in is_visible_file (conn=0xaaa570,
    dir_path=0xaade40 "./", name=<value optimized out>, pst=0x7fff7b84be90,
    use_veto=1) at smbd/dir.c:897
#10 0x000000000046e620 in dptr_normal_ReadDirName (dptr=0x9ffdf0,
    poffset=0x7fff7b84bf58, pst=0x7fff7b84be90) at smbd/dir.c:562
#11 0x000000000046e694 in dptr_ReadDirName (dptr=0x9ffdf0,
    poffset=0x7fff7b84bf58, pst=0x7fff7b84be90) at smbd/dir.c:642
#12 0x00000000004a54e4 in get_lanman2_dir_entry (conn=0xaaa570,
    inbuf=<value optimized out>, outbuf=0xad0ab0 "",
    path_mask=0x7fff7b84d170 "*", dirtype=22, info_level=260,
    requires_resume_key=4, dont_descend=0, ppdata=0x7fff7b84d140,
    base_data=0xaf0f00 "`", end_data=0xaf6003 "", space_remaining=12700,
    out_of_space=0x7fff7b84d164, got_exact_match=0x7fff7b84d14c,
    last_entry_off=0x7fff7b84d16c, name_list=0x0, ea_ctx=0x0)
    at smbd/trans2.c:1149
#13 0x00000000004a8b13 in call_trans2findfirst (conn=0xaaa570,
    inbuf=0xab0660 "", outbuf=0xad0ab0 "", bufsize=131072, pparams=0x9df8c0,
    total_params=<value optimized out>, ppdata=0x9df8d0, total_data=0,
    max_data_bytes=16644) at smbd/trans2.c:1859
#14 0x00000000004a92ae in handle_trans2 (conn=0xaaa570, state=0x9df770,
    inbuf=0xab0660 "", outbuf=0xad0ab0 "", size=<value optimized out>,
    bufsize=131072) at smbd/trans2.c:6433
#15 0x00000000004afc6a in reply_trans2 (conn=0xaaa570, inbuf=0xab0660 "",
    outbuf=0xad0ab0 "", size=90, bufsize=131072) at smbd/trans2.c:6703
#16 0x00000000004c87ce in switch_message (type=50, inbuf=0xab0660 "",
    outbuf=0xad0ab0 "", size=90, bufsize=131072) at smbd/process.c:1004
#17 0x00000000004c9bc2 in smbd_process () at smbd/process.c:1031
#18 0x00000000006c5fad in main (argc=<value optimized out>,
    argv=0x7fff7b84f0f8) at smbd/server.c:1120
The program is running. Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]

MMarking (cpt-mocha) wrote :

I'm on Intrepid (plan to upgrade to Jaunty soon) and I have literally thousands of these messages in my dmesg and logs after an uptime of a few days:

[215799.967346] type=1502 audit(1243006362.717:7274): operation="inode_permission" requested_mask="rw::" denied_mask="w::" fsuid=0 name="/var/lib/samba/group_mapping.ldb" pid=1027 profile="/usr/sbin/smbd"

It seems I'm in the right place for this issue. Until this bug is fixed, is there someway to supress these messages in the logs?

I'm on intrepid and I get this maybe once a week. I'm not sure if this is the same issue, since the stack trace looks slightly different:

[Thread debugging using libthread_db enabled]
[New Thread 0x7fbc9b551710 (LWP 20441)]
0x00007fbc981058f5 in waitpid () from /lib/libc.so.6
#0 0x00007fbc981058f5 in waitpid () from /lib/libc.so.6
#1 0x00007fbc9809d2d1 in ?? () from /lib/libc.so.6
#2 0x00007fbc9b7427a8 in smb_panic (why=<value optimized out>)
    at lib/util.c:1679
#3 0x00007fbc9b72fbe7 in sig_fault (sig=11) at lib/fault.c:46
#4 <signal handler called>
#5 pdb_get_domain (sampass=0x0) at passdb/pdb_get_set.c:285
#6 0x00007fbc9b63db4c in change_to_user (conn=0x7fbc9c9052f0, vuid=100)
    at smbd/uid.c:88
#7 0x00007fbc9b6573cf in switch_message (type=50 '2', req=0x7fbc9c8eb370,
    size=<value optimized out>) at smbd/process.c:1429
#8 0x00007fbc9b6593cd in smbd_process () at smbd/process.c:1509
#9 0x00007fbc9b626cc8 in main (argc=<value optimized out>, argv=0x2)
    at smbd/server.c:1512
The program is running. Quit anyway (and detach it)? (y or n) [answered Y; input not from terminal]

Looks like some issue in pdb.

Derek

Thierry Carrez (ttx) wrote :

The problem is those are different crashes, all ending in smb-panic, but most certainly coming from very different causes. Some of those Intrepid issues were fixed in Jaunty, so I would be interested in knowing if any of you can still reproduce their crash after an upgrade to Jaunty. If yes, please open a separate bug so that we can track it (and mark it as duplicate if it is indeed the same as some other). Thanks !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers