/usr/sbin/smbd:6:dump_core:smb_panic_s3:smb_panic:change_to_user_internal:smbd_smb2_request_check_tcon

Bug #1810827 reported by errors.ubuntu.com bug bridge on 2019-01-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba
Unknown
Unknown
samba (Ubuntu)
High
Unassigned
Bionic
Low
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding samba. This problem was most recently seen with package version 2:4.7.6+dfsg~ubuntu-0ubuntu2.5, the problem page at https://errors.ubuntu.com/problem/a0e114fe3466c147093f166768061a9b12111b13 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Andreas Hasenack (ahasenack) wrote :

I can reproduce this crash with the instructions from the samba upstream bug:

  1. Define a share without `force group=...` in the smb.conf.
  2. Connect to the share by an SMB client.
  3. Add `force group=...` to the share definition in the smb.conf.
  4. Run `smbcontrol all reload-config` to apply the change.
  5. Access a file in the share by the SMB client.

Changed in samba (Ubuntu):
status: New → Confirmed
Robie Basak (racb) on 2019-01-10
Changed in samba (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

The upstream bug is marked resolved, and includes patches backported to various samba versions. I haven't examined them for the nature of the fix but with them now released and available this issue may be worth another look.

The error tracker shows this crash has occurred 3 more times since this bug was last touched, although only once in the past 6 months. According to the tracker the crashes are appearing on bionic only (though I wonder if other releases have the same crash but just generate a different signature).

A good next-action would be to jot down commands to run in an lxc instance to reproduce the problem. With that in hand, the patches can then be reviewed and verified as addressing the crash, and an SRU can proceed from there.

tags: added: server-next
Andreas Hasenack (ahasenack) wrote :

Still in our queue.

Andreas Hasenack (ahasenack) wrote :

There is a fix available, but is not frequent enough and there is a simple workaround: restart instead of reload. Also only that specific "force group" config change is affected.

tags: removed: server-next
Changed in samba (Ubuntu):
status: Triaged → Fix Released
Changed in samba (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Low
Andreas Hasenack (ahasenack) wrote :

I mean the crash is not frequent enough.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.