network storage - cannot access audio/video files only

Bug #180829 reported by NexusDave on 2008-01-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Using Gutsy, smb, a network hard disk (Maxtor Shared Storage Plus 500Gb).

I have every kind of files on the network share, and on another machine running Windows XP. I can see and use every files on both, except for audio/video files on the network share only. So, I can read a .pdf file on the network share and on the xp share, but not a .mpg or .mp3 on the network share.
If I use my Windows computer to copy a .mp3 file from the share to the XP computer, then , I can read it from Linux.
The bug is that I can list (ls) those files correctly, but can't do anything with them (read,write,modify,rename,copy) , not because of an error or unset permissions, but because it just HANGS. For example, if I have multiple kinds of files in the same directory, and want to copy a .pdf file using Ubuntu, no problem, but a .mp3 or .mpg file would hang at the file copy dialog without even starting the file copy and hang there indefinitely (same for renaming the file or just accessing it's properties). I have to click 'cancel' or sometimes hard close the window because it doesn't respond anymore.

The strangest thing is that I CAN use my Windows computer to JUST rename the file extension from .mp3 to anything else (ex: .ttt) and then it works right away in Ubuntu!!!. I can then copy the file with Ubuntu and then rename it back to .mp3.
This happens just with audio/video files of some kinds (mp3,mpg,avi,wav,wma). Have not tried other audio/video formats.
But ALL other files are OK.

I could use this workaround to just copy files but I wanted to access them directly from Ubuntu to play them remotely with Movie Player and Totem Player.
Those applications of course hang also if I use them to access those files directly from the network share.

I have tried this on 2 other Maxtor network storages and it does the same.
Tried using the File Browser logged as a user, tried command-line as root, and tried using access to shares with smb and cifs. all do the same.
Network shares permissions (and all other permissions for that matter) are all RW for every users (not so normally , but did it for testing purposes).

## Ubuntu 7.1 Gutsy, updated. Maxtor storage firmware updated.

------------
Done some other tests, with still the same results. See pictures attachments.

I have to add that when renaming the file extension back to '.avi' , it "freezes" at the 'renaming progress window' for a while (a few seconds) and then actually do the renaming. SEE 5-long.png , picture attachment.

NexusDave (nexusdave) wrote :

If file extension is '.avi' , for example, file cannot be copied from network drive to linux desktop. SEE 1-error.png

NexusDave (nexusdave) wrote :

Renaming the file extension to something else, let's say '.avi-NOT' (or '.not' , anything not video bound). SEE 2-renamed.png

NexusDave (nexusdave) wrote :

now, the file copy to Desktop successfully.

NexusDave (nexusdave) wrote :

here's the file copied and seen as video type. SEE 4-finished.png

NexusDave (nexusdave) wrote :

If I want to rename the file's ext back to '.avi' , it will take a while to do so (SEE 5-long.png), but actually do rename it at the end.

NexusDave (nexusdave) on 2008-01-20
description: updated
Joel Goguen (jgoguen) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in samba:
status: New → Incomplete
Joel Goguen (jgoguen) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Chuck Short (zulcss) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in samba (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers