undefined symbol in libpam-winbind

Bug #1686325 reported by anders@adstate.net on 2017-04-26
This bug report is a duplicate of:  Bug #1677329: libpam-winbind: unable to dlopen. Edit Remove
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

When trying to get PAM to authenticate to Active Directory, I get this in /var/log/auth.log:

PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: undefined symbol: wbcCtxFree

$ dpkg -l | grep winbind
ii libnss-winbind:amd64 2:4.5.8+dfsg-0ubuntu0.17.04.1 amd64 Samba nameservice integration plugins
ii libpam-winbind:amd64 2:4.5.8+dfsg-0ubuntu0.17.04.1 amd64 Windows domain authentication integration plugin
ii libwbclient0:amd64 2:4.5.8+dfsg-0ubuntu0.17.04.1 amd64 Samba winbind client library
ii winbind 2:4.5.8+dfsg-0ubuntu0.17.04.1 amd64 service to resolve user and group information from Windows NT servers

$ lsb_release -rd
Description: Ubuntu 17.04
Release: 17.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed

This is not a duplicate of Bug #1644428. The libraries are in the right spot, but has unresolved symbols.

Andrew Reis (drew-reis) wrote :

Also having this issue. After symlinking /lib/x86_64-linux-gnu/security to /lib/security, receiving:

Jul 19 12:05:41 hostname login[28882]: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: undefined symbol: wbcCtxFree
Jul 19 12:05:41 hostname login[28882]: PAM adding faulty module: pam_winbind.so

user@hostname:/lib$ dpkg -l | grep 'samba\|winbind' | awk '{print $2" --- "$3}'
libnss-winbind:amd64 --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
libpam-winbind:amd64 --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
libwbclient0:amd64 --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
python-samba --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
samba --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
samba-common --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
samba-common-bin --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
samba-dsdb-modules --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
samba-libs:amd64 --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
samba-vfs-modules --- 2:4.5.8+dfsg-0ubuntu0.17.04.4
winbind --- 2:4.5.8+dfsg-0ubuntu0.17.04.4

Joseph Reeves (iknowjoseph) wrote :

Building a VM with Debian as this bug stopped me logging in with my domain credentials over ssh :-/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers