[FFe] samba-vfs-modules misses ceph vfs module

Bug #1668940 reported by Felix Stolte on 2017-03-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Debian)
Fix Released
Unknown
samba (Ubuntu)
Medium
Nish Aravamudan
Xenial
Wishlist
Unassigned
Yakkety
Wishlist
Unassigned

Bug Description

Feature Freeze Exception justification:

 * samba currently has no build-dependency on libcephfs-dev. Thus, at build-time, no cephfs support is detected and ceph support is not built into samba. However, we ship man-pages that refer to that support, and there is nothing in debian/changelog indicating this is an intentional omission.

 * libcephfs-dev is in main as is libcephfs1 (the runtime dependency that results for samba), so no component mismatches should exist.

 * Adding the build-dependency has been tested locally to generate the correct .so file as mentioned in this bug.

 * Users expecting to use ceph with samba are currently surprised and possibly confused by the mixed support, including a man-page that states configuration optoins that will result in errors from samba.

 * This is not a feature change, but a feature introduction, so I do not believe any regressions are possible, except if ceph support were somehow buggy. But if that is the case, we would currently never find this out or fix it ... This is also an issue for Debian and I plan on submitting the same change so it should not introduce any delta.

---

Man page for vfs_ceph exists (/usr/share/man/man8/vfs_ceph.8.gz) but the module itself is missing. Should be /usr/lib/x86_64-linux-gnu/samba/vfs/ceph.so
Defining a share using "vfs objects = ceph" results in
"Error loading module '/usr/lib/x86_64-linux-gnu/samba/vfs/ceph.so': /usr/lib/x86_64-linux-gnu/samba/vfs/ceph.so: cannot open shared object file: No such file or directory"

Nish Aravamudan (nacc) wrote :

Hello and thank you for this report! It does seem like what is missing is a build-dependency on libcephfs-dev (also needed on Debian):

Checking for header cephfs/libcephfs.h : 03:18:32 runner /usr/bin/gcc -g -O2 -fdebug-prefix-map=/<<BUILDDIR>>/samba-4.5.4+dfsg=. -fPIE -fstack-protector-strong -Wformat -Werror=format-security -D_FILE_OFFSET_BITS=64 -MD -D_FILE_OFFSET_BITS=64 -Wdate-time -D_FORTIFY_SOURCE=2 -I/usr/local/include -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H=1 -D_GNU_SOURCE=1 -D_XOPEN_SOURCE_EXTENDED=1 ../test.c -c -o default/test_1.o
no

Based upon the build-log for the 17.04 version. I expect the same output/missing file on prior versions. I am building a test version for 17.04 with the fixed b-d first and then will submit the bug to Debian and upload for 17.04.

Thanks,
Nish

Changed in samba (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
tags: added: bitesize server-next
Nish Aravamudan (nacc) on 2017-03-06
Changed in samba (Ubuntu):
assignee: nobody → Nish Aravamudan (nacc)
importance: Undecided → Medium
Nish Aravamudan (nacc) wrote :

Note that adding the build-dep did fix the issue, but since we are in Feature Freeze, I will need to file a FFe to get the fix into 17.04 before SRU'ing back to Xenial & Yakkety.

Nish Aravamudan (nacc) on 2017-03-07
summary: - samba-vfs-modules misses ceph vfs module
+ [FFe] samba-vfs-modules misses ceph vfs module
description: updated
Changed in samba (Debian):
status: Unknown → New
Jon Grimm (jgrimm) wrote :

resetting to 'new' state to correspond to FFe protocol: The bug should be set to status of "New" when requesting a freeze exception, to ensure the release team sees the request.

Changed in samba (Ubuntu):
status: Triaged → New
Adam Conrad (adconrad) wrote :

I'm entirely fine with this happening for 17.04, however please do hammer on it a bit in 17.04 (with enough time to revert if we find it's broken, or causes regressions for non-ceph users) before we consider backporting the change as an SRU.

Jon Grimm (jgrimm) wrote :

Considered ACKed by comment #4.

Changed in samba (Ubuntu):
status: New → Triaged
Nish Aravamudan (nacc) wrote :

Agreed, on the SRU position, 100%. I also did send this to Debian, but it didn't make Stretch.

Changed in samba (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:4.5.4+dfsg-1ubuntu2

---------------
samba (2:4.5.4+dfsg-1ubuntu2) zesty; urgency=medium

  * d/control: add libcephfs-dev as b-d to build vfs_ceph
    (LP: #1668940).

 -- Nishanth Aravamudan <email address hidden> Mon, 06 Mar 2017 11:13:41 -0800

Changed in samba (Ubuntu):
status: Fix Committed → Fix Released
Christoffer Lilja (c-hellbom) wrote :

Will this be backported to Xenial?

Changed in samba (Debian):
status: New → Fix Committed
Changed in samba (Debian):
status: Fix Committed → Fix Released
Changed in samba (Ubuntu Xenial):
importance: Undecided → Wishlist
Changed in samba (Ubuntu Yakkety):
importance: Undecided → Wishlist
Changed in samba (Ubuntu Xenial):
status: New → Triaged
Changed in samba (Ubuntu Yakkety):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.