Activity log for bug #1644428

Date Who What changed Old value New value Message
2016-11-24 05:53:56 Lyle Dietz bug added bug
2016-11-24 10:04:09 Launchpad Janitor samba (Ubuntu): status New Confirmed
2016-11-24 10:26:05 Björn Ramberg attachment added winbind_logfile https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1644428/+attachment/4782373/+files/winbind_logfile
2016-11-24 13:46:49 Louis Bouchard bug added subscriber Louis Bouchard
2016-11-24 13:47:06 Louis Bouchard bug added subscriber Jorge Niedbalski
2016-11-24 13:47:18 Louis Bouchard nominated for series Ubuntu Trusty
2016-11-24 13:47:18 Louis Bouchard bug task added samba (Ubuntu Trusty)
2016-11-24 13:47:27 Louis Bouchard samba (Ubuntu Trusty): status New Triaged
2016-11-24 13:47:31 Louis Bouchard samba (Ubuntu Trusty): importance Undecided High
2016-11-24 13:47:33 Louis Bouchard samba (Ubuntu Trusty): assignee Louis Bouchard (louis-bouchard)
2016-11-24 14:07:37 Robie Basak tags regression-update
2016-11-24 14:54:21 Robie Basak samba (Ubuntu): status Confirmed Invalid
2016-11-24 15:06:08 Martin Pitt samba (Ubuntu Trusty): status Triaged Fix Committed
2016-11-24 15:06:10 Martin Pitt bug added subscriber Ubuntu Stable Release Updates Team
2016-11-24 15:06:16 Martin Pitt bug added subscriber SRU Verification
2016-11-24 15:06:21 Martin Pitt tags regression-update regression-update verification-needed
2016-11-24 15:10:23 Robie Basak bug added subscriber Robie Basak
2016-11-24 15:37:50 Robert Euhus bug added subscriber Robert Euhus
2016-11-24 15:40:18 Ian Gordon bug added subscriber Ian Gordon
2016-11-25 00:03:23 Barry Pederson bug added subscriber Barry Pederson
2016-11-25 00:42:26 Lyle Dietz tags regression-update verification-needed regression-update verification-done
2016-11-25 10:25:00 sense bug added subscriber sense
2016-11-25 12:52:28 Robie Basak removed subscriber Ubuntu Stable Release Updates Team
2016-11-25 12:52:26 Launchpad Janitor samba (Ubuntu Trusty): status Fix Committed Fix Released
2016-12-15 09:46:54 Louis Bouchard samba (Ubuntu): status Invalid Confirmed
2017-03-09 02:23:19 Tomasz Grzegurzko bug added subscriber Tomasz Grzegurzko
2017-03-20 20:07:05 Michael Iatrou bug added subscriber Michael Iatrou
2017-03-29 17:00:28 Mario Lipinski bug added subscriber Mario Lipinski
2017-04-26 16:17:52 Sebastian bug added subscriber Sebastian
2017-05-05 06:30:05 Christian Ehrhardt  bug added subscriber Ubuntu Server Team
2017-05-05 06:38:45 Christian Ehrhardt  tags regression-update verification-done regression-update server-next verification-done
2017-05-05 06:39:00 Christian Ehrhardt  nominated for series Ubuntu Zesty
2017-06-13 18:35:41 Launchpad Janitor merge proposal linked https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/323767
2017-06-13 18:39:38 Andreas Hasenack samba (Ubuntu): importance Undecided High
2017-06-13 18:39:42 Andreas Hasenack samba (Ubuntu): assignee Andreas Hasenack (ahasenack)
2017-06-13 18:39:45 Andreas Hasenack samba (Ubuntu): status Confirmed In Progress
2017-06-13 18:54:46 Andreas Hasenack bug added subscriber Ubuntu Sponsors Team
2017-06-19 12:53:48 Launchpad Janitor merge proposal linked https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/325929
2017-06-20 13:41:11 Launchpad Janitor samba (Ubuntu): status In Progress Fix Released
2017-06-21 13:04:57 Launchpad Janitor merge proposal linked https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/326073
2017-06-21 13:11:30 Robie Basak bug task added samba (Ubuntu Zesty)
2017-06-21 13:12:12 Andreas Hasenack samba (Ubuntu Zesty): status New In Progress
2017-06-21 13:12:17 Andreas Hasenack samba (Ubuntu Zesty): importance Undecided High
2017-06-21 13:12:21 Andreas Hasenack samba (Ubuntu Zesty): assignee Andreas Hasenack (ahasenack)
2017-06-21 13:26:12 Andreas Hasenack description After performing a system update one of my users was no longer able to authenticate against Active Directory. This is on a Ubuntu 14.04 on amd64. The error in /var/log/auth.log was: Nov 24 15:08:06 haggerstone lightdm: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory I tried rebooting thinking something broke during the update, but I got the same error. I checked against my PC and saw that there were updates pending for the samba packages. I used the version numbers on my PC to perform a downgrade to 2:4.3.11+dfsg-0ubuntu0.14.04.1 and the problem went away. The affected version is 2:4.3.11+dfsg-0ubuntu0.14.04.2 [Impact] The pam_winbind.so module is unusable in zesty. It won't load because of missing symbols: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory This is due to the (re)introduction of patch fix-1584485.patch which changes the way this module is built, trying to statically link some libraries. That linking was incorrectly done. The patch was subsequently removed, but later added back again by mistake during a huge sync. A new version of the patch exists, but upstream (Samba) isn't very fond of such a change and asked to submit it for discussion to the samba-technical mailing list. That was done, but since this could take some time, we decided it's best to revert the patch one more time. [Test Case] In a zesty machine/container: * sudo apt install libpam-winbind winbind samba * tail -f /var/log/auth.log * perform a login on this machine. Via ssh, for example * the broken version will log this: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory * The fixed version will load winbind just fine, but won't log anything (unless you fully setup winbind). It's easier to add "debug" to the pam_winbind.so lines in /etc/pam.d/common-* files and repeat the login, then you get to see it being loaded in the logs [Regression Potential] This reversal has been done before and worked. Right now, the biggest regression potential is to add the broken patch back again. [Other Info] Sorry for keeping both bugs open (#1644428 and #1677329), but the history on this issue is a bit complicated with multiple SRUs and regressions.
2017-06-21 13:45:04 Andreas Hasenack description [Impact] The pam_winbind.so module is unusable in zesty. It won't load because of missing symbols: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory This is due to the (re)introduction of patch fix-1584485.patch which changes the way this module is built, trying to statically link some libraries. That linking was incorrectly done. The patch was subsequently removed, but later added back again by mistake during a huge sync. A new version of the patch exists, but upstream (Samba) isn't very fond of such a change and asked to submit it for discussion to the samba-technical mailing list. That was done, but since this could take some time, we decided it's best to revert the patch one more time. [Test Case] In a zesty machine/container: * sudo apt install libpam-winbind winbind samba * tail -f /var/log/auth.log * perform a login on this machine. Via ssh, for example * the broken version will log this: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory * The fixed version will load winbind just fine, but won't log anything (unless you fully setup winbind). It's easier to add "debug" to the pam_winbind.so lines in /etc/pam.d/common-* files and repeat the login, then you get to see it being loaded in the logs [Regression Potential] This reversal has been done before and worked. Right now, the biggest regression potential is to add the broken patch back again. [Other Info] Sorry for keeping both bugs open (#1644428 and #1677329), but the history on this issue is a bit complicated with multiple SRUs and regressions. [Impact] The pam_winbind.so module is unusable in zesty. It won't load because of missing symbols: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory This is due to the (re)introduction of patch fix-1584485.patch which changes the way this module is built, trying to statically link some libraries. That linking was incorrectly done. The patch was subsequently removed, but later added back again by mistake during a sync. A new version of the patch exists (https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/323767), but upstream (Samba and Debian) isn't very fond of such a change and asked me to submit it for discussion to the samba-technical mailing list (https://lists.samba.org/archive/samba-technical/2017-June/121139.html). That was done, but since this could take some time, we decided it's best to revert the patch again. [Test Case] In a zesty machine/container:  * sudo apt install libpam-winbind winbind samba  * tail -f /var/log/auth.log  * perform a login on this machine. Via ssh, for example  * the broken version will log this: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory  * The fixed version will load pam_winbind.so just fine, but won't log anything (unless you fully setup winbind). It's easier to add "debug" to the pam_winbind.so lines in /etc/pam.d/common-* files and repeat the login, then you get to see it being loaded in the logs. [Regression Potential] This reversal has been done before and worked. Right now, the biggest regression potential is to add the broken patch back again. Reversing this patch will also reintroduce bug #1584485, but I think the configuration that leads to that bug is asking for trouble and I stated as such in a comment (https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1584485/comments/43). "winbind" should be listed after "files" or "compat", not before. That being said, it is my opinion that having a working pam_winbind module benefits more users than the amount of users that could be affected by the particular configuration that leads to #1584485. [Other Info] Sorry for keeping both bugs open (#1644428 and #1677329), but the history on this issue is a bit complicated with multiple SRUs and regressions.
2017-06-21 17:49:31 Andreas Hasenack description [Impact] The pam_winbind.so module is unusable in zesty. It won't load because of missing symbols: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory This is due to the (re)introduction of patch fix-1584485.patch which changes the way this module is built, trying to statically link some libraries. That linking was incorrectly done. The patch was subsequently removed, but later added back again by mistake during a sync. A new version of the patch exists (https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/323767), but upstream (Samba and Debian) isn't very fond of such a change and asked me to submit it for discussion to the samba-technical mailing list (https://lists.samba.org/archive/samba-technical/2017-June/121139.html). That was done, but since this could take some time, we decided it's best to revert the patch again. [Test Case] In a zesty machine/container:  * sudo apt install libpam-winbind winbind samba  * tail -f /var/log/auth.log  * perform a login on this machine. Via ssh, for example  * the broken version will log this: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory  * The fixed version will load pam_winbind.so just fine, but won't log anything (unless you fully setup winbind). It's easier to add "debug" to the pam_winbind.so lines in /etc/pam.d/common-* files and repeat the login, then you get to see it being loaded in the logs. [Regression Potential] This reversal has been done before and worked. Right now, the biggest regression potential is to add the broken patch back again. Reversing this patch will also reintroduce bug #1584485, but I think the configuration that leads to that bug is asking for trouble and I stated as such in a comment (https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1584485/comments/43). "winbind" should be listed after "files" or "compat", not before. That being said, it is my opinion that having a working pam_winbind module benefits more users than the amount of users that could be affected by the particular configuration that leads to #1584485. [Other Info] Sorry for keeping both bugs open (#1644428 and #1677329), but the history on this issue is a bit complicated with multiple SRUs and regressions. [Impact] The pam_winbind.so module is unusable in zesty. It won't load because of missing symbols: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory This is due to the (re)introduction of patch fix-1584485.patch which changes the way this module is built, trying to statically link some libraries. That linking was incorrectly done. The patch was subsequently removed, but later added back again by mistake during a sync. A new version of the patch exists (https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/323767), but upstream (Samba and Debian) isn't very fond of such a change and asked me to submit it for discussion to the samba-technical mailing list (https://lists.samba.org/archive/samba-technical/2017-June/121139.html). That was done, but since this could take some time, we decided it's best to revert the patch again. [Test Case] In a zesty machine/container:  * sudo apt install libpam-winbind winbind samba  * tail -f /var/log/auth.log  * perform a login on this machine. Via ssh, for example  * the broken version will log this: Jun 21 13:17:05 zesty-pamwinbind-1677329 systemd: PAM unable to dlopen(pam_winbind.so): /lib/security/pam_winbind.so: cannot open shared object file: No such file or directory  * The fixed version will load pam_winbind.so just fine, but won't log anything (unless you fully setup winbind). It's easier to add "debug" to the pam_winbind.so lines in /etc/pam.d/common-* files and repeat the login, then you get to see it being loaded in the logs: Jun 21 17:48:52 zesty-pamwinbind-1677329 sshd[18052]: pam_winbind(sshd:session): [pamh: 0x56460f355740] ENTER: pam_sm_open_session (flags: 0x0000) Jun 21 17:48:52 zesty-pamwinbind-1677329 sshd[18052]: pam_winbind(sshd:session): [pamh: 0x56460f355740] LEAVE: pam_sm_open_session returning 0 (PAM_SUCCESS) [Regression Potential] This reversal has been done before and worked. Right now, the biggest regression potential is to add the broken patch back again. Reversing this patch will also reintroduce bug #1584485, but I think the configuration that leads to that bug is asking for trouble and I stated as such in a comment (https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1584485/comments/43). "winbind" should be listed after "files" or "compat", not before. That being said, it is my opinion that having a working pam_winbind module benefits more users than the amount of users that could be affected by the particular configuration that leads to #1584485. [Other Info] Sorry for keeping both bugs open (#1644428 and #1677329), but the history on this issue is a bit complicated with multiple SRUs and regressions.
2017-06-26 16:48:40 Andrew Reis bug added subscriber Andrew Reis
2017-07-03 12:15:21 Andreas Steffan bug added subscriber Andreas Steffan
2017-07-19 18:04:28 Andreas Hasenack attachment added zesty-revert-static-winbind-1677329.debdiff https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1644428/+attachment/4917756/+files/zesty-revert-static-winbind-1677329.debdiff
2017-07-24 13:10:45 Andreas Hasenack removed subscriber Ubuntu Sponsors Team
2017-07-24 13:10:53 Andreas Hasenack bug added subscriber Andreas Hasenack
2017-07-24 13:12:22 Andreas Hasenack bug added subscriber Ubuntu Stable Release Updates Team
2017-08-04 18:11:33 Brian Murray samba (Ubuntu Zesty): status In Progress Fix Committed
2017-08-04 18:11:47 Brian Murray tags regression-update server-next verification-done regression-update server-next verification-needed verification-needed-zesty
2017-08-04 20:53:40 Andrew Reis tags regression-update server-next verification-needed verification-needed-zesty regression-update server-next verification-done-zesty
2017-08-14 15:36:30 Launchpad Janitor samba (Ubuntu Zesty): status Fix Committed Fix Released