copying files from vista share results in timeout

Bug #161118 reported by Kay.one on 2007-11-09
12
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Chuck Short

Bug Description

When trying to copy a big files from a vista share (samba), the process starts OK, but after 30-60 seconds it starts slowing down rapidly till it gets to 0 Kbps, and after a few seconds it aborts the copy process with a timeout error.

there is a thread in the forums http://ubuntuforums.org/showthread.php?p=3716302 with about 10 people confirming the bug!

Dylan (dylanrjones) wrote :

- Can confirm problem between Vista and Gutsy
- Not just large files, also multiple files and folders. Any prolonged transfer.
- No problem between XP and gutsy.

Kay.one (kay-one) on 2007-11-09
description: updated
jfouchard (jfouchard) wrote :

I can confirm this issue. Connected to two different computers running Vista. I am using Wireless on this computer. It fails from Nautilus. If I use SMBFS to copy the files the following gets printed over and over to the syslog:

Nov 10 07:23:42 ubuntu6400 kernel: [ 427.336000] smb_fill_super: missing data argument
Nov 10 07:27:24 ubuntu6400 kernel: [ 649.296000] smb_add_request: request [f0baa0c0, mid=746] timed out!
Nov 10 07:27:55 ubuntu6400 kernel: [ 679.864000] smb_add_request: request [f0baa0c0, mid=881] timed out!
Nov 10 07:28:25 ubuntu6400 kernel: [ 710.124000] smb_add_request: request [f0baa0c0, mid=945] timed out!
Nov 10 07:28:56 ubuntu6400 kernel: [ 741.320000] smb_add_request: request [f0baa0c0, mid=1193] timed out!
Nov 10 07:29:27 ubuntu6400 kernel: [ 771.856000] smb_add_request: request [f0baa0c0, mid=1278] timed out!
Nov 10 07:29:57 ubuntu6400 kernel: [ 802.296000] smb_add_request: request [f0baa0c0, mid=1355] timed out!

Using CIFS causes the operation to fail with:

Nov 10 07:40:12 ubuntu6400 kernel: [ 1417.160000] CIFS VFS: server not responding
Nov 10 07:40:12 ubuntu6400 kernel: [ 1417.160000] CIFS VFS: No response to cmd 46 mid 189
Nov 10 07:40:12 ubuntu6400 kernel: [ 1417.160000] CIFS VFS: Send error in read

joedawg (joedawg) wrote :

I can confirm this issue between Gutsy and WinXPpro via a wired connection through a linksys router,
Text of error message is: Error "Timeout reached" while copying "filename".
This error occurs when copying large files. Small files copy OK.
I'm using Nautilus 2.20.0, Samba 3.0.26a

joedawg (joedawg) wrote :

The problem resolved itself after I rebooted both systems.
Will continue to monitor for this phenomena...

Chuck Short (zulcss) wrote :

Hello,

Can you post the full dmesg as an attachment if that happens again?

Thanks
chuck

Changed in samba:
assignee: nobody → zulcss
status: New → Incomplete
Kevin Wood (kevin-proximalabs) wrote :

I am also experiencing this problem. The samba server is running Vista.
Seems to happen whenever there is a wireless link involved. I have tried both with my laptop wireless connection running Ubuntu, and my desktop running Ubuntu 64 over a wireless ethernet bridge (no wireless card). The problem happens on both. Booting to Windows and accessing the share that way works fine from both machines. Also seems to work fine over Ethernet.
No messages show up in dmesg, would you like me to post it anyway?
Thanks Chuck,
-Kevin

Kay.one (kay-one) wrote :

I'm gonna install Vista Service Pack 1 (RTM) this weekend and see if that changes anything.

Chuck Short (zulcss) on 2008-02-11
Changed in samba:
status: Incomplete → Triaged
Chuck Short (zulcss) wrote :

Hello,

Any luck with the service pack?

Thanks
chuck

Changed in samba:
status: Triaged → Incomplete
Chuck Short (zulcss) wrote :
physicsnick (physicsnick) wrote :

Can confirm this here too, driving me crazy. I can copy large files to and from an XP box with no problems but copying large files from the Vista box stalls after ~20 seconds. If the Vista user tries to copy files to one of my writeable shares, that works fine. When I boot into Windows XP, everything works fine. It's just copying from the Vista box on my Ubuntu box that stalls.

I'm also on a wireless connection, and I'm using KDE's Remote Places, i.e. the smb:// protocol in Dolphin.

Attached is dmesg after several failed attempts, but as another user indicated, it contains no information.

fadhater (fadhater) wrote :

Found this windows-side fix.

"I had the same issue

Came across this under the control Panel

Go to the Control Panel
Open Programs and Features
Click on " Turn windows features on or off" on the left side of the panel
Uncheck "Remote Differential Compression"

Fixed up the problem for me"

Hope this helps

Kevin Wood (kevin-proximalabs) wrote :

Turning off Remote Differential Compression on the Vista box does not help the problem unfortunately. Has anyone tried Vista SP1?

Kevin Wood (kevin-proximalabs) wrote :

Upgrading to Vista SP1 on the share host solved this problem for me. Sounds like you can close this one!

Jonathan Jesse (jjesse) wrote :

Also upgraded to Vista SP1 to resolve this problem.

Chuck Short (zulcss) on 2008-03-19
Changed in samba:
status: Incomplete → Fix Released
Paul (b01) wrote :

Vista laptop connecting to samba share on Hardy. Have has the same problem but fixed when I installed SP1. So looks like it's a Vista bug that's now fixed.

physicsnick (physicsnick) wrote :

Verified fixed using Vista SP1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments