SMB Client bug. Can't connect to smb shares on OSX Elcaptain

Bug #1585168 reported by Zimny's Brain on 2016-05-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Can't connect to smb shares on OSX Elcaptain

smbclient -L //osxhost/smbshare -U user
after proper creditenials:

session setup failed: NT_STATUS_INVALID_SIGNATURE

this happened after update

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: samba 2:4.3.9+dfsg-0ubuntu0.14.04.1
ProcVersionSignature: Ubuntu 3.13.0-86.131-generic 3.13.11-ckt39
Uname: Linux 3.13.0-86-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.20
Architecture: amd64
Date: Tue May 24 12:17:09 2016
SambaClientRegression: Yes
SourcePackage: samba
UpgradeStatus: Upgraded to trusty on 2014-10-01 (600 days ago)

Zimny's Brain (zimnysbrain) wrote :
Zimny's Brain (zimnysbrain) wrote :

anyone is looking in this section at all?

Zimny's Brain (zimnysbrain) wrote :

the support is great from samba team ... :(
can't access network shares from few weeks
revert samba ver dasn't help as well

many thanks

Zimny's Brain (zimnysbrain) wrote :

issue still there
anyone can offer any kind of help at all?

already tried add/remove samba user, revert samba and sambaclient versions

still the same problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
Zimny's Brain (zimnysbrain) wrote :

no help received at all
looks like samba team completely ignore their users

unprofessional and simple rude

cheers

Hi,
I'm sorry that you got no samba support in time - yet I wanted to ask now if that might also be related to an ElCapitan update (or both actually).
See
https://github.com/videolabs/libdsm/issues/80

There is also a config workaround that you may want to try:
Adding the two lines

    <key>SigningRequired</key>
    <false/>
to /Library/Preferences/SystemConfiguration/com.apple.smb.server.plist and restarting the server (or switching SMB sharing off and on again) re-enables connectivity.

Morbius1 (morbius1) wrote :

If you don't want to muck about with the internals of the macOS box you can also bypass smbclient on the Linux box and connect to it with a CIFS mount:

sudo mount -t cifs //server/share /mountpoint -o username=xxx,password=yyy,uid=1000,nounix

Stefan Metzmacher (metze) wrote :

This looks like https://bugzilla.samba.org/show_bug.cgi?id=11994 which is already fixed a while ago

Morbius1 (morbius1) wrote :

To paraphrase a former US President it all depends on what the definition of "fixed" is.

In Xubuntu 17.04 Beta1 which uses 4.5.4 of samba it does appear to be fixed. But for Xubuntu 16.10 ( 4.4.5 ), Xubuntu 16.04 ( 4.3.11 ), and Xubuntu 14.04 ( 4.3.11 ) not so much.

Now the last two are LTS releases so you know .. it may come someday.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.