smbpasswd -r host -U user broken after samba update from 4.1.6 to 4.3.9

Bug #1584809 reported by Reinhard on 2016-05-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Ubuntu Security Team

Bug Description

I am using smbpassword -i <remotehost> -U <user> to sync samba & linux password store in an LDAP - directory.
This worked well until samba-4.1.6.
In samba 4.3.9 ill get following error message:
smb_signing_good: BAD SIG: seq 1
Could not connect to machine <remotehost>: NT_STATUS_ACCESS_DENIED

Downgrade to 4.1.6 brings password sync to work again:
aptitude -y install samba-libs=2:4.1.6+dfsg-1ubuntu2 libsmbclient=2:4.1.6+dfsg-1ubuntu2 libwbclient0=2:4.1.6+dfsg-1ubuntu2 python-samba=2:4.1.6+dfsg-1ubuntu2 samba=2:4.1.6+dfsg-1ubuntu2 samba-common=2:4.1.6+dfsg-1ubuntu2 samba-common-bin=2:4.1.6+dfsg-1ubuntu2 samba-dsdb-modules=2:4.1.6+dfsg-1ubuntu2 samba-vfs-modules=2:4.1.6+dfsg-1ubuntu2 smbclient=2:4.1.6+dfsg-1ubuntu2 libldb1=1:1.1.16-1 python-ldb=1:1.1.16-1 winbind=2:4.1.6+dfsg-1ubuntu2 libpam-winbind=2:4.1.6+dfsg-1ubuntu2 libnss-winbind=2:4.1.6+dfsg-1ubuntu2

an errormessage from :
>> smbpasswd -D 10 -r smb01 -U teacher01
is included

Reinhard (reinhard-fink) wrote :
Reinhard (reinhard-fink) wrote :

I am buggy as well :-( forgot:

Server = <remotehost> runs Samba version 3.5.8
Linux Clients where smbpassword -i <remotehost> -U <user> is used, run Ubuntu 14.04
Windows Clients run Windows 7 and password change is not affected

Samba version 4.1.6 worked/works, while version 4.3.9 does not.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
Reinhard (reinhard-fink) wrote :

I think this problems is based on an authentification problem, similar to the report in:

https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1572876

Joshua Powers (powersj) on 2016-09-19
tags: added: regression-update
tags: added: trusty
Changed in samba (Ubuntu):
assignee: nobody → Ubuntu Security Team (ubuntu-security)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments