Get an error 255 when trying to share a folder in Ubuntu 12.04.

Bug #1574403 reported by Mark Yeager on 2016-04-24
262
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Debian)
Fix Released
Unknown
samba (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Ubuntu 12.04 and after doing the latest updates this is happening on both my computers. There was an update a few days ago and now whenever I try to share a folder on my computer I get the following error....

'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. Access denied.

CVE References

Mark Yeager (mjy222) wrote :

Here are a couple of snapshots while trying to share a folder....

I have never had this issue before on Ubuntu 12.04 until an update sometime last week around maybe 04/18/16.
This issue started happening on two different computers, both running Ubuntu 12.04.

Let me know if there is a way to fix this, or do I need to wait for an update.

Thanks
Mark Yeager
<email address hidden>

information type: Private Security → Public Security
Seth Arnold (seth-arnold) wrote :

I'm sorry to say that I don't know the answer. The recent updates were huge to fix a variety of fundamental protocol flows and other outstanding issues. I think it's plausible that further updates may reduce some issues but other issues may require manual configuration changes (potentially returning to the vulnerable state in the process) and some issues may not have good resolutions.

Thanks

tags: added: precise regression-update
Marc Deslauriers (mdeslaur) wrote :

What command are you using to share your folder?

Changed in samba (Ubuntu):
status: New → Incomplete
Mark Yeager (mjy222) wrote :

Hello,

Thanks for getting back to me.

Here is what I am doing to try and share a folder. This has always worked fine until a recent update.

I am just right clicking on a folder and clicking on: Sharing Options
A new window comes up and there is a Check Mark button that says: Share this folder
After I check the box I click on Create Share at the bottom of the windows.

Then right above the Create Share button I just pushed a statement appears saying.....

'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. Access denied.

Then when I cancel out of the screen there is no change to the folder, it is still not shared.

Anything I need to go into and change?

Thanks
Mark Yeager
<email address hidden>

Marc Deslauriers (mdeslaur) wrote :

I can reproduce this. It's caused by the patch for CVE-2016-2115.

As a workaround until a proper fix is available, the following can be added to /etc/samba/smb.conf, in the [global] section:

client ipc signing = no

Changed in samba (Ubuntu):
status: Incomplete → Confirmed
Changed in samba (Debian):
status: Unknown → Fix Committed
Marc Deslauriers (mdeslaur) wrote :

Hi,

I have uploaded a samba package for precise to the following PPA:

https://launchpad.net/~mdeslaur/+archive/ubuntu/testing

Could you please give it a try? I believe it may fix this issue, and if tested successfully, I will release it as a regression update.

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.6.25-0ubuntu0.12.04.4

---------------
samba (2:3.6.25-0ubuntu0.12.04.4) precise-security; urgency=medium

  * SECURITY REGRESSION: compatibility with NetAPP SAN (LP: #1576109)
    - debian/patches/fix_netapp.patch: don't require NTLMSSP_SIGN for smb
      connections in source3/libsmb/ntlmssp.c.
  * SECURITY REGRESSION: compatibility with 3.6 servers (LP: #1574403)
    - debian/patches/relax_client_ipc_signing.patch: relax the
      "client ipc signing" parameter to "auto" so a 3.6 client can still
      connect to a 3.6 server. Administrators in environments that
      exclusively connect to more recent servers might want to manually
      configure this back to "mandatory".

 -- Marc Deslauriers <email address hidden> Thu, 12 May 2016 11:51:56 -0400

Changed in samba (Ubuntu):
status: Confirmed → Fix Released
Download full text (4.8 KiB)

Hello,

Thanks for fixing the folder sharing issue. Works great now.

I was wondering if you were aware of another problem, I am using Ubuntu
12.04

I work online for a Company called: Upwork.com
They have a time tracking software app that you run on your computer to
keep track of your work time.
It takes a screen shot of your computer at random times to make sure you
are working for the client while time is being tracked.

About 2 months ago there was an update to libnss3. After that update
their software no longer works. I have contacted them many times and
they don't seem to be getting anywhere on the fix. They are telling us
to do a work around. I have tried to do this, but it seems to just want
to reload the latest libnss3 and it still never works.

I have a laptop running ubuntu mate and it works on there, but only
because I install ubuntu mate and didn't do any updates after the
initial installation. Guess I still have the older version of libnss3,
because I didn't do an update.

Are you able to check into this or know what steps need to be taken to
get this issue fixed?

Below is what they are suggesting.

Thanks,
Mark Yeager
<email address hidden>

                        Below is what they are telling us to do
====================================================================================================
Unable to Load Upwork App
Linux libnss3 Library Incompatibility, SSL Error 12218

If you are experiencing a problem logging in or getting stuck in caching
mode on Linux, the problem could be an incompatibility of the app with
your libnss3 library. We are aware of the issue and our engineering team
is working to devise a solution. However, since that will take time, we
want to share a workaround that may provide a solution for you.

Please check if you have a libnss3 library version greater than 3.19.x.
The issue is in the Chromium embedded framework we use, so for the time
being, we cannot resolve the incompatibility ourselves. You'll need to
downgrade this library to it's previous version 3.19.x to be able to use
app.

The following workaround will download the previous version of the
libnss3 library (3.19.1). To do this, please follow the steps below:

     Exit and close Upwork Team App (Time Tracker and Messages).
     Determine which version of Ubuntu Linux you use, 64-bit or 32-bit.
If you aren’t certain, click here to learn more.
     If you use the 64-bit Ubuntu version, click here​ to download the
correct file.
     If you use the 32-bit version, click here to download the correct
file.
     Save the file to disk.
     Open with the file-roller (archive manager), and extract the
x86_64-linux-gnu directory (for 64-bit) or i386-lunux-gnu (for 32-bit)
as shown on the screenshot here. You can create a directory "lib" in
your home directory and extract the directory to there.
     Start a terminal, and type one of these two sets of commands:
     For 64-bit:

      export LD_LIBRARY_PATH=~/lib/x86_64-linux-gnu​​:$LD_LIBRARY_PATH
      nohup upwork &

     For 32-bit:

      export LD_LIBRARY_PATH=~/lib/i386-linux-gnu​​:$LD_LIBRARY_PATH
      nohup upwork &

     Upwork Time Tracker and Message...

Read more...

Marc Deslauriers (mdeslaur) wrote :

While the Upwork app is definitely unrelated to this bug, you can send them this link, which contains a description of the fix they need to make to their app to make it compatible with both the old and new nss versions:

https://bugs.launchpad.net/ubuntu/+source/nss/+bug/1547133/comments/2

Same problem on Ubuntu 17.04
corrado@corrado-Z2:~$ uname -a
Linux corrado-Z2 4.9.0-12-generic #13-Ubuntu SMP Mon Jan 9 20:06:25 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Changed in samba (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.