Unable to access location Failed to mount Windows share: Invalid argument

Bug #1442972 reported by Christopher M. Peñalver on 2015-04-11
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

When attempting to mount a Ubuntu samba share via Nautilus, it notes:
Unable to access location
Failed to mount Windows share: Invalid argument

However, mounting via smbclient works fine. Hence, this would be an issue with Nautilus/backend.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: nautilus 1:3.14.2-0ubuntu8
ProcVersionSignature: Ubuntu 3.19.0-12.12-generic 3.19.3
Uname: Linux 3.19.0-12-generic x86_64
ApportVersion: 2.17-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME-Flashback:Unity
Date: Sat Apr 11 16:42:15 2015
GsettingsChanges: b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'date_modified', 'date_accessed', 'owner', 'group', 'permissions', 'mime_type', 'where']"
InstallationDate: Installed on 2014-06-21 (293 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: nautilus
UpgradeStatus: Upgraded to vivid on 2015-03-13 (29 days ago)

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Incomplete
Changed in nautilus:
status: Incomplete → Unknown

As per https://bugzilla.gnome.org/show_bug.cgi?id=747718#c13 this is a samba library bug.

affects: nautilus (Ubuntu) → samba (Ubuntu)
Changed in nautilus:
importance: Medium → Undecided
status: Unknown → New
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
sohel (sohelmk) wrote :

yes this bug affects me also - ubuntu 14.04, i also tried command line with cifs, following are some of errors:

CIFS VFS: Malformed UNC in devname.
CIFS VFS: cifs_mount failed w/return code = -6

This no longer affects me as I don't use Trusty, Utopic, or Vivid, and this is not reproducible with Wily+Wily.

no longer affects: samba (Ubuntu)
affects: nautilus → samba (Ubuntu)
Changed in samba (Ubuntu):
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
vanadium (ftack) wrote :

I am now having this error on mounts that worked before on Ubuntu 18.10.

Andreas Hasenack (ahasenack) wrote :

Please open a new bug about it, using apport-bug <package> if possible, and stating the problem accurately, i.e., which command or action failed, its parameters, etc.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.