Samba4 get stuck after a server reboot, if IPv6 is enabled.

Bug #1339434 reported by Thiago Martins
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba
Unknown
Unknown
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Guys,

I'm trying to deploy Samba4 AD DC with IPv6 and I'm facing a hard time (LP #1335502)... First, it didn't worked "as-is", now, after enabling IPv6 in Samba4 AD DC, it does not come up after a server reboot, it get stucked, look:

---
root@ubuntu-ad-1:~# host -t SRV _ldap._tcp.tcmc.com.br
_ldap._tcp.tcmc.com.br has SRV record 0 100 389 ubuntu-ad-1.tcmc.com.br.
root@ubuntu-ad-1:~# reboot

Broadcast message from administrativo@ubuntu-ad-1
 (/dev/pts/2) at 22:10 ...

The system is going down for reboot NOW!
root@ubuntu-ad-1:~# Connection to 192.168.15.221 closed by remote host.
Connection to 192.168.15.221 closed.

--

tmartins@zion:~$ ssh administrativo@192.168.15.221
administrativo@192.168.15.221's password:
Welcome to Ubuntu 14.04 LTS (GNU/Linux 3.13.0-30-generic x86_64)

 * Documentation: https://help.ubuntu.com/
Last login: Tue Jul 8 22:09:22 2014 from 192.168.0.104
administrativo@ubuntu-ad-1:~$ sudo -i
[sudo] password for administrativo:
root@ubuntu-ad-1:~# host -t SRV _ldap._tcp.tcmc.com.br
Host _ldap._tcp.tcmc.com.br not found: 3(NXDOMAIN)
root@ubuntu-ad-1:~#
---

Then, I tried:

---
root@ubuntu-ad-1:~# pidof samba
675

root@ubuntu-ad-1:~# pidof smbd
791 719

root@ubuntu-ad-1:~# host -t SRV _ldap._tcp.tcmc.com.br
Host _ldap._tcp.tcmc.com.br not found: 3(NXDOMAIN)
---

See it?!

Now I'm doing:

---
root@ubuntu-ad-1:~# ps xfa
....
  461 ? S 0:00 avahi-daemon: running [ubuntu-ad-1.local]
  462 ? S 0:00 \_ avahi-daemon: chroot helper
  675 ? S 0:00 samba -D
  719 ? Ss 0:00 \_ /usr/sbin/smbd -D --option=server role check:inhibit=yes --f
  791 ? S 0:00 \_ /usr/sbin/smbd -D --option=server role check:inhibit=yes
  728 ? Ss 0:00 /usr/sbin/cups-browsed
  745 ? S 0:00 upstart-file-bridge --daemon
....
---

So, samba is stucked, I'm not seeing the others "samba" child process as usual, then I tried:

---
root@ubuntu-ad-1:~# service samba-ad-dc stop
stop: Unknown instance:

root@ubuntu-ad-1:~# killall samba smbd
root@ubuntu-ad-1:~#

root@ubuntu-ad-1:~# service samba-ad-dc start
samba-ad-dc start/running, process 1446

root@ubuntu-ad-1:~# host -t SRV _ldap._tcp.tcmc.com.br
_ldap._tcp.tcmc.com.br has SRV record 0 100 389 ubuntu-ad-1.tcmc.com.br.
---

Back online!!

I believe that there is something wrong with the Samba4 init scripts when we have IPv6 enabled.

Cheers!
Thiago

Thiago Martins (martinx)
description: updated
Revision history for this message
Thiago Martins (martinx) wrote :

BTW, if in an IPv4-Only environment, then "Samba4 AD DC" works okay after rebooting the server. This problem appear only in a Dual-Stacked (not tried it in a IPv6-Only network) env.

Revision history for this message
Tim Lapawa (lapawa) wrote :

I got the same trouble with my vanilla Ubuntu 14.04 installation.
Samba4 AD DC is not working properly after system reboot when ipv6 is enabled.

Snipped from /var/log/syslog:

Sep 3 12:05:08 ubuntu samba[986]: [2014/09/03 12:05:08.864745, 0] ../source4/cldap_server/cldap_server.c:134(cldapd_add_socket)
Sep 3 12:05:08 ubuntu smbd[982]: You should start 'samba' instead, and it will control starting smbd if required
Sep 3 12:05:08 ubuntu samba[986]: Failed to bind to ipv6:XXXX:XX:XXX:XXXX:XXX:XXXX:XXXX:XXXX:389 - NT_STATUS_ADDRESS_NOT_ASSOCIATED
Sep 3 12:05:08 ubuntu samba[986]: [2014/09/03 12:05:08.877964, 0] ../source4/smbd/service_task.c:35(task_server_terminate)
Sep 3 12:05:08 ubuntu samba[986]: task_server_terminate: [cldapd failed to setup interfaces]

Is there a upstart signal which is emitted after a successful ipv6 interface configuration?

Samba4 DC is working when I login into the system and restart the service via initctl.
I hope this helps....

tlapawa@ubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
Revision history for this message
Georg Abenthung (georg-0) wrote :

+1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.