ucfr fails if smb.conf is not owned by samba

Bug #1330408 reported by bog on 2014-06-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
samba (Debian)
Fix Released
Unknown
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Line 107 in /var/lib/dpkg/info/samba-common.postinst fails if smb.conf is not owned by samba and because of set -e breaks the configuration of the package.
Thats the line:
ucfr samba-common "$CONFIG"

it should be something like that:

ucfr samba-common "$CONFIG" || true

in the end it samba-common should install anyway. Thats what ucfr is intended for.

Cheers

Bog

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
Changed in samba (Ubuntu):
assignee: nobody → Filip Sohajek (filip-sohajek)
status: Confirmed → In Progress
Changed in samba (Ubuntu):
status: In Progress → Fix Committed
Changed in samba (Ubuntu):
status: Fix Committed → In Progress
bog (martaina) wrote :

Thanks a lot Filip!

Changed in samba (Debian):
status: Unknown → New
Changed in samba (Debian):
status: New → Incomplete
Changed in samba (Debian):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.