Samba,Ubuntu 14.04,smbpasswd,failed to open var/lib/samba/private/secrets.tdb

Bug #1327846 reported by Sven.Frings on 2014-06-08
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Hey Ubuntu Samba Bug i found one strange bug in samba after i uninstall samba from my ubuntu laptop and reinstall samba to

readd one of my folders t samba duringg the process to add my user name to samba,samba says to me cant open var/lib/samba and

so on wasn´t possible to solve this problem with reinstall samba on my ubuntu 14.04 system

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: samba 2:4.1.6+dfsg-1ubuntu2.14.04.1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
Date: Sun Jun 8 22:17:46 2014
InstallationDate: Installed on 2014-04-17 (51 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
ProcEnviron:
 LANGUAGE=de_DE
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions:
 nautilus 1:3.10.1-0ubuntu9.1
 gvfs 1.20.1-1ubuntu1
SambaClientRegression: Yes
SourcePackage: samba
UpgradeStatus: No upgrade log present (probably fresh install)

Sven.Frings (svenkirk) wrote :
Chad West (yesterdayjones) wrote :

Try adding the folder that it say it's missing add the user name again.

Run mkdir WHATEVER/IT/SAYS/IS/MISSING

Chad West (yesterdayjones) wrote :

I just saw the title of the post. So you'd run mkdir /var/lib/samba/private and then add your user again.

Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Please state exact steps required to reproduce the bug on a fresh system. This includes exactly what steps you followed (eg. command lines) to uninstall, reinstall, "add my user name to samba", "read one of my folders", etc. Once done, please change the status back to New.

Changed in samba (Ubuntu):
status: New → Incomplete
Sven.Frings (svenkirk) on 2014-07-30
Changed in samba (Ubuntu):
status: Incomplete → New
Sven.Frings (svenkirk) wrote :

Hey i deleted samba via Terminal with sudo apt-get remove --purge samba after that i removed config file from my samba folder after

 that my problems begins .

DasBastard (spamthisnameplease) wrote :

Happened to me also under similar circumstances.

All you need to do is the following

sudo mkdir /var/lib/samba/private

sudo touch /var/lib/samba/private/secrets.tdb

then you can add your user

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
summary: Samba,Ubuntu 14.04,smbpasswd,failed to open
- var/libsamba/private/secrets.tdb
+ var/lib/samba/private/secrets.tdb
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers