aptitude update/upgrade erased smb.conf, to the initial state

Bug #1318937 reported by Sergei Vorobyov on 2014-05-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

A routine

aptitude update
aptitude upgrade

erased the smb.conf file; the definitions of my all shares simply disappeared.

There were no question asked, but I saw (on the screen) samba packages configured and the samba server restarted

1.

root@fpu:/etc/samba# lsb_release -rd
Description: Ubuntu 14.04 LTS
Release: 14.04

3.

I expected my /etc/samba/smb.conf preserved

4.

It was overwritten by the default

2.

root@fpu:/etc/samba# apt-cache policy samba*
gadmin-samba:
  Installed: (none)
  Candidate: 0.3.2-0ubuntu1
  Version table:
     0.3.2-0ubuntu1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
libsamba-policy0:
  Installed: (none)
  Candidate: (none)
  Version table:
samba-ad-dc:
  Installed: (none)
  Candidate: (none)
  Version table:
samba-tools:
  Installed: (none)
  Candidate: (none)
  Version table:
samba4:
  Installed: (none)
  Candidate: (none)
  Version table:
libsamba-util0:
  Installed: (none)
  Candidate: (none)
  Version table:
python-samba:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
libsamba-credentials0:
  Installed: (none)
  Candidate: (none)
  Version table:
python2.7-samba:
  Installed: (none)
  Candidate: (none)
  Version table:
samba4-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
samba:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
gadmin-samba-dbg:
  Installed: (none)
  Candidate: 0.3.2-0ubuntu1
  Version table:
     0.3.2-0ubuntu1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
samba-dbg:
  Installed: (none)
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
     2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
samba4-clients:
  Installed: (none)
  Candidate: (none)
  Version table:
libsamba-hostconfig0:
  Installed: (none)
  Candidate: (none)
  Version table:
samba-dev:
  Installed: (none)
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
     2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
samba-client:
  Installed: (none)
  Candidate: (none)
  Version table:
samba-dsdb-modules:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
samba-common-bin:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
zentyal-samba:
  Installed: (none)
  Candidate: 2.3.12+quantal1ubuntu1
  Version table:
     2.3.12+quantal1ubuntu1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
libsamba-credentials-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
samba-libs:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
samba-doc:
  Installed: (none)
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
     2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
ebox-samba:
  Installed: (none)
  Candidate: (none)
  Version table:
libsamba-hostconfig-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
samba4-common-bin:
  Installed: (none)
  Candidate: (none)
  Version table:
system-config-samba:
  Installed: (none)
  Candidate: 1.2.63-0ubuntu6
  Version table:
     1.2.63-0ubuntu6 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
samba-testsuite:
  Installed: (none)
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
     2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
samba4-common:
  Installed: (none)
  Candidate: (none)
  Version table:
dpsyco-samba:
  Installed: (none)
  Candidate: 1.0.36
  Version table:
     1.0.36 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
gosa-plugin-samba:
  Installed: (none)
  Candidate: 2.7.4+reloaded1-1
  Version table:
     2.7.4+reloaded1-1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
libsamba-util-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
samba-vfs-modules:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
samba-common:
  Installed: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Candidate: 2:4.1.6+dfsg-1ubuntu2.14.04.1
  Version table:
 *** 2:4.1.6+dfsg-1ubuntu2.14.04.1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.1.6+dfsg-1ubuntu2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
samba4-testsuite:
  Installed: (none)
  Candidate: (none)
  Version table:
libsamba-policy-dev:
  Installed: (none)
  Candidate: (none)
  Version table:

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: samba 2:4.1.6+dfsg-1ubuntu2.14.04.1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
BothFailedConnect: Yes
Date: Tue May 13 09:49:23 2014
NmbdLog:

SambaServerRegression: Yes
SmbConfIncluded: Yes
SmbLog: Failed to delete pidfile /var/run/samba/smbd.pid. Error was No such file or directory
SourcePackage: samba
UpgradeStatus: Upgraded to trusty on 2014-05-02 (10 days ago)

Sergei Vorobyov (svorobyov) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers