Creating a Samba Share is not possible because "'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. Access denied."

Bug #1299186 reported by Alexander Langanke on 2014-03-28
This bug affects 31 people
Affects Status Importance Assigned to Milestone
samba (Ubuntu)

Bug Description

I am trying to create a smb Share on Ubuntu 14.04.

I get the following Error Message and am not able to create a share.

'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. Access denied.

This is a new Ubuntu install and I have the exact same error on several machines.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: samba 2:4.1.3+dfsg-2ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
BothFailedConnect: Yes
CurrentDesktop: Unity
Date: Fri Mar 28 20:37:56 2014
InstallationDate: Installed on 2014-01-09 (78 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)

SambaServerRegression: Yes
SmbConfIncluded: Yes
SourcePackage: samba
UpgradeStatus: Upgraded to trusty on 2014-03-13 (15 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in samba (Ubuntu):
status: New → Confirmed
Ayrton Araújo (ayrton) wrote :


Jaime Marques (jimmy93) wrote :

i can comfirm this...
i managed to add the folder with "sudo nano /etc/samba/smb.conf"
but then it wont allow me to create a user with "sudo smbpasswd -a <user>" keep getting acess denied on the other machine trying to login.

It renders essential functionality of the package (or a dependent one) broken.

Changed in samba (Ubuntu):
importance: Undecided → High
Paul (paul-louw) wrote :

I ran Ubuntu 12.04 and shares worked perfectly. After upgrading to 14.04 I found none of my shares was accessible from the newtwork. I would be presented with a login request but was never able to connect.

Then I tried to share a new folder and I received the following error:

'net usershare' returned error 255: net usershare add: cannot share path /media/Philips/Pictures as we are restricted to only sharing directories we own.
 Ask the administrator to add the line "usershare owner only = false"
 to the [global] section of the smb.conf to allow this.

After adding the usershare line as instructed the error changed to:

'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. Access denied.

First of all, this is NOT a duplicate of I get the same problem, while my [homes] section in smb.conf is ok, i.e. ALL the lines there are commented out.

What happens on at least two independend installations of Trusty, one of them a fresh one: Trying to share a folder in Nautilus for the first time makes it automatically ask to install the samba package. This seems to work, but then a simmilar dialogue appears asking to install "libpam-smbpass", too, but this time the whole dialogue is greyed out and clicking one of the two buttons (cancel or install) has no effect at all. It can only be closed clicking the x button in the top corner.

Shares don't work then, as discribed before.

Cameron (cdl-i) wrote :

For the record, I'm having exactly this same problem on 14.10 desktop. I'm going to 13.10 to see if it happens there. If so I will post it here.



Changed in samba (Ubuntu):
assignee: nobody → m7254292808 (test72542928)

I'm having this same problem on 17.04 desktop

Nish Aravamudan (nacc) wrote :

@carradoventu, can you attach your smb.conf file and possibly try the suggestion from:


Adam Conrad (adconrad) on 2016-12-19
Changed in samba (Ubuntu):
assignee: m7254292808 (test72542928) → nobody

Installed a new Zesty from daily: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170118)
... problem remains

corrado@corrado-Z2:~$ sudo service samba status
[sudo] password for corrado:
● samba.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

sorry, i see now that the message i receive is different:
'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. The connection was refused. Maybe smbd is not running.

for me on Zesty this problem disappeared after the fix for the Bug #1639962

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers