Segfault in Samba installing a printer on a client

Bug #128612 reported by Alessandro Bono
4
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned
Declined for Dapper by Mathias Gug

Bug Description

Binary package hint: samba

Segfault occur installing a printer on a fresh windows 2000 client autodownloading the driver from server

print server cups

   printing = cups
   printcap name = cups
   cups options = "raw"

system is a Dapper amd64

[2007/07/26 20:48:17, 0] smbd/service.c:make_connection(851)
  contabilita2 (192.168.1.71) couldn't find service ::{2227a280-3aea-1069-a2de-08002b30309d}
[2007/07/26 20:48:25, 1] smbd/service.c:make_connection_snum(693)
  contabilita2 (192.168.1.71) connect to service print$ initially as user sandro (uid=1001, gid=513) (pid 17528)
[2007/07/26 20:48:28, 1] smbd/service.c:close_cnum(890)
  contabilita2 (192.168.1.71) closed connection to service print$
[2007/07/26 20:48:30, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2007/07/26 20:48:30, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 17528 (3.0.22)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2007/07/26 20:48:30, 0] lib/fault.c:fault_report(39)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2007/07/26 20:48:30, 0] lib/fault.c:fault_report(40)
  ===============================================================
[2007/07/26 20:48:30, 0] lib/util.c:smb_panic2(1544)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 17528]
[2007/07/26 20:48:30, 0] lib/util.c:smb_panic2(1552)
  smb_panic(): action returned status 0
[2007/07/26 20:48:30, 0] lib/util.c:smb_panic2(1554)
  PANIC: internal error
[2007/07/26 20:48:30, 0] lib/util.c:smb_panic2(1562)
  BACKTRACE: 18 stack frames:
   #0 /usr/sbin/smbd(smb_panic2+0x66) [0x5c1246]
   #1 /usr/sbin/smbd [0x5ae427]
   #2 /lib/libpthread.so.0 [0x2aaaab7ab4d0]
   #3 /usr/sbin/smbd(prs_uint8s+0x170) [0x4d0dd0]
   #4 /usr/sbin/smbd(spoolss_io_r_getprinterdata+0xb2) [0x5638a2]
   #5 /usr/sbin/smbd [0x501f94]
   #6 /usr/sbin/smbd(api_rpcTNP+0x18c) [0x534a3c]
   #7 /usr/sbin/smbd(api_pipe_request+0x1ae) [0x534f7e]
   #8 /usr/sbin/smbd [0x530ec7]
   #9 /usr/sbin/smbd [0x53108e]
   #10 /usr/sbin/smbd [0x45611b]
   #11 /usr/sbin/smbd(reply_trans+0xdac) [0x45716c]
   #12 /usr/sbin/smbd [0x4a110a]
   #13 /usr/sbin/smbd(process_smb+0x190) [0x4a15e0]
   #14 /usr/sbin/smbd(smbd_process+0x1a4) [0x4a2494]
   #15 /usr/sbin/smbd(main+0x7b9) [0x6459c9]
   #16 /lib/libc.so.6(__libc_start_main+0xdb) [0x2aaaac03849b]
   #17 /usr/sbin/smbd [0x44214a]
[2007/07/26 20:48:32, 1] smbd/service.c:make_connection_snum(693)
  contabilita2 (192.168.1.71) connect to service print$ initially as user sandro (uid=1001, gid=513) (pid 17537)
[2007/07/26 20:48:43, 1] smbd/service.c:close_cnum(890)
  contabilita2 (192.168.1.71) closed connection to service print$
[2007/07/26 20:48:52, 1] smbd/service.c:make_connection_snum(693)
  contabilita2 (192.168.1.71) connect to service print$ initially as user sandro (uid=1001, gid=513) (pid 17537)
[2007/07/26 20:49:03, 1] smbd/service.c:close_cnum(890)
  contabilita2 (192.168.1.71) closed connection to service print$
[2007/07/26 20:49:04, 1] smbd/service.c:make_connection_snum(693)
  contabilita2 (192.168.1.71) connect to service print$ initially as user sandro (uid=1001, gid=513) (pid 17537)
[2007/07/26 20:49:15, 1] smbd/service.c:close_cnum(890)
  contabilita2 (192.168.1.71) closed connection to service print$
[2007/07/26 20:49:15, 1] smbd/service.c:make_connection_snum(693)
  contabilita2 (192.168.1.71) connect to service print$ initially as user sandro (uid=1001, gid=513) (pid 17537)
[2007/07/26 20:49:26, 1] smbd/service.c:close_cnum(890)
  contabilita2 (192.168.1.71) closed connection to service print$
[2007/07/26 20:49:47, 1] smbd/service.c:make_connection_snum(693)
  contabilita2 (192.168.1.71) connect to service print$ initially as user sandro (uid=1001, gid=513) (pid 17537)
[2007/07/26 20:49:48, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2007/07/26 20:49:48, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 17537 (3.0.22)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2007/07/26 20:49:48, 0] lib/fault.c:fault_report(39)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2007/07/26 20:49:48, 0] lib/fault.c:fault_report(40)
  ===============================================================
[2007/07/26 20:49:48, 0] lib/util.c:smb_panic2(1544)
  smb_panic(): calling panic action [/usr/share/samba/panic-action 17537]
[2007/07/26 20:49:48, 0] lib/util.c:smb_panic2(1552)
  smb_panic(): action returned status 0
[2007/07/26 20:49:48, 0] lib/util.c:smb_panic2(1554)
  PANIC: internal error
[2007/07/26 20:49:48, 0] lib/util.c:smb_panic2(1562)
  BACKTRACE: 18 stack frames:
   #0 /usr/sbin/smbd(smb_panic2+0x66) [0x5c1246]
   #1 /usr/sbin/smbd [0x5ae427]
   #2 /lib/libpthread.so.0 [0x2aaaab7ab4d0]
   #3 /usr/sbin/smbd(prs_uint8s+0x170) [0x4d0dd0]
   #4 /usr/sbin/smbd(spoolss_io_r_getprinterdata+0xb2) [0x5638a2]
   #5 /usr/sbin/smbd [0x501f94]
   #6 /usr/sbin/smbd(api_rpcTNP+0x18c) [0x534a3c]
   #7 /usr/sbin/smbd(api_pipe_request+0x1ae) [0x534f7e]
   #8 /usr/sbin/smbd [0x530ec7]
   #9 /usr/sbin/smbd [0x53108e]
   #10 /usr/sbin/smbd [0x45611b]
   #11 /usr/sbin/smbd(reply_trans+0xdac) [0x45716c]
   #12 /usr/sbin/smbd [0x4a110a]
   #13 /usr/sbin/smbd(process_smb+0x190) [0x4a15e0]
   #14 /usr/sbin/smbd(smbd_process+0x1a4) [0x4a2494]
   #15 /usr/sbin/smbd(main+0x7b9) [0x6459c9]
   #16 /lib/libc.so.6(__libc_start_main+0xdb) [0x2aaaac03849b]
   #17 /usr/sbin/smbd [0x44214a]
[2007/07/26 20:49:48, 1] smbd/service.c:make_connection_snum(693)

Revision history for this message
Chuck Short (zulcss) wrote :

Hello,

Which version of samba are you using?

Thanks
chuck

Changed in samba:
status: New → Incomplete
Revision history for this message
Alessandro Bono (a.bono) wrote : Re: [Bug 128612] Re: Segfault in Samba installing a printer on a client

On Fri, 2008-01-18 at 17:27 +0000, Chuck Short wrote:
> Hello,
>
> Which version of samba are you using?

now

ii samba 3.0.22-1ubuntu3.6 a
LanManager-like file and printer server fo
ii samba-common 3.0.22-1ubuntu3.6
Samba common files used by both the server a
ii samba-doc 3.0.22-1ubuntu3.6
Samba documentation

at time of this bug report, I think

3.0.22-1ubuntu3.3

>
> Thanks
> chuck
>
> ** Changed in: samba (Ubuntu)
> Status: New => Incomplete
>
--
Cordiali saluti

Alessandro Bono

Revision history for this message
Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Revision history for this message
Connor Imes (ckimes) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in samba:
status: Incomplete → Invalid
Revision history for this message
Chuck Short (zulcss) wrote :

Alessandro,

This has been fixed recently upstream. I hope to have an debian package for you to test soon.

Thanks
chuck

Changed in samba:
status: Invalid → Confirmed
Revision history for this message
Connor Imes (ckimes) wrote :

Chuck, any updates on this? You mentioned it was fixed upstream so I'm marking this as Fix Committed, but has then made its way into Ubuntu or Debian repositories yet? Thanks in advance.

Changed in samba:
status: Confirmed → Fix Committed
Przemek K. (azrael)
Changed in samba (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers