Ubuntu

File transfer to windows hangs

Reported by Istvan Szekeres on 2007-05-03
6
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Low
Chuck Short

Bug Description

Possibly this is since an upgrade from edgy to feisty, I am not exactly sure.

On my linux host I have a vmware running windows xp as guest. This xp mounts my home folder on the host using samba. It also mounts other samba shares on other linuxes.

In some cases when I try to transfer a file from linux to xp, the file transfer hangs - the destination file on windows is created but absolutely no data is moved (in windows the "Copying" dialog is shown (with the fancy animation going on) but the progess bar remains in the "0" position). After a few minutes windows says "The specified network name is no longer available" and the transfer is aborted.

If meanwhile I strace the smbd process handling this connection, it hangs in this syscall:

myhost:~% sudo strace -p 9846
Process 9846 attached - interrupt to quit
pause()

- Browsing the directories work without problems
- Browsing and transferring files from other samba shares (on other computers) also work
- Transferring the problematic file using smbclient running on the host also works.

Samba version:

ii samba 3.0.24-2ubuntu1 a LanManager-like file and printer server for

Hajo (hajo-hoesel) wrote :

Just to throw in some confirmation: I have the same behaviour with the same samba version on my Gentoo box. It worked 2 or 3 weeks ago, now, after some "emerge --sync && emerge -D world" (== apt-get update && apt-get upgrade) it behaves just like the OP describes.

sperlyjinx (jgbaum) wrote :

I have exactly the same problem. I just upgraded to feisty from edgy and run and xp client under vmware-server. Under dapper & edgy, the samba share worked perfectly, but since upgrading to feisty I have the problem described above. Additionally, it seems that navigating through the samba share is much slower than it was with edgy. I am able to browse windows shares on other machines from my xp guest with no problem, so the issue is with feisty.

Istvan Szekeres (szekeres) wrote :

Not a solution, but...

I configured a host-only networking interface, if I connect to the share using that (and not using the bridged interface), the problem does not appear.

sperlyjinx (jgbaum) wrote :

NAT networking for VMware is also a workaround.

It appears that this issue is specific to XP VMware guest machines that try to access samba shares hosted on a Feisty machine, as I am able to browse these shares and transfer files easily from native XP machines.

I will create a VMware guest linux machine and try to access the shares on my Feisty server to see if the same problem arises. Will post the results later today.

sperlyjinx (jgbaum) wrote :

OK, I booted up into KNOPPIX under VMware (using bridged networking) running on my Feisty machine and was able to connect to the samba shares on Feisty. However, although I was able to transfer a 6MB file from the samba share to the KNOPPIX system, the connection was excruciatingly slow, taking approximately 10 minutes.

Chuck Short (zulcss) wrote :

I think this is a more of a problem with vmware rather than samba.

Regards
chuck

Changed in samba:
assignee: nobody → zulcss
importance: Undecided → Low
status: New → Incomplete
James Clemence (jvc26) wrote :

Interestingly I have been having this problem on Hardy server. This isnt on VMWare this is on an actual box, which although old appears to be working fine. All network processes seem to have issues, falling into some form of hang after a while, but I am posting here because the error declared by the windows box is exactly as above: "The specified network name is no longer available" I am not sure what is causing this, but it certainly doesnt happen on gutsy, only on a test box with hardy on it. Is there any further ideas on what is causing this?

Il

MoiLejter (moilejter) wrote :

I've also seen a problem like this one, on an actual HP notebook running 8.04 and acting as a server: a transfer from an SMB share on the HP to a PC running Windows XP as a client can proceed normally to completion - if it is the only transfer active. If I attempt to start a second transfer while the first one is still in progress, the second one will proceed, and the first one will result in a "the specified network name is no longer available". This used to work just fine on Ubuntu 7.1, and I did a fresh install to get the HP from 7.1 to 8.04, not an upgrade...

Moises

Chuck Short (zulcss) on 2009-11-23
Changed in samba (Ubuntu):
status: Incomplete → Confirmed
Chuck Short (zulcss) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Lucid Lynx. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in samba (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers