Unable to print to HP OfficeJet 5510 shared by Windows XP

Bug #109205 reported by TheReaperD on 2007-04-23
8
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gs-esp

Printing From:
HP Pavilion dv9000t laptop
Intel Core Duo 2 2.0Ghz
1GB of RAM
Intel 802.11a/b/g wireless adapter
Kubuntu Feisty Fawn 7.04 - Release (All packages updated as of 2007-04-22)

Connecting Through: Linksys WRT55AG ver 2.0 Firmware 1.79

Printing To:
Generic Home Build
AMD Athlon 64 3200+
NVIDIA K8N-E Motherboard
1GB of RAM
NVIDIA Ethernet Adapter
HP OfficeJet 5510 all-in-one connected via USB
Windows XP Pro [Yo-Ho edition] - All patches and updates as of 2007-04-22
Using full feature print driver downloaded from http://hp.com

KDE Printer Settings:
OfficeJet_Print
Type: Local printer
State: Idle (accepting jobs)
Location:
Description: HP OfficeJet 5500
URI: ipp://localhost:631/printer/OfficeJet_Print
Device: smb://192.168.42.40/hpoffice_print
Model: HP OfficeJet 5500 Foomatic/hpijs (recommended)

Issue:
After successfully adding the printer in KDE, tried to print a test page. According to KDE, everything was fine. Print job appears in Windows host, printer acknowledges that it is printing, print heads move and then nothing. Copy light (what this printer uses to indicate printing) keeps flashing and "Printing...." is displayed in the printer's LCD screen. Print job still shows in the Windows spooler but, nothing prints.

Steps to get to this point:
1) K -> System Settings -> Printers
2) Add -> Add Printer/Class
3) Next
4) Other printer type (KDE was unable to detect printers over the network. Not surprised as a password is needed to search the Windows shares on my desktop.)
5) At URI Selection entered: smb://[login:passwd]@192.168.42.40/hpoffice_print (Login and password not displayed for obvious reasons. IP address is statically assigned using DHCP on the router, share name is correct on Windows box)
6) Selected Manufacturer: HP
7) Selected Model: OfiiceJet 5500 (Closest model - 5510 not listed) -> No check boxes selected
8) Clicked on "Test" button

Results of clicking "Test" button:
1) Received the message from KDE: "Test page successfully sent to printer. Wait until printing is complete, then click the OK button."
2) Print job appeared in Windows Spooler
3) COPY light started flashing on printer and "Printing..." appeared in LCD screen
4) Print head moved a few times
5) Nothing else happened. Print job remained in spooler, "Printing..." still appeared in printer LCD screen. No error messages from either system.

Windows XP print spooler information:
Document Name: Remote Downlevel Document
Status: Printing
Owner: *Omitted Intentionally*
Pages: N/A
Size: 64.0 KB/3.67 MB
Submitted: 12:54:10 AM 4/23/2007
Port: USB002

Contents of printers.conf: (username and password removed)
# Printer configuration file for CUPS v1.2.8
# Written by cupsd on 2007-04-23 01:54
<Printer OfficeJet_Print>
Info HP OfficeJet 5500
Location
DeviceURI smb://XXXXXXXXXX:XXXXXXXXXXX@192.168.42.40/hpoffice_print
State Idle
StateTime 1177318469
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

Forum and other posts from users about the same topic:
http://ubuntuforums.org/showthread.php?t=414315
http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=218768&start=0

Till Kamppeter (till-kamppeter) wrote :

Have you turned off bi-directional printer access in the printer settings on the Windows machine? Otherwise non-Windows clients cannot print.

Changed in samba:
status: Unconfirmed → Needs Info
TheReaperD (djones) wrote :

Craptacular. Thank you, that did resolve the issue. Sorry for the bandwidth. I read every forum post and FAQ I could find in Google and didn't run across that piece of information. I posted the solution in the forum that I have a login to so the other people interesting will have this information. For anyone needed this information, the URL for the solution:

http://ubuntuforums.org/showthread.php?p=2521809#post2521809

Changed in samba:
status: Needs Info → Rejected
Tsvi Mostovicz (tsvi) wrote :

Thank you for the solution, this solved my problem as well.

Dereck Wonnacott (dereck) wrote :

I am confirming the bug because this issue affects quite a few people it seems including myself. The bug was invalidated after a workaround was found, It is my opinion that we need a solution that is automated or a prompt for users so that they won't need to Google for the solution for themselves.

Changed in samba:
status: Invalid → Confirmed
Chuck Short (zulcss) wrote :

Fiesty Fawn is no longer supported.

Changed in samba (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers