Ubuntu

smbclient fails if server does not support Echo request (eg. Time Capsule)

Reported by Malte S. Stretz on 2012-08-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
samba
Fix Released
Medium
samba (Debian)
Fix Released
Unknown
samba (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

This is the same as bug 445595 which is marked closed: smbclient can't access files shared by Apple's Time Capsule because the server doesn't support the echo request:

stretz@slpn-nb-mss:~$ smbclient //timecapsule/HD1
Enter stretz's password:
Domain=[WORKGROUP] OS=[Apple Base Station] Server=[CIFS 4.32]
smb: \> SMBecho failed. Maybe server has closed the connection

This is also reported in the Samba Bugzilla and marked as fixed over there.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: smbclient 2:3.6.3-2ubuntu2.3
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
BothFailedConnect: Yes
Date: Thu Aug 2 12:21:14 2012
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
NmbdLog:
 Packet send failed to 172.27.8.255(138) ERRNO=Invalid argument
   Packet send failed to 172.27.8.255(138) ERRNO=Invalid argument
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SambaServerRegression: No
SmbConfIncluded: Yes
SmbLog:
 failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
   failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
   failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
   failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
SourcePackage: samba
UpgradeStatus: Upgraded to precise on 2012-04-29 (94 days ago)

Malte S. Stretz (mss) wrote :
Clint Byrum (clint-fewbar) wrote :

looks like this was fixed in samba 3.6.4, and so is fixed in Quantal (3.6.6) but not in precise (3.6.3)

Changed in samba (Ubuntu):
status: New → Fix Released
importance: Undecided → High
Changed in samba (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
Changed in samba (Debian):
status: Unknown → Confirmed
Changed in samba (Debian):
status: Confirmed → Fix Released
Changed in samba:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.