Update to feisty fails with samba installed

Bug #102011 reported by Rick McCarty on 2007-04-02
46
Affects Status Importance Assigned to Milestone
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: samba

I was upgrading to feisty beta from edgy and when it hit the samba package, things failed. The error indicated that perl stack smashing was detected and the "new post install script returned status 134". I was unable to uninstall/reinstall samba to fix things - kept getting the same error.

I finally had to use apt directly to remove samba ("apt-get remove samba") and it updated a whole bunch of unrelated stuff as well (as in it looked like it was reconfiguring the world). Not sure what state the system was in - but I assume that it cleaned up a lot of leftovers from the failed install. I then went into the package manager and did a full upgrade. Seems to have gotten me to a point where (I think) I am actually running a full feisty install. At least the system rebooted (though I didn't have a default display manager configured anymore).

Rick McCarty (mccarty-io) wrote :

I reinstalled samba without errors after getting the feisty upgrade done.

The best thing to do is uninstall samba first and then reinstall to avoid getting the upgrade process totally messed up.

Marco Cimmino (cimmo) wrote :

same here:
2007-04-19 17:51:45,244 ERROR got an error from dpkg for pkg: '/var/cache/apt/archives/samba_3.0.24-2ubuntu1_i386.deb': 'il sottoprocesso nuovo script di post-removal ha restituito un codice di errore 134

with kubuntu feisty 7.04 final

Changed in samba:
status: Unconfirmed → Confirmed
montag (montag-fire) wrote :

Same problem here.
Maybe that bug 107776 is a duplicate of this one? I think so.
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/107776

eldelinux (eldelinux) wrote :

Same problem here.

Reinstall all samba packages without erros but the problem persist.

Marco Cimmino (cimmo) wrote :

I think this bug should have high priority, remember that all people with this package installed will have upgrade failure to Feisty and will have trouble to make it finish.

Thierry Carrez (ttx) wrote :

This was a feisty upgrade bug and apparently it didn't impact later release upgrades. As feisty is now unsupported, I'm closing this as wontfix.

Changed in samba:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers