[SRU] Installation fails with rm: cannot remove '/var/lib/openstack-dashboard/secret-key/.secret_key_store': No such file or directory

Bug #1575635 reported by György Szombathelyi on 2016-04-27
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Ocata
Undecided
Unassigned
Pike
Undecided
Unassigned
Queens
Undecided
Unassigned
Ubuntu on IBM z Systems
Low
Unassigned
sahara-dashboard (Ubuntu)
Undecided
Unassigned
Xenial
Low
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Installing python-sahara-dashboard results in:
 rm: cannot remove '/var/lib/openstack-dashboard/secret-key/.secret_key_store': No such file or directory
openstack-dashboard doesn't create this directory, I think the postinstall script should not do this 'rm'.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sahara-dashboard (Ubuntu):
status: New → Confirmed
sean redmond (sean-redmond1) wrote :

I see this issue also, the work around was to comment out the rm from /var/lib/dpkg/info/python-trove-dashboard.postinst

Frank Heimes (frank-heimes) wrote :

adding an '-f' to rm might be a good solution ...

tags: added: packaging
Changed in sahara-dashboard (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-z-systems:
status: New → Confirmed
Changed in ubuntu-z-systems:
importance: Undecided → Low
no longer affects: ubuntu-z-systems
Changed in sahara-dashboard (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Low
Changed in sahara-dashboard (Ubuntu):
status: Confirmed → Invalid
importance: Low → Undecided
status: Invalid → Fix Released
importance: Undecided → Low
Changed in sahara-dashboard (Ubuntu Artful):
status: New → Fix Released
Changed in sahara-dashboard (Ubuntu Bionic):
importance: Low → Undecided
Changed in ubuntu-z-systems:
status: New → Triaged
Corey Bryant (corey.bryant) wrote :

Ubuntu SRU details:

[Impact]
See bug description.

[Test Case]
Install python-sahara-dashboard.

[Regression Potential]
Very minimal regression potential. This just adds a test to ensure the file exists before deleting it.

[Discussion]

summary: - Installation fails with rm: cannot remove '/var/lib/openstack-dashboard
- /secret-key/.secret_key_store': No such file or directory
+ [SRU] Installation fails with rm: cannot remove '/var/lib/openstack-
+ dashboard/secret-key/.secret_key_store': No such file or directory
Corey Bryant (corey.bryant) wrote :

I've uploaded a patched version of sahara-dashboard package to the xenial review queue where it is awaiting SRU team review: https://launchpad.net/ubuntu/xenial/+queue?queue_state=1&queue_text=

Changed in ubuntu-z-systems:
status: Triaged → In Progress
Changed in ubuntu-z-systems:
importance: Undecided → Low
Brian Murray (brian-murray) wrote :

It'd be helpful if the bug report had information about this being fixed in other releases (Artful and Bionic) rather than just Fix Released tasks. I got the source of sahara-dashboard for Artful and confirmed the fix though.

Changed in sahara-dashboard (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello György, or anyone else affected,

Accepted sahara-dashboard into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sahara-dashboard/4.0.0-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Frank Heimes (frank-heimes) wrote :

Ok, I didn't faced the initially reported problem anymore ...

tags: added: verification-done-xenial
removed: verification-needed-xenial
tags: removed: verification-needed
Corey Bryant (corey.bryant) wrote :

Removed bug task for mitaka cloud archive because sahara-dashboard doesn't exist there.

no longer affects: cloud-archive/mitaka
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sahara-dashboard - 4.0.0-1ubuntu1

---------------
sahara-dashboard (4.0.0-1ubuntu1) xenial; urgency=medium

  * d/python-sahara-dashboard.postinst: Ensure .secret_key_store file
    exists before removing it in post install script (LP: #1575635).

 -- Corey Bryant <email address hidden> Wed, 07 Mar 2018 09:36:46 -0500

Changed in sahara-dashboard (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for sahara-dashboard has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers