Please remove sagemath source and binary from lucid

Bug #510521 reported by Scott Kitterman on 2010-01-21
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
sagemath (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: sagemath

The current sagemath is unbuildable due both to boost1.38 removal and lack of python2.5 as a supported Python in Lucid.

The boost problem is solvable, but the python2.5 one is not (directly build-depending on python2.5 does not help).

This package has never made it into Debian Testing and it does not appear it will be in Squeeze. It should be removed without blacklist in case it does get fixed.

It has no rdepends.

Changed in sagemath (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → lucid-alpha-3
Tim Abbott (tabbott) wrote :

The Python 2.5 issue is also not very hard to address. But making this package a good choice for Lucid would require updating the version of Sage in Debian, which is more work than I (the Debian maintainer) have time for, and I've had little luck finding volunteers to help.

Tim Abbott (tabbott) wrote :

So, to be clear, I support removing sagemath from lucid.

James Westby (james-w) on 2010-02-08
Changed in sagemath (Ubuntu):
status: Confirmed → Fix Released
Donjan Rodic (bryonak) wrote :

The sagemath package in Debian/Ubuntu is at version 3.0.x, which seems quite outdated.
AFAICT the current sagemath version (4.3.5) runs with Python 2.6, but nobody has managed to package a deb yet (which does seem a complex task for this particular project).

A workaround is to download the binary distribution and link it into your PATH.
http://www.sagemath.org/download.html

It's already been removed for Lucid and won't be back until someone can update it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers