sabayon blocks ssh based ltsp logins if not user profiles are created

Bug #38410 reported by Jeffrey Elkner on 2006-04-06
20
Affects Status Importance Assigned to Milestone
Sabayon
Fix Released
Medium
sabayon (Ubuntu)
Medium
Edubuntu Bugsquad

Bug Description

I have an Edubuntu Dapper (flight-6) lab. After "apt-get install sabayon" no one could log-in from the client machines. Log-in directly on the server worked, but not from client machines, so this is appears to effect Edubuntu rather than Ubuntu.

Related branches

Changed in sabayon:
status: Unconfirmed → Confirmed
Jeffrey Elkner (jelkner) wrote :

After creating a profile and adding users to it, they can log-in. However, it seems they need to log-in 3 times before log-in succeeds. No /var/log/messages about failed log-ins. New users must be added to a profile before they can log-in.

Pete Savage (petesavage) on 2006-04-26
Changed in sabayon:
assignee: nobody → ogra
Oliver Grawert (ogra) on 2006-04-26
Changed in sabayon:
assignee: ogra → edubuntu-bugs
Andres Mujica (andres.mujica) wrote :

Not only edubuntu but ubuntu and kubuntu suffer this same error

checking .xsession-errors

there's a message about user xxxxx not in profile

and it cannot start session.

I've got a problem, how can i create a profile if i cannot start a grafical session?

Andres Mujica (andres.mujica) wrote :

i must say it's my personal laptop so there's direclty on the " server"

Oliver Grawert (ogra) wrote :

you should be able to edit profiles with the admin user in any way directly on the ltsp server (many people reported that it works fine that way), else thats another bug that should be filed separately.

I was able to edit profiles. And once profiles were created, users could login, though it took several unsuccessful login attempts first (what I've been calling the "3rd time's a charm bug").

jeff

On Tue, 16 May 2006 10:44:26 -0000, Oliver Grawert <email address hidden> wrote:
>you should be able to edit profiles with the admin user in any way
>directly on the ltsp server (many people reported that it works fine
>that way), else thats another bug that should be filed separately.
>
>--
>Edubuntu clients can't log-in after sabayon is installed.
>https://launchpad.net/bugs/38410
>

Andres Mujica (andres.mujica) wrote :

i've got another machine with the same beahaviou, so i'm going to fill another bug.

Krzysztof Chojnowski (notch) wrote :

Problem still occurs in feisty and gutsy. It is caused by /etc/X11/Xsession.d/60sabayon_apply script. Because of 'set -e' at the beginning of Xsession script any command that won't return true will stop whole Xsession script. /usr/sbin/sabayon-apply returns 1 if the profile is not set for current user causing whole Xsession to stop with an error. As this error is non-fatal this shouldn't happen. As a workaround one can ensure that subject line will return true by adding '|| true' at the end of this line. It should look like:
if [ -x /usr/sbin/sabayon-apply ] ; then
    /usr/sbin/sabayon-apply || true
fi

This can be a bit problematic as all sabayon-apply errors (even fatal) would be thrown away, but I don't have idea how can it be solved differently.

Krzysztof Chojnowski wrote:
> Problem still occurs in feisty and gutsy. It is caused by /etc/X11/Xsession.d/60sabayon_apply script. Because of 'set -e' at the beginning of Xsession script any command that won't return true will stop whole Xsession script. /usr/sbin/sabayon-apply returns 1 if the profile is not set for current user causing whole Xsession to stop with an error. As this error is non-fatal this shouldn't happen. As a workaround one can ensure that subject line will return true by adding '|| true' at the end of this line. It should look like:
> if [ -x /usr/sbin/sabayon-apply ] ; then
> /usr/sbin/sabayon-apply || true
> fi
>
> This can be a bit problematic as all sabayon-apply errors (even fatal)
> would be thrown away, but I don't have idea how can it be solved
> differently.
>

could users be added to a default profile?
something so that when sabayon looks it goes 'oh good, profile', and
keeps going?
kk

Scott Balneaves (sbalneav) wrote :

sabayon (2.19.2-0ubuntu2) gutsy; urgency=low

  * Added an option, -n, --no-profile-error. If set, then no profile existing
    returns a 1, failing the login. Default is unset, returning 0 if no
    profile exists.
    Closes LP: #38410

 -- Scott Balneaves <email address hidden> Fri, 07 Sep 2007 10:05:30 -0500

Changed in sabayon:
status: Confirmed → Fix Released
Oliver Grawert (ogra) wrote :

filed upstream for possible patch inclusion

Changed in sabayon:
status: Unknown → New
Changed in sabayon:
status: New → Fix Released
johnny (johnny-localmomentum) wrote :

this bug has been fixed upstream using another method in revision 899

http://svn.gnome.org/viewvc/sabayon/trunk/admin-tool/sabayon-apply?revision=899&view=markup

Oliver Grawert (ogra) wrote :

right, needs a new upstream version ....

Changed in sabayon:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.