KeyError: dest_name in subcmd_cp_mv

Bug #523586 reported by Martin Pool on 2010-02-18

This bug report will be marked for expiration in 17 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
s3cmd (Ubuntu)
Undecided
Unassigned

Bug Description

% s3cmd mv -v s3://xxx/yyy/\* s3://zzz/

Binary package hint: s3cmd

Problem: KeyError: 'dest_name'
S3cmd: 0.9.9.91

Traceback (most recent call last):
  File "/usr/bin/s3cmd", line 1736, in <module>
    main()
  File "/usr/bin/s3cmd", line 1681, in main
    cmd_func(args)
  File "/usr/bin/s3cmd", line 582, in cmd_mv
    subcmd_cp_mv(args, s3.object_move, "move", "File %(src)s moved to %(dst)s")
  File "/usr/bin/s3cmd", line 568, in subcmd_cp_mv
    dst_uri = S3Uri(item['dest_name'])
KeyError: 'dest_name'

ProblemType: Bug
Architecture: amd64
Date: Thu Feb 18 13:48:37 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
NonfreeKernelModules: nvidia
Package: s3cmd 0.9.9.91-1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SourcePackage: s3cmd
Uname: Linux 2.6.32-13-generic x86_64

Martin Pool (mbp) wrote :
description: updated
Martin Pool (mbp) wrote :

Changing from using the attempted glob to just passing the directory and using --recursive avoided the problem.

Hi Martin, can you please try 1.5.2 from Wily?

feel free to set the status back to new if the problem persists, thanks

Changed in s3cmd (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers